Jump to content

Undoing Phantom Commands


Recommended Posts

CyberAngel

Just now I moved an object. I panned and zoomed to see how it looked. I changed my mind and tried to undo the move. I had to undo dozens of phantom commands (listed as "group of commands") to get back to the move, when I should have had to undo only a couple of real commands.

 

This is not an isolated incident. Looking at my Undo log, there may be no phantom commands for one real command, for another two, for another fifteen. There doesn't seem to be any correlation between the type of command and the number of phantoms.

 

Is this something only Civil 3D does? Do I have a gremlin?

Link to post
Share on other sites

A search of Autodesk community reveals many of the same complaint for Civil 3D 2012 & 2013.

 

From some of the problems described on Autodesk, almost sounds like the mouse software interaction with Civil 3D is the culprit.

 

Are you panning and zooming with the mouse wheel?

Link to post
Share on other sites
CyberAngel
I'm not sure I've seen that. Can you post a screen shot of the command line text history?

 

The command line history wouldn't tell you anything, unless you want to see bunches of Us. The undo history shows commands separated by "Group of command" (see pic). I had just opened that drawing. I used the mouse wheel to scroll in and out a few times but didn't use any commands.

 

Undo.jpg

 

A search of Autodesk community reveals many of the same complaint for Civil 3D 2012 & 2013.

 

From some of the problems described on Autodesk, almost sounds like the mouse software interaction with Civil 3D is the culprit.

 

Are you panning and zooming with the mouse wheel?

 

Yes I am.

 

You have to wonder why using a mouse in Civil 3D is any different from using a mouse in vanilla AutoCAD. Well, we'll have to chalk this up to another "interesting feature" of AutoCAD. Thanks again Autodesk.

Link to post
Share on other sites

I don't know if this will help but have you tried setting the option to "Combine zoom and pan commands" to on? It's on the "User Preferences" tab in options.

Link to post
Share on other sites
CyberAngel
I don't know if this will help but have you tried setting the option to "Combine zoom and pan commands" to on? It's on the "User Preferences" tab in options.

 

I had that turned on. I turned it off, but I still get the phantom commands. Thanks for the advice (not sarcastic this time).

Link to post
Share on other sites
Just now I moved an object. I panned and zoomed to see how it looked. I changed my mind and tried to undo the move. I had to undo dozens of phantom commands (listed as "group of commands") to get back to the move, when I should have had to undo only a couple of real commands.

 

This is not an isolated incident. Looking at my Undo log, there may be no phantom commands for one real command, for another two, for another fifteen. There doesn't seem to be any correlation between the type of command and the number of phantoms.

 

Is this something only Civil 3D does? Do I have a gremlin?

 

I get that problem too. I have Civil 3D 2010 to 2013 installed on my computer and I also run AutoCAD Civil 3D as AutoCAD and the problem persists in both. I haven't heard of a solution for this problem yet.

Link to post
Share on other sites
  • 1 month later...
CyberAngel

A co-worker has the same problem. Are there certain mouses known to have this problem? If so, we'll get new ones that don't.

 

Time-wasters like this are unacceptable. Sometimes it's faster to go back and redraw a line I deleted rather than use the built-in undo function. In other words, it's easier not to use a feature that has been in the package for years without causing any problems. What's wrong with this picture?

Link to post
Share on other sites
SLW210

What brand mouse do you have? I think I recall many mentioning using a Microsoft, not sure about Logitech. Wouldn't hurt to try a cheap no brand with out custom software IMHO.

Link to post
Share on other sites
  • 1 year later...
  • 6 years later...
CyberAngel

I noticed this was still happening. It seems to have started with the 2014 edition and has not been fixed.

 

According to this post, the problem may be associative hatches (???). I tried un-associating all my hatches and it seemed to work, but then I had no associative hatches. I guess the problem becomes, would you waste more time undoing phantom commands or editing hatches and their borders at the same time.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...