Jump to content
bustr

Handles all over the place

Recommended Posts

bustr

Anyone know how to get rid of this garbage in the attached picture? I remember when it was only Ustation that caused this grief. I guess autodesk decided to catch up

ROGUE_GRIPS.jpg

Share this post


Link to post
Share on other sites
Tyke

I've never experienced that in either AutoCAD or MicroStation. How did you achieve that? Can you upload the drawing and give a few more details?

 

The simple answer would be press the escape key a couple of times. But I guess you tried that already.

Share this post


Link to post
Share on other sites
bustr

Here it is. Call it up and hit CTRL-A. All of the flotsam and jetsam will show up. If you use a window it won't show. This junk is invisible but it is there and it slows down the computer.

HANDLES.dwg

Share this post


Link to post
Share on other sites
BlackBox

The blue handles you're having an issue with, are grip handles of the selected entities, which show when you Ctrl+A based on your other system settings.

 

To manipulate this functionality, simply modify the Show Grips setting of the Selection tab, in the Options dialog:

 

ct.options.selection.disable.grips.png

 

 

... Or look into the GRIP* System Variables as needed. :thumbsup:

Share this post


Link to post
Share on other sites
JD Mather
.... I guess autodesk decided to catch up

 

What version of AutoCAD are you using?

I don't see this problem with your file in AutoCAD 2014?

Share this post


Link to post
Share on other sites
nestly
What version of AutoCAD are you using?

I don't see this problem with your file in AutoCAD 2014?

 

Probably because GRIPOBJLIMT is set to something normal, but did you check the number of entities after selecting everything?

 

I'm finding 2.8K + empty block references spread out all over the place. Block Name "AE" accounts for most of them, but 57 named "NEWLAYERSETUP" which probably means something to the OP.

Share this post


Link to post
Share on other sites
rkent

You have blocks that are attributes without any geometry throughout the drawing. Since the attributes don't have a value or a default value and there is no geometry associated with them they don't show. I would block out the geometry that does show and insert in a new drawing.

Share this post


Link to post
Share on other sites
bustr

Thanks for all the help. I'm using AutoCAD 2011. I'm trying to avoid copying my work into a new drawing simply because this happens so often. I was hoping that autocad might have some sort of built in way to fix this.

Share this post


Link to post
Share on other sites
BlackBox
Thanks for all the help. I'm using AutoCAD 2011. I'm trying to avoid copying my work into a new drawing simply because this happens so often. I was hoping that autocad might have some sort of built in way to fix this.

 

No worries; we're happy to help... err... Oh, so you didn't read anything above...?? :facepalm:

 

bth_ImpliedFacepalm.jpg

Share this post


Link to post
Share on other sites
bustr

Yes! I could care less about the grips showing up. My problem is that there presence causes the program to run slow. My cursor doesn't move smoothly but rather jumps making it hard to select anything when the drawing is laden with this junk.

Share this post


Link to post
Share on other sites
ReMark

Maybe that slowness can be attributed to the hardware?

Share this post


Link to post
Share on other sites
BlackBox
Yes! I could care less about the grips showing up. My problem is that there presence causes the program to run slow.

 

What I feel you may not be understanding fully, is that the grips being displayed have a direct result on the performance... Again, as the small 'bubble' information in the image I attached earlier clearly states:

 

... Displaying grips in a drawing significantly affects performance. Clear this option to optimize performance. (GRIPS system variable).

Share this post


Link to post
Share on other sites
rkent
Thanks for all the help. I'm using AutoCAD 2011. I'm trying to avoid copying my work into a new drawing simply because this happens so often. I was hoping that autocad might have some sort of built in way to fix this.

 

So move the stuff you want to keep over out of the way, Ctrl+A, remove the good stuff from the selection set, erase, move the good stuff back, continue.

Share this post


Link to post
Share on other sites
BlackBox
Maybe that slowness can be attributed to the hardware?

 

I suspect this as well, and I run Civil 3D 2011 without any issue.

Share this post


Link to post
Share on other sites
BlackBox
So move the stuff you want to keep over out of the way, Ctrl+A, remove the good stuff from the selection set, erase, move the good stuff back, continue.

 

Drawing maintenance is always a good practice, IMO.

Share this post


Link to post
Share on other sites
ReMark

The OP states "this happens often" so I am inclined to think hardware.

Share this post


Link to post
Share on other sites
nestly

I'm inclined to believe it's a procedure or practice that's causing all these empty blocks to be created in the first place. Deleting them after the fact is not proper solution, figuring out what's causing them to appear is.

Share this post


Link to post
Share on other sites
BlackBox
I'm inclined to believe it's a procedure or practice that's causing all these empty blocks to be created in the first place. Deleting them after the fact is not proper solution, figuring out what's causing them to appear is.

 

I agree with you, but they're not being created on their own... This is a standards/training issue (or something inserted from 3rd party?), and not really something fixed here. So forgive the, what I felt was an, implied task... Yes, right here, right now, deleting them is of benefit to the OP... Admittedly a bandaid, and not a cure for a systemic problem (if that's what this even is?). Just saying.

Share this post


Link to post
Share on other sites
ReMark

It's either S.O.P. or O.I.E. Old MacDonal had a farm, E, I, E, I, O......

Share this post


Link to post
Share on other sites
tzframpton

Ctrl+A will select everything, including these phantom items. Holding Shift+Select everything will deselect all objects and leave the phantom objects selected. Deleting them, and running a PURGE and -PURGE with RegenApps will rid the items.

 

Nestly has the right idea... might need to consider a review of content (Blocks, Customized LISP Routines if any, Templates, etc).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...