Jump to content
run2

Disappering surfaces when saving an AutoCAD 2013-drawing to 2007 and then to SketchUp

Recommended Posts

run2

Hi,

 

I have an urgent problem that I'd be really grateful for some help with. I've built a model in AutoCAD 2013 - which is the software Ihave available - and I need to export it to SketchUp in order to transfer itfurther to yet another program. But I get stuck on just getting it saved in an old enough AutoCAD-version.

 

It all looks fine in AutoCAD 2013, but when I try saving as a 2007-file and then import it in SketchUp almost everything is lost. The model consists of surfaces, and a few that originally were made in AutoCAD 2000 remain, but all the others are considered incompatible and are simply disregarded. On forums concerning SketchUp it is stated that surfaces based on splines are not supported and I guess all my swept surfaces are then not accepted, but how canI convert my model - or the surfaces - to something edible for SketchUp or even the old AutoCAD 2000-version I still have on my old computer? Exactly the same thing happens there, the surfaces that show up in 2000 are the same that show up in SketchUp.

 

I have tried converting to 2007 and 2000, and just save as 2007 and 2000 drawings, I've broken the connection between the lines used to create the surfaces and the surfaces themselves and nothing seem to help.

 

Its a rather large model that has taken me weeks to build and I should have been finished weeks ago, so I'm a bit desperate and I definitely don't want to have to redo the entire project.... :bloodshot:

Share this post


Link to post
Share on other sites
ReMark

Maybe you would have better luck if your model was constructed of solids. Can it be converted in 2013 then saved to 2007 file format?

Share this post


Link to post
Share on other sites
run2

Well, that is about as far as I've gotten so far - that solids are more easily transferred - my only problem is I'll then end up with many more surfaces than I can have in the model - adjacent ones will be double, and as a solid box has at least 6sides where I mean to have one, I'll have to then sit and try to get rid of up to 80 % of the drawing content in SketchUp... A bit annoying, to say the least - I have some little less than 4000 surfaces x 6 to clean up then. What I've done now is I've taken only the lines I used to construct the surfaces and try to import them to SketchUp and then I'm preparing myself for a loooong session of sitting here and recreating each and everyone of the surfaces - doesn't feel quite right, does it? Should be some more sophisticated way of just importing....

Share this post


Link to post
Share on other sites
ReMark

I am very surprised you did not test this all out previously with a much smaller surface model. You just assumed this was going to work? Even the part where you go from a 3D model in AutoCAD to importing to Sketchup and from there into a third program. I'd think you would test that as well. What is the last program anyway and why were you unable to do everything in that program so as to avoid AutoCAD and Sketchup? What is this a model of?

Share this post


Link to post
Share on other sites
run2

Sorry, but that last reply wasn't very constructive, though I get that in the end what you're getting at is finding alternative ways to solve the problem - and possibly trying to point out that I've screwed up. Well, I assure you that I'm very well aware of having screwed up and I've also been trying to find alternative ways of solving the problem, in fact that is one of the reasons for my predicament now: Trying too long to find optional paths and in the end getting too little time left to take the really long road...

 

Now, as a PhD-student I pretty used to moving around on the verge of what is possible, it comes with the territory, and sometimes I end up on the "wrong" side of that line - it just really hurts this time, missing an important deadline. But the causes of my predicament now are two:

 

1. That I assumed that since I've imported geometries from AutoCAD 2000 to SketchUp before, with some minor issues but nothing that couldn't be fixed, it wouldn't be that much of a hassle to do it from AutoCAD 2013. If it didn't work from 2013 directly I'd simply convert to an older version and it would work out. Obviously that assumption was wrong, since it wasn't even possible to get all the information along from one version to the other. So that problem is in the conversion process from one AutoCAD version to another.

 

2. Also, I've almost always worked with solids before, not surfaces without attachment to a solid, and I didn't anticipate that the surfaces would be so much different and simply disappear in the conversion/export/import process - not much to fix or work with afterwards then. The solids could at least be fixed up after the importing. But the weird thing is that even the simplest elements such as lines are disappearing, and just some of them. Some 30% of the lines produced at the same time, in the same layer and in the same group, and not necessarily adjacent ones but some here and some there... No discernable logic to it. Sounds a bit buggy to me, really, just hard to tell exactly where.

 

Could be due to some corruption of the file but as I've said, I have tried taking just parts and place them in new files, and that has not helped. So if something is corrupt with the large AutoCAD model, it is something that comes along even when a small amount of lines are copied from it.

 

So sure, I've tried smaller parts in the process and made tests with all kinds of settings and conversion methods but I saw no reason to not build the whole model in the one of the programs involved that was suited for it, AutoCAD. SketchUp is not really suited for the task though it's possible, and in the third program is more or less impossible - it would literally take months and anyone would go nuts halfways, even less impatient people than me.

Share this post


Link to post
Share on other sites
ReMark

Maybe someone who uses Inventor can pull you out of the hole you have dug for yourself. You would have to provide them with your model though. That's the only alternative I can think of. I don't believe you will find an easy solution using AutoCAD. I hope however for your sake someone comes along and proves me wrong.

 

It was not my intent to point out that you screwed up. You are however a PhD-student so I guess I expected more from you in terms of testing the procedure before jumping in with both feet. I don't see that as being a bad course of action to follow when three different programs are involved to achieve the final product whatever that may be.

Share this post


Link to post
Share on other sites
ReMark

Given the size you say this model is I don't suppose this would work but did you try using the SURFSCUPLT command to derive a solid from your surfaces? I'm guessing if you did it would either have locked up your computer or failed altogether.

 

SURFSCULPT

 

The SURFSCULPT command automatically combines and trims a collection of surfaces that enclose a watertight area to create a solid.

Share this post


Link to post
Share on other sites
RobDraw

I'm not familiar with working with solids and surfaces in AutoCAD but I am all too familiar with files that have not been properly converted to earlier versions of AutoCAD. "Save As" an earlier version can really make a mess of things. Your answer may be in "exporting" your files in a different manner. You may have tried exporting in different ways, it really isn't clear as some people use the terms interchangeably. Sorry if I am stating the obvious...

Share this post


Link to post
Share on other sites
run2

ReMark, I totally agree with you on the wisdom of testing different paths and procedures and making sure they work properly before putting everything at stake and "jump in with both feet" as you put it. And in this case I had carried out a number of tests that didn't work until I ran out of time and reverted to a path I thought I had enough experience of already. So your advice is very sound and it would be the correct scientific method and I tried to rush things when the deadline approached too fast...

 

I too hope that you are wrong about there being no easy solution, but I don't really have much hope that one will show up now - I'll just have to put in a lot of hours in SketchUp to get the model up and running. The bright side of that is that I'll get a lot more experience of working in SketchUp.... :)

Share this post


Link to post
Share on other sites
run2

Thank you Rob, that is a valid remark - at first I just used "save as" and when that didn't work I went on to converting, testing different settings, but I'm not certain that I've found all ways of doing it and maybe it is just the right one I've missed. What method have you have the best experience of?

Share this post


Link to post
Share on other sites
RobDraw

Like I said, I have no experience with solids and surfaces. I would try exporting to a very simple more globally accepted format and if that worked but not quite there then try the more complex formats. Sorry I can't be more specific without doing some extensive research. Maybe if a mod moves this thread to the 3D section of the forum, you will get you better answers.

Share this post


Link to post
Share on other sites
run2

Ok. Thanks Rob! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...