Jump to content
PJ01

Cannot draw line through rectangle

Recommended Posts

PJ01

Hello, I have drawn a rectangle 200 x 100 using the Rectangle button in the Draw panel.

 

I then selected the Line button to draw a horizontal line through the midpoints of both vertical sides. But when I go to select the midpoint on any side to start the line, I end up at the nearest corner point on the rectangle. It will not select a mid point on any of the 4 sides of the triangle

 

Can anyone please advise what I am doing wrong?

Share this post


Link to post
Share on other sites
PJ01

Using AutoCAD 2016

Share this post


Link to post
Share on other sites
Cad64

Do you have 'Midpoint' enabled in your Osnap settings?

Share this post


Link to post
Share on other sites
Cad64

Type OSNAP at the command prompt. This will open up the "Drafting Settings" window.

 

Make sure you're on the "Object Snap" tab and then enable the object snap modes that you want to use, (see image below).

 

Click "OK" and you should be ready to go.

Osnap.jpg

Share this post


Link to post
Share on other sites
PJ01

Many thanks for this very helpful reply, CAD64, much appreciated. Worked perfectly.

 

Strange, in any of the rectangles I have drawn, the SNAP was not switched ON ( F9 key), but after doing as you suggest, it now finds the mid point, even though I am still not using SNAP

Share this post


Link to post
Share on other sites
Cad64

The F9 key toggles Grid Snap mode on and off. The F3 key toggles Osnap mode on and off. Don't confuse Grid Snap with Object Snap. They are two very different things.

 

Function Key Reference: https://knowledge.autodesk.com/support/autocad/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/AutoCAD-Core/files/GUID-ACAA0279-047D-458E-889F-60BBFDD40489-htm.html

Share this post


Link to post
Share on other sites
PJ01
Don't confuse Grid Snap with Object Snap.

As a raw beginner, I was unaware of this. Many thanks Cad64 !

Share this post


Link to post
Share on other sites
CyberAngel

If you only need one snap point (that is, you don't want to keep turning OSNAP on and off), you can type MID for Midpoint etc. You can also use Ctrl-RightClick to bring up a menu of snap options.

Share this post


Link to post
Share on other sites
BIGAL

Using mouse for snaps, Shift+right click

 

A bit down the road you can have different osnaps combinations and quickly jump between them a couple of ways, an easy 1 is set up all your osnaps then type "osmode" a number will appear this is the osnaps settings. Osmode 1 is endpoint only, I use 47 mostly, the other way is to use lisp shortcuts or a menu/toolbar. So I type 47 and my snaps are set.

Share this post


Link to post
Share on other sites
alireza-res

i have same problem , thanks guys for your guidance . i like this forum, we can help each others.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×