Jump to content
Ana

Rectangle command not working as it used to

Recommended Posts

Hi everyone.

Its been 2 days that Ive been driving myself insane.

 

I used to draw a rectangle the following way:

 

- Rectangle command ENTER

- Specify point ENTER

- enter dimensions, ex: 20",30" ENTER

 

Now for some reason, when I do the same steps it draws a HUGE rectangle, covering all the drawing. What happened?

 

I figured out a way to draw it the following way, but its too complicated:

- Rectangle

- Specify point

- D

- 20"

- 30"

- Specify placement

 

Please help! I want my "easy way" back!

Screen Shot 2017-09-30 at 9.51.49 AM.jpg

Share this post


Link to post
Share on other sites

I've always typed in "D" for Dimensions when using the Rectangle command. There are custom lisp routines that operate the way you specified however so I'm wondering if that's what you were using previous to this.

Share this post


Link to post
Share on other sites

Please help! I want my "easy way" back!

 

Click the little "DYN" button at the bottom of your screen. Then you should be able to do it the "easy way".

Share this post


Link to post
Share on other sites

Where do I find this DYN? this is my status bar, shown everything that is turned ON and OFF

 

Thank you for everyone helping me out

Screen Shot 2017-09-30 at 1.42.08 PM.jpg

Share this post


Link to post
Share on other sites

Sorry, I have my buttons set to display as text. I don't like icons. Your icons look very different from mine though, so I don't know which button toggles dynamic input. I'm surprised to see the 2015 interface looks so much different than 2014.

 

You can use the F12 key on your keyboard to toggle Dynamic Input on and off.

Share this post


Link to post
Share on other sites

If you find that your Dynamic Input is already enabled but you're still having this issue, check your settings. Type DSETTINGS at the command line. This will open the Drafting Settings window. Make sure you're on the "Dynamic Input" tab, click the "Settings" button and make sure you have "Relative Coordinates" selected. See below.

Relative.jpg

Share this post


Link to post
Share on other sites
I've always typed in "D" for Dimensions when using the Rectangle command. There are custom lisp routines that operate the way you specified however so I'm wondering if that's what you were using previous to this.

 

Or maybe a custom ribbon or toolbar button. I have always had to do it by hitting "D" for the distance, as well.

Share this post


Link to post
Share on other sites

I didn't even know the "D" option existed before today, with dynamic input it's automatic to input relative sizes after the initial start point (at least I thought it was), and the area and rotation options are a revelation as well.

Share this post


Link to post
Share on other sites

Another way to do it until you find a solution is to use the @ symbol before the relative coordinates, i.e. @20,30.

Share this post


Link to post
Share on other sites

I have DYN on and the D is required if you want a rectangle by the lengths of the sides. I do not see anything in the OPs first thread about using relative coordinates.

Share this post


Link to post
Share on other sites
I do not see anything in the OPs first thread about using relative coordinates.

 

It sounds like he wants to draw the length and width in relation to the first point.

Share this post


Link to post
Share on other sites
It sounds like he wants to draw the length and width in relation to the first point.

Never mind, I got it now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×