Jump to content
Incognito Cube

Ortho Toggle Using F8 While a Command is Active

Recommended Posts

Incognito Cube

Hey y'all, most of you are already aware of this minor issue, but I've just encountered for the first time, so this is more of an exploratory post:

 

My machine was just updated to Win10 from Vista, in which my company has us outfitted with C3D 2014. No debilitating issues thus far, which is unexpected.

 

Before we go into this, I know it's probably nothing more than a compatibility issue with our current GPU and/or the drivers with them, as it's been happening to any other Drafter that they have outfit with Win10 recently.

 

Now, to the issue:

 

Every once in a while (maybe 80% of the drawings I work in), if I have any drawing command active (LINE, ARC, REC, etc.) and I try to toggle Ortho on or off using 'F8' CAD will lock up (no white screen of death, though) until I click out and back into the application window for CAD. I can toggle Ortho on/off before I enter any of the said commands just fine.

 

1. It's not an issue with the keybinding itself.

2. Hardware Acceleration makes no difference on or off.

3. Running CAD in compatibility mode is of no help, and actually guarantees that I get the issue every time instead of just 80% of the time, on top of making CAD sluggish.

 

I'm not looking for the obvious solution to this issue, as so far any solutions I've read are things out of my control (updating drivers, getting a newer version of CAD). However, if there is anything anyone here knows that can alleviate this issue strictly within CAD, I'm all ears :) , but if nothing else I'm just kinda throwing this post into the air

 

At the moment when this issue arises, my current workaround is to try to drill it into my head to know exactly what I need to do before I enter into a command (Which is a good practice to get the hang of.. Slowing down every once in a while lol) and toggling Ortho accordingly. Additionally, while in the command if I need to toggle Ortho I've started holding shift to toggle it that way. I've never done it like that and honestly, I didn't know that was a function. THIS method does not lock up CAD.. Probably something to do with the difference in a temporary toggle and a true toggle. Or something. I don't usually know what I'm talking about :wink:.

 

The point of this is to throw this low-priority issue out here in hopes that MAYBE something has developed since Oct. 2016 (The last date I saw on a breif thread of this issue), but again, this is not breaking my CAD work, and I'm more curious than anything else how others would deal with this, or go about fixing it beyond the obvious software updating.. If there is at all a way.

Share this post


Link to post
Share on other sites
steven-g

Don't know if it the same in Civil but there is one of the icons on the lower right side of the Autocad window that toggles ortho, in amongst the annotation scale and snap settings icons (at least there is if it's turned on)

Share this post


Link to post
Share on other sites
Incognito Cube

Nothing in the lower right, however there is the button toggle on the lower left between POLAR and GRID, if that's what you're referring to. I forgot to mention in the OP that clicking that toggle instead of using F8 while in an active draw command does in fact work. But such as the original issue, it's more of an annoyance than anything else.

 

[EDIT: I say that due to the face that I'm more of a keyboard and mouse type of guy. It's rare that I need to use buttons]

 

[EDIT 2: Keyboard command type of guy* obviously the mouse too lol. Slipped that in there by muscle memory of typing it]

Edited by Incognito Cube

Share this post


Link to post
Share on other sites
BIGAL

Ortho is controlled also from Orthomode setting 0 or 1 maybe a lisp defun

(defun c:88 () (setvar 'orthomode 1))
(defun c:89 () (setvar 'orthomode 0))

 

Do this uses the ability to call transparent commands within a command turns ortrho on and off in the line command.

Line pick a couple of points
'88 pick points '89 pick points

Share this post


Link to post
Share on other sites
Dadgad

For a Temporaty Toggle, just hold down SHIFT.

 

Sorry about that, I was busy, and late to the party, hadn't read the entire thread, or obviously I wouldn't have felt the need to suggest the way you are already doing it! :oops: :beer:

Edited by Dadgad

Share this post


Link to post
Share on other sites
SLW210

I never use ORTHO, Polar is a much better tool.

Share this post


Link to post
Share on other sites
SLW210

As a side note, AutoCAD 2014, or any vertical, was not created to run on Windows 10, so whoever is in charge of having those computers upgraded to Windows 10 should have been prepared to research loading the correct drivers, etc. or correct any problems that arise from using older software on a newer OS or be prepared to upgrade the software.

Share this post


Link to post
Share on other sites
Incognito Cube

Dadgad:

Additionally, while in the command if I need to toggle Ortho I've started holding shift to toggle it that way. I've never done it like that and honestly, I didn't know that was a function.

 

Yeah, I learned this nifty little function earlier yesterday :wink:

 

I never use ORTHO, Polar is a much better tool.

 

Most do seem to prefer Ortho, I've noticed. However for the creation of Plats, I rarely need to lock my drafting to any angle other than 90d

 

 

As a side note, AutoCAD 2014, or any vertical, was not created to run on Windows 10, so whoever is in charge of having those computers upgraded to Windows 10 should have been prepared to research loading the correct drivers, etc. or correct any problems that arise from using older software on a newer OS or be prepared to upgrade the software.

 

That's what I've been noticing. As of 30 minutes or go this morning, I have yet to be able to open CAD. Exactly the same issue as http://www.cadtutor.net/forum/showthread.php?102528-auto-cad-stopped-loading&p=695946#post695946 with the only negligible difference being in CAD versions. (mine 14, theirs 15). So... This aughtta be a fun day.

 

I'll update with what happens :itsover:

Share this post


Link to post
Share on other sites
Incognito Cube

Update: We did a repair of CAD. Loaded up & Works fine... For now.. :danger:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×