Jump to content
jesterminute

AUTOCAD XREFs ARE ATTACHING XREFS IN THAT DRAWING!

Recommended Posts

jesterminute

Hi,

 

When I add an xref, let's say floor plans, to my drawing the xref brings in the xrefs in that drawing to my new drawing. I do not want this; nobody wants this. I want to just bring in the floor plans, not the drawings that I attached to the plans.

 

 

So how do I just bring in just the actual drawing? I hope that makes sense. Hard to explain because there are drawings within drawings.

 

It is driving me insane.

Share this post


Link to post
Share on other sites
Dadgad

Each drawing should be an Xref, in its own right.

Are the attached items you don't want to bring in Xrefs or blocks?

Any drawing which you XREF into another drawing brings everything with it, that is how it is meant to work.

 

I suggest you Google and watch a video or two about Xrefs.

Share this post


Link to post
Share on other sites
SLW210

I have moved your thread to the AutoCAD Drawing Management & Output Forum.

 

In the drawing you want to xref into your drawing, change the xref type of those other xrefs in that drawing to OVERLAY I believe is how you do that, been a while since I have messed around with unnecessary nested xrefs.

 

As mentioned by Dadgad, look up all the related information on xrefs, a lot out there.

Share this post


Link to post
Share on other sites
rkmcswain

In your floor plan drawing - change the Xref type to OVERLAY (instead of ATTACH).

 

See illustration here:

 

yHZFP2p.png

Share this post


Link to post
Share on other sites
BIGAL

The only way around may be to change the tree structure looking at rkmcswain example un xref B C from A then you can xref say only A & B. Like wise though create dwg D which is xref A B C if required.

Share this post


Link to post
Share on other sites
Alfamano

You have a drawing that has Xref let us say X, you want to make X an Xref to another drawing let us say Y, after you want to attach X to Y without attaching the other Xref to Y, well i guess you can't do so, unless someone solved your problem please share it with us

Thanks

 

Sent from my SM-N9005 using Tapatalk

Share this post


Link to post
Share on other sites
lukaskupasz

When Xref a file onto the current file shows differents in elevation;but the value of elevation shows “0” for both current file elements & xref. both files BASE(0,0,0) & Units are same.

Pls any one know how to solve it?

Share this post


Link to post
Share on other sites
Aftertouch

Look into the ATTACH and OVERLAY button when attaching XREFS.

 

@ LUKASKUPASZ: The XREF is located at 0,0,0, so the content will be on the right elevation.

If you move the elevation off the XREF, it'll add up to the actual elevations in the DWG..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...