Jump to content
Silvercloak

Cleaning a drawing

Recommended Posts

Silvercloak

Hey all,

 

   I've started at a new company recently and there's something in their template drawing that I can't figure out.  To make a long story short, no matter how much I audit it still has corruption issues, no amount of purging, deleting or whatnot creates a blank clean drawing.  Sometimes I DXFOUT 2D files for xrefs or transmittal.  I can't do that here because the audit never completely works.  I'm absolutely stumped as to what else to do.

Will attach the drawing if any of you are interested in taking a look and offering your suggestions.

 

Silvercloak

blank.dwg

Share this post


Link to post
Share on other sites
BIGAL

Ok sounds like best thing is make a new CIV3D template, so you need a clean dwt to start with like acadiso.dwt that's for metric.There are some definitely for CIV3D I use a custom one.

 

You will also need to bring in all blocks I would use Lee-mac.com Steal.lsp as it allows a get all blocks. Then do "importstyles" this will bring in your CIV3d styles from your dwg. You may need to also bring in any custom line types and standard linetypes. 

 

I had a look at your dwg and it only has 3 description keys very odd mine has 200+ and does not appear to have any blocks. Not sure how you get it to work at all.

Edited by BIGAL

Share this post


Link to post
Share on other sites
Silvercloak

Thanks!  I'll give that a try when I get back into the office.

Share this post


Link to post
Share on other sites
tombu

Like BIGAL implied a template drawing with 3 description keys and no blocks would be useless for Survey/Civil work. Like BIGAL we use quite a few description keys grouped into various key sets, I've got two just for trees. The Civil 3D description key set in your blank.dwg is simply from the default Qnew template installed  with Civil 3D. I still have that Civil 3D description key set in my Qnew template along with others of course. It took quite some time for me to get Civil 3D functional for our office after switching over from Eagle Point software. Still modifying it and adding codes, just last week I added a code for a satellite dish as the crew located one in a drainage easement for the first time.

 

Not knowing how much Civil 3D experience you have I'd suggest using standard templates, styles and procedures created by others you may do work for or have worked for in the past. Florida's FDOT requires consultants to use their downloadable templates, styles, code, CUI and procedures and provide help and tutorials as well as an example. We use consultants and having one whose work was easier to integrate with ours would be fantastic. Otherwise there's plenty here that would be willing to help you get started.  

Share this post


Link to post
Share on other sites
Silvercloak

Oh this isn't our standard template in full.  This is what I'm left with after I've purged everything and deleted every layer.  Shockingly there's dozens of items that are unpurgable and audit constantly pops errors.

 

There's something deeply wrong with the template   At least that's what i think.

Share this post


Link to post
Share on other sites
tombu

Purging Civil 3D templates can cause issues. All the layers in the installed templates are referenced to point blocks, feature lines, or intelligent objects. While the number of layers may seem difficult to work with having a handful of filters in those templates like NCS, No Nodes, No NCS, and Topo reduces the layers displayed for current tasks to a reasonable amount.

 

Share this post


Link to post
Share on other sites
Silvercloak

I think you misunderstood.  I'm trying to basically create a 2D Transmittal drawing by purging everything, auditing it, and turning it into a DXF.  I noticed that no matter how much I audit one of our drawings it's never clean of errors.  Which prevents me from turning it into a DXF.

 

I opened a blank drawing and purged the heck out of it, audited it (as useless as THAT was) and attempted to DXFOUT it and that predictably failed.  If even a blank drawing is corrupt, then there's obviously an issue.

 

I attempted to use the DWT that comes with Civil3d and auditing is bringing up errors.  Leading me to wonder if it's in fact the profile that my company is running our copies of civil3d under.  I'm not sure.  I'm just really concerned that there are objects still in the drawing after being purged and audited, and errors remain.  I'm worried that somewhere down the line we're going to have a project that goes fubar because SOMETHING is causing some kind of drawing corruption here.

 

Silvercloak

Share this post


Link to post
Share on other sites
BIGAL

-purge will go deeper choose all.

 

If your getting errors with the default out of box dwt some one has re saved it. Which template did you start with I have 2016 so do others can send to you and it will be clean.

 

You say your getting errors what are they ?

 

Another way around this is use exporttoautocad convert surface triangulation to 3d faces then use wblock make sure you say No to "Include Map" this will make a new dwg and it does not have the CIV3d stuff make your DXF from this dwg. We use this method when sending field surveys to a 3rd party.

Edited by BIGAL

Share this post


Link to post
Share on other sites
Silvercloak

Sorry fighting a wicked cold.  When I get all my brain cells back together I'll pursue this again and try your suggestions.

Share this post


Link to post
Share on other sites
Silvercloak
On 1/20/2020 at 3:42 PM, BIGAL said:

-purge will go deeper choose all.

 

If your getting errors with the default out of box dwt some one has re saved it. Which template did you start with I have 2016 so do others can send to you and it will be clean.

 

You say your getting errors what are they ?

 

Another way around this is use exporttoautocad convert surface triangulation to 3d faces then use wblock make sure you say No to "Include Map" this will make a new dwg and it does not have the CIV3d stuff make your DXF from this dwg. We use this method when sending field surveys to a 3rd party.

 

I can't even make a DXF from a blank drawing template.  The template I have on my hard drive is the one that comes packaged with Civil3d.  According to my drafting manager, these errors just started happening after they switched to 2018.

 

I've even tried to unload all the startup suite apps, I've switched to the original Cad profile.   Nothing.  Still getting audit errors up the wazoo and can't DXFOUT.  I don't know WHAT is causing the issue or how to fix it and google-fu finds nothing.

 

Silvercloak

Share this post


Link to post
Share on other sites
BIGAL

Open the original dwt that came with CIV3d.

 

image.thumb.png.239ac130da681fcbf98958a0a54145d7.png

Edited by BIGAL

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...