Jump to content

Can't join 3D polylines (I've tried every suggestion I could find)


Recommended Posts

I've been given a design file for a terrace which consists of thousands of individual lines and polylines which I would like to merge into continuous 3D polylines (They need to remain 3D).


They appear end to end, I've tried all the tips I could find (including mapclean in civil3D) and nothing is working for me. The only thing that I've noticed is that the elevations seem a bit funky in the properties dialog when you click on some of the lines (ID inspect and 3D view looks fine).


I was wondering if anyone could have a look and potentially help me out with what I'm doing wrong.


Any help would be appreciated, cheers. 

Terrace Example.dwg

Link to comment
Share on other sites

4 minutes ago, BIGAL said:

I just typed "Join" and appeared to work.

Hi Bigal,


So you're telling me when you select all the lines and run the join command you end up with 12 polylines? The best I get is the bottom alignment being partially complete. Most of the lines don't join at all.

Link to comment
Share on other sites

I used Bricscad and just did Join and selected all line work. There is a fuzz setting mine may be different will try to find it.


"PEDIT command>Multiple>select entities>Join>Fuzz Factor.... HELP explains
the PEDIT command structure, you can review it for tips and ideas."




  • Like 1
Link to comment
Share on other sites

Same here, 'Join', select all, and they all join.


What version of CAD are you running and are there any error messages? I am on 2022, all good.

Link to comment
Share on other sites

How are you selecting the 3D Plines?


They all join here. I first did the JOIN>ALL>Enter, then I used a left-to-right window to select them all, then I used a right-to-left window to select them all, I ended up with 12 3D Plines all methods.

Terrace Example SLW210.dwg

Link to comment
Share on other sites

I appreciate the help guys. I'm running Autocad 2022 and Civil 3D and had the same issue on both. I had a random breakthrough where it randomly worked yesterday (I didn't do anything different, just selected everything and ran JOIN). I've tried to do it again now and it doesn't work. PEDIT doesn't give me the option to join when I select them all either. Not sure what the root cause of the issue is.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...