PDA

View Full Version : Text Rotating 270' every time I edit??!!!



NeilGTi85
31st Jul 2008, 10:34 am
Hello all,

Ive got a problem with a drawing from a client and the text is in multi-line format and is currently at the correct angle, however, when I go to edit the text is rotate's it's self round 270 deg....

Any idea's?

Cheers All,

Neil

Dipali
31st Jul 2008, 10:49 am
looks like the current ucs in which drawing is done is not the world ucs. you can check it out by making ucsfollow-1 & than ucs>enter>entr

NeilGTi85
31st Jul 2008, 11:10 am
I have tried that and it does not work.

There is something forcing the text to rotate, any more idea's? :)

Cheers

Neil

ReMark
31st Jul 2008, 11:22 am
What are the parameters for your default text style?

NeilGTi85
31st Jul 2008, 11:44 am
The paramerters are all ok untill i go to edit the text, then it rotates.

I have found though by changing the text style it does not rotate??

Neil

ReMark
31st Jul 2008, 11:46 am
Interesting. Any reason the client would have to set their style to be rotated in the first place?

NeilGTi85
31st Jul 2008, 11:50 am
Not that I can see....Once you first open the drawing all text is ok....but as soon as you edit the text (double click on it) it rotates 270'

Neil

NeilGTi85
4th Aug 2008, 01:06 pm
Interesting. Any reason the client would have to set their style to be rotated in the first place?

Do you know how to change the paramter of the text.....there must be some way to stop this as I have 50+ drawings to do!!!

Cheers

Neil :)

ReMark
4th Aug 2008, 02:59 pm
I'd check the Text Style dialog box. Look under Effects > Oblique Angle. Is it set to something other than "0" for the particular text style your client provided? If so, change it there.

rustysilo
4th Aug 2008, 03:03 pm
Sounds like your dview is twisted. I think there is a variable that controls whether it rotates to 0 when you edit, but I don't know for sure.

smorales02
4th Aug 2008, 03:58 pm
Not that I can see....Once you first open the drawing all text is ok....but as soon as you edit the text (double click on it) it rotates 270'

Neil


Have you actually edited it or just double clicked on it and than hit escape cause it rotates?

NeilGTi85
5th Aug 2008, 10:52 am
Have you actually edited it or just double clicked on it and than hit escape cause it rotates?

The text is mtext, when you open the drawing all text is correctly rotated, as soon as you double click on it it rotate's 270', you then retype the text and return and it is rotated 270'!!

I have found that when I change the text from standard to aerial for instance it will re-rotate back to normall!

I can not find anything to do with Dview....will keep searching

The Oblique angle is correct at 0

Cheers, will get there in the end :)

Neil

edit - I am using AutoCAD LT 2008

ReMark
5th Aug 2008, 10:54 am
Have you called the client about this and asked them what they did?

NeilGTi85
5th Aug 2008, 11:01 am
Have you called the client about this and asked them what they did?

Its not the sort of client I want to tell that 'I cant...'

Maybe once Ive finished the job doing it the manual way I will ask but untill then....lol

Cheers

Neil

ReMark
5th Aug 2008, 11:10 am
"Its not the sort of client I want to tell that 'I cant...'"

Then turn it around. Tell them how much you like what they did and ask if they would share the secret of how they accomplished it.

NeilGTi85
5th Aug 2008, 11:23 am
"Its not the sort of client I want to tell that 'I cant...'"

Then turn it around. Tell them how much you like what they did and ask if they would share the secret of how they accomplished it.

I have tried to contact them i min ago and its not possible to take to the drawing contracter who made the drawing for some unkown reason.....dont ask....must be a matter of 'national security'??!!

Right another clue :)

When I edit the text and it rotates 270', when I go to the properties menu for the text, the rotation is at 270' so when I change this back to 0 the text rotate's. BUT when I the edit the text it roates as im editing it then when i hit enter it goes back to 0.......

The the standard font style is automaticly roating 270'.....there must be an option for the text somewhere...

Cheers

Neil

ReMark
5th Aug 2008, 11:35 am
Jeez, I would have thought by now we had put this topic to bed.

Would it be a violation of your contract to email the drawing to a third party? It doesn't have to be the entire drawing.

NeilGTi85
5th Aug 2008, 11:39 am
Jeez, I would have thought by now we had put this topic to bed.

Would it be a violation of your contract to email the drawing to a third party? It doesn't have to be the entire drawing.

It would defently be a violation....leading to prosercution...:shock:

It is something I have never come accross in 5 years of using all sorts of cad program's...there must be some sort of way to see the paramerters of the text??

Neil

NeilGTi85
5th Aug 2008, 11:41 am
It has now started doing the same thing when i open a new drawing....the text has been changed to standard instead of aerial......it has change the defualt text somehow on the program!!

ReMark
5th Aug 2008, 12:06 pm
Now it affects new drawings as well? That's very odd indeed.

Would you still be violating your contract if you erased all the linework and saved an "empty" drawing? As long as you do not change any of the parameters regarding text someone else could still tinker with it.

NeilGTi85
5th Aug 2008, 12:58 pm
Now it affects new drawings as well? That's very odd indeed.

Would you still be violating your contract if you erased all the linework and saved an "empty" drawing? As long as you do not change any of the parameters regarding text someone else could still tinker with it.

I could send a new blank drawing.....who wants to take alook? :lol:

Cheers

Neil

NeilGTi85
5th Aug 2008, 02:15 pm
I have just found that instead of double clicking the mtext to edit it, if i go to modify - object - text.....it does not rotate!! :unsure:

Whats going on?? It must be something to do with double clicking Mtext

Neil

foxbyrd31
29th May 2009, 03:12 am
Did you ever figure out what was causing this? I just recently got AutoCAD2008 Educational Edition for my laptop and it is doing the same thing to me. I have used it previously, but this is the first time I am setting up a whole new drawing, and thereby going in and making all the option settings that I have when I use regular AutoCAD 2008 on the non-laptop.
I will use your fix for now, but this could get annoying!

Signs
30th May 2009, 01:55 am
If all else fails, maybe try contacting Autodesk for help? But I noticed this thread is very old so you probably have the assignment done by now.

I'm wondering why foxbyrd bumped this 9 month old thread lol.

Good luck.

Car5858
30th May 2009, 02:33 am
I also had this problem with the text when I first installed the AutoCad 2008 in sept of 08.

I ended up deleating the profile's, repairing the installation with the add remove programs.

Options menu then re-created a new profile. This worked for me not sure what was causing the problem. I alos had other issues and this solved them also. So for me it was a case of EUS.:oops:

NeilGTi85
20th Jul 2009, 01:14 pm
Just to bump this thread agian!

I am still having the same trouble, no breakthrough's on how to stop it.

It looks like a new profile set-up is required....

Neil

NeilGTi85
20th Jul 2009, 01:21 pm
Breakthrough....only after 10 mins of posting ^^^^^

From Lynn Allen's Blog:

"
Last week at Disney one of the attendees asked me if there was a way to get the old MTEXT editor back and I drew a blank...I knew it was possible but couldn't remember the system variable. I dusted off my brain and remembered it is the new MTEXTED setvar. Some of you don't like the newfangled in place editor and long for the old days of the slightly prinmitive MTEXT Editor. Now those of you in AutoCAD 2006 should definitely listen up...especially if you have lots of rotated text and are tired of standing on your head! The old editor would whip that text back around for you, so it was back to that 0 degree angle for easy editing (and fewer headaches).
Set the system variable MTEXTED to "oldeditor". Yes that's right - you heard me. This will tell AutoCAD to use the old MTEXT editor. To put it back you'll need to set MTEXTED to "internal".
AutoCAD 2007 updated the in-place-text editor such that if the text is too small or rotated it will blow the text up to a decent height and rotate it for easy viewing while you edit. So most of you won't need to touch the MTEXTED command anymore. If you don't like the fact that the in-place editor does this new feature (I love it incidentally), you can put it back (but why?). The MTEXTFIXED system variable controls the behavior as seen below:
MTEXTFIXED (when MTEXTED is set to "internal") when set to 0 or 1 will leave the text as is - won't enlarge it or rotate it for easy viewing.
MTEXTFIXED when set to 2 enlarges super small text for viewing and rotates it if necessary.

Hope this helps some people!

Neil

ReMark
21st Jul 2009, 11:40 am
Thank you Neil for updating us on your problem and sharing the "fix" as suggested by Lynn Allen.

Xav1er
25th Sep 2013, 11:21 am
Set the system variable MTEXTED to "oldeditor" Neil

Thanks a lot !!!
in French i say : Merci Beaucoup !
--> comment éviter que le texte tourne de 270° à chaque fois que je l'édite / mettre la variable MTEXTED = "oldeditor"