PDA

View Full Version : Drawing disappeared after saving it in block editor



factor
18th Apr 2011, 01:47 pm
Hello everyone,
can somebody help me with this issue:
I was working on my drawing, using blocks: open block editor, edit block, close editor by clicking cross of closing block editor, then autocad asks me if I want to save changes, I click yes. And one time I clicked the smaller cross, which closes the whole drawing, and intuitionally clicked to save it. So my whole drawing closed. And when I open it, Autocad asks me : "filename.dwg contains authoring elements. Open it in Block Etidor?" yes/no/cancel. If I press Yes, then my drawing opens in block edit mode, and when I click close block editor the whole drawing closes. If I press no, then my drawing opens in normal mode, and I have in it just lines of that block. All layers, titleblocks are there, but my drawing disappeared. Is there any chance to get it back? how? I can't attach this drawing, because it's to large, ~4,7 mb... but I can send it to email, if someone would like to help me.

dbroada
18th Apr 2011, 02:44 pm
this is probably because you have included some parameters, or at least AutoCAD thinks you have. Start a new drawing and then INSERT your problem drawing in to it. This should give you access to the block using the block editor.

factor
18th Apr 2011, 04:35 pm
Hi, thanks for your answer.
Maybe because of my bad English, you didn't understand the problem ;]
The problem is that I saved my drawing while editing it's block in block editor. So my drawing became a block, therefore autocad offers me to open it in block editor. If I open it as normal drawing (not in block editor mode), then I have that block, all layer and titleblocks that I had before, but don't have my drawing. But the size of the file is still big, and I can see small representation of my drawing when I switch between layouts (that small icons of layouts) but when I click on the layout to choose, it opens empty, only with titleblocks and that block, which I was editing when save everything... sorry for my bad English :oops:

ReMark
18th Apr 2011, 05:02 pm
Dave: This is the second time I've heard of this happening.

dbroada
19th Apr 2011, 09:39 am
Mark, when I saw that you had commented I thought, good - somebody knows.

Sorryfactor, I'm not quite sure what you are saying but that is as much because I don't use layouts as anything. Is it possible that your drawing become very small and you just can't see it. Try erasing the border and then zoom extents.

Or wait for somebody more knowledgable to come along.

Organic
19th Apr 2011, 09:53 am
................................

JFK
25th May 2011, 05:47 am
http://www.cadtutor.net/forum/images/icons/icon8.gif I know your pain!


I have just had the exact same experience with autocad 2012LT. ARGHHHHHHH!

I was editing a block and walked away from my machine, came back and saved and closed the file without closing the block editor. I reopened the file and it opened up inside the block itself, not the whole model. Now I can't get out of the block!

I tried inserting the file into a new one and nothing came through apart from the bock so that is that unless someone else can offer insight.

The nasty thing is that as the drawing saved and closed my temp file disappeared at the same time! The previous file version was overwritten at the same time too.

I have yesterdays back up, which is nice but not particularly useful with a tender to get out tomorrow and consultants waiting on the drawings... now 6 hours delayed. Presumably this is one of those things early adopters get to enjoy.... whinge over.

jfk

Organic
25th May 2011, 06:30 am
I wasn't able to reproduce it fully. I did find that if I created a new drawing, created a new block in that drawing and opened it in the block editor, then closed the program it didn't ask to save/discard the block changes and simply tried to close the program. This resulted in a access violation error and the program crashed. When I tried to open that file again though it opened normally (and not in the block editor).

Can you upload the file here?

JFK
25th May 2011, 07:13 am
file upload attached. Interestingly i have been stripping data from the file - blocks of windows etc which i updated today without drama, I just cannot get out of the last block being edited when I closed the file. It's bloody weird. The file also appears to be about the right file size so presumably all the file is in there somewhere.

Fun and games.

JFK
25th May 2011, 07:20 am
i can not upload the file as the size is 1.6mb and the limit for uploads on my account is 250kb

JFK
25th May 2011, 07:35 am
I just emailed the file.
I can also repeat the fail, try this:

1. open an existing file with blocks in it and other geometry.
2. double click a block to open the block editor
3. make some changes
4. click the close drawing option in stead of the close block editor option
5. follow prompts to save file.

Now when you reopen the file you will be stuck in the block you were editing when the file was closed.

interestingly:
If you audit the file there should be plenty of errors detected but the original model space does not come back.
if you open the block editor you can repeat the process again.....weirD

jfk

Organic
25th May 2011, 08:09 am
I received your email and see the problem.

I was also able to reproduce your problem using the above conditions (previously I was trying a blank new file, not one with existing blocks/geometry in it). Auditing my file didn't find any errors either.

I don't know of any solution. I don't think the drawing is opening in the block editor when you reopen the file (rather it is opening in the normal drawing mode correctly). It looks like the block you had open in the block editor at the time of closing the program is saved as the drawing model space and the existing model space is overwritten/deleted. The other blocks are still defined, although if you purge the drawing you will find there are no instances of them in the drawing. Thus, unless someone else has an idea, I think you have to go to yesterdays file. This seems like a nasty bug in 2012 which should be fixed when the first service pack is released.

Edit: Seems to have been reported back in 2006 also; http://www.cadtutor.net/forum/showthread.php?7834-Block-Editor-bug
I tried to recreate it in 2010 and it didn't occur (model loaded up fine afterwards)

williams1
8th Jan 2013, 03:55 pm
Hi, I've just now had a similar problem. After use f. BLOCK EDITOR (via right mouse click), and I used an external f. FIXBLOCK, then save and close the editing block and block disappeared, is lost. Through f. FILTER him sort out, but the only shining point of reference, nothing more.
I read this forum and ingested f. AUDIT has been found and corrected a lot of mistakes. Block appeared. Everything works.
Thank you for your kind.

Organic
8th Jan 2013, 10:03 pm
Thanks for posting that Williamss1 :)

CyberAngel
8th Jan 2013, 11:19 pm
This same thing happened to me several years ago. The cause is using Undo while in block editor. The workaround is, if you have to undo something in block editor, don't--just exit without saving or make the change yourself. Also save often while editing blocks.

I don't know how to get the main drawing back.

toldo
2nd May 2013, 03:04 pm
I just used drawing utilities to recover me file, had the same problem, the only thing is it's read only

SLW210
2nd May 2013, 03:54 pm
Known problem for 2012 versions.

See my post HERE (http://www.cadtutor.net/forum/showthread.php?79043-Problem-in-block-saving).

Preisner
27th Oct 2014, 01:05 pm
Hi all

Sorry for update this old post, but today I had the same problem and finally I could solve it.

After search the web looking how to solve the problem, I found this post and wanted to explain how I could solve for the next colleague who happens the same issue. I work with AutoCAD 2014 Mechanical.

When I open the dwg "damaged", I can only see the block I was editing, but all the blocks are yet in the drawing, so I started to insert again the blocks one by one and, inside the block I was editing when press "Save" there was the whole drawing! :)

So if you have the same problem, just search between the existing blocks and your work will be in one of them!


Cheers!



Hello everyone,
can somebody help me with this issue:
I was working on my drawing, using blocks: open block editor, edit block, close editor by clicking cross of closing block editor, then autocad asks me if I want to save changes, I click yes. And one time I clicked the smaller cross, which closes the whole drawing, and intuitionally clicked to save it. So my whole drawing closed. And when I open it, Autocad asks me : "filename.dwg contains authoring elements. Open it in Block Etidor?" yes/no/cancel. If I press Yes, then my drawing opens in block edit mode, and when I click close block editor the whole drawing closes. If I press no, then my drawing opens in normal mode, and I have in it just lines of that block. All layers, titleblocks are there, but my drawing disappeared. Is there any chance to get it back? how? I can't attach this drawing, because it's to large, ~4,7 mb... but I can send it to email, if someone would like to help me.

ReMark
27th Oct 2014, 01:23 pm
Your whole drawing was inside of a block? How do you suppose that happened?

SLW210
27th Oct 2014, 03:08 pm
Sounds like the bug may have returned.

Did you notify Autodesk? If not you should.