+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Super Member
    Using
    AutoCAD 2010
    Join Date
    Dec 2010
    Posts
    1,170

    Default Turn off Xref snapping

    Registered forum members do not see this ad.

    hi

    i have very lazzy xref that i want to redraw,
    is there a way to turn off snapping to that xref? its dwg

    Thanks
    S

  2. #2
    Luminous Being RobDraw's Avatar
    Using
    MEP 2017
    Join Date
    Apr 2007
    Location
    Connecticut, USA
    Posts
    5,165

    Default

    Not without turning off OSnaps entirely.
    Drafting is a breeze.

  3. #3
    Forum Deity Dana W's Avatar
    Computer Details
    Dana W's Computer Details
    Operating System:
    Windows 8 64 bit
    Computer:
    Dell XPS ONE 2710
    Motherboard:
    Dunno
    CPU:
    Intel I-5 3330S @ 2.7 Ghz
    RAM:
    6 Gb
    Graphics:
    On board barely adequate
    Primary Storage:
    1 Terrabyte
    Secondary Storage:
    1 Terrabyte external
    Monitor:
    All in one 27" touch & pen
    Discipline
    Construction
    Dana W's Discipline Details
    Occupation
    Architectural Millwork Designer/Draftsman
    Discipline
    Construction
    Details
    Custom commercial millwork.
    Using
    AutoCAD LT 2018
    Join Date
    Feb 2010
    Location
    Oviedo, Florida
    Posts
    4,703

    Default

    If you have a command active F3 suppresses object snaps. It's the best i've been able to come up with.

    You can press and hold F3 while cursoring over the xref with an active command, like Pline, then let it go when you're ready to snap, but that can be a bit tedious.

    Now, if your attachment is a pdf, then there is a button on the xref ribbon to turn snaps on or off in the pdf, but there is not one for an attached dwg. The button may not be there at all in 2010, don't know.
    The S197 gen Ford Mustang, and the F-4 Phantom both prove the same theory. "With enough power applied, a school bus will fly."

  4. #4
    Super Moderator Cad64's Avatar
    Computer Details
    Cad64's Computer Details
    Operating System:
    Windows 7 Profesional x64
    Computer:
    XI Computers
    Motherboard:
    Asus P8Z77-V Pro
    CPU:
    Intel Core I7 3770K 4.1 Ghz Quad Core 3rd Gen
    RAM:
    24GB DDR3 @ 1333MHz
    Graphics:
    Nvidia GeForce GTX 570 1280MB GDDR5
    Primary Storage:
    SATAII 500GB 7200 RPM
    Secondary Storage:
    Western Digital My Book Studio Edition II - 2TB capacity
    Monitor:
    HPf2105 21" LCD Widescreen & Cintiq 21ux
    Discipline
    Multi-disciplinary
    Cad64's Discipline Details
    Occupation
    Freelance Digital Artist
    Discipline
    Multi-disciplinary
    Details
    3D model building, texturing and rendering. Photoshop Color Graphics.
    Using
    AutoCAD 2014
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    10,156

    Default

    I wouldn't typically recommend doing this, but if you want to disable snapping to your xref, put it on layer Defpoints and then freeze layer 0. This will make the xref unselectable and you won't be able to snap to it.

    It is not good practice to put anything on layer Defpoints though, so I only mention this as a temporary workaround. Once you're finished, thaw layer 0 and move your xref off the Defpoints layer.
    CGSociety Portfolio: http://rdeweese.cgsociety.org/
    Facebook:
    https://www.facebook.com/rdeweese67/


    "Work Smart, Not Hard"

  5. #5
    Super Moderator SLW210's Avatar
    Computer Details
    SLW210's Computer Details
    Operating System:
    Windows 7 PRO 64-bit
    Computer:
    IBM Lenovo
    Motherboard:
    ACPI x64
    CPU:
    Pentium(R) i5 4570 @ 3.2GHz
    RAM:
    8 GB RAM
    Graphics:
    Nvidia Quadro 600 1GB
    Primary Storage:
    300 GB
    Secondary Storage:
    650GB
    Monitor:
    2x ThinkVision 24"
    Discipline
    Multi-disciplinary
    SLW210's Discipline Details
    Occupation
    Design Draftsman
    Discipline
    Multi-disciplinary
    Details
    Mostly do drafting related to manufacturing. From doing site layouts with proposed updates, additions and renovations to be budgeted and submitted for bid, to updating and changing existing drawings to reflect maintenance and repair/revision work done on site.
    Using
    AutoCAD 2011
    Join Date
    May 2007
    Location
    South Florida, USA
    Posts
    11,795

    Default

    Registered forum members do not see this ad.

    It's not bad practice if the effects are intended.
    It's only not recommended now, because there is another way to have non-plot layers, it once was standard operating procedure. I still run across lots of drawings with Viewports on Defpoints, some aren't that old, either.
    “A narrow mind and a fat head invariably come on the same person” Zig Zigler



Similar Threads

  1. ISO lisp to turn off layers by picking a xref first
    By iconeo in forum AutoLISP, Visual LISP & DCL
    Replies: 5
    Last Post: 28th Jul 2017, 03:54 am
  2. Line snapping is not snapping to correct area - need help
    By Joestradamus in forum Civil 3D & LDD
    Replies: 1
    Last Post: 26th Feb 2013, 05:23 pm
  3. Turn on/off Xref layers
    By LISP2LEARN in forum AutoLISP, Visual LISP & DCL
    Replies: 4
    Last Post: 24th May 2011, 02:51 pm
  4. random veiwports turn off as i turn others on
    By mvrcad in forum AutoCAD Drawing Management & Output
    Replies: 0
    Last Post: 20th Apr 2011, 11:55 pm
  5. If layer is on turn it off if off turn it on
    By TheZman in forum AutoLISP, Visual LISP & DCL
    Replies: 11
    Last Post: 13th Oct 2010, 05:09 pm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts