Jump to content

Turn off Xref snapping


samifox
 Share

Recommended Posts

If you have a command active F3 suppresses object snaps. It's the best i've been able to come up with.

 

You can press and hold F3 while cursoring over the xref with an active command, like Pline, then let it go when you're ready to snap, but that can be a bit tedious.

 

Now, if your attachment is a pdf, then there is a button on the xref ribbon to turn snaps on or off in the pdf, but there is not one for an attached dwg. The button may not be there at all in 2010, don't know.

Link to comment
Share on other sites

I wouldn't typically recommend doing this, but if you want to disable snapping to your xref, put it on layer Defpoints and then freeze layer 0. This will make the xref unselectable and you won't be able to snap to it.

 

It is not good practice to put anything on layer Defpoints though, so I only mention this as a temporary workaround. Once you're finished, thaw layer 0 and move your xref off the Defpoints layer. ;)

  • Like 1
Link to comment
Share on other sites

It's not bad practice if the effects are intended.

It's only not recommended now, because there is another way to have non-plot layers, it once was standard operating procedure. I still run across lots of drawings with Viewports on Defpoints, some aren't that old, either. :facepalm:

Link to comment
Share on other sites

  • 2 years later...
On 10/25/2017 at 8:03 AM, Cad64 said:

I wouldn't typically recommend doing this, but if you want to disable snapping to your xref, put it on layer Defpoints and then freeze layer 0. This will make the xref unselectable and you won't be able to snap to it.

 

It is not good practice to put anything on layer Defpoints though, so I only mention this as a temporary workaround. Once you're finished, thaw layer 0 and move your xref off the Defpoints layer. ;)

 

thats not works for me

 

thanks. so autocad is not perfect after all

Link to comment
Share on other sites

51 minutes ago, samifox said:

thats not works for me

 

thanks. so autocad is not perfect after all


Who said Autocad is perfect? :unsure:

 

Also, I'm not sure why my suggestion isn't working for you? It has always worked for me.

 

Did you do exactly as I described? Put your xref on layer Defpoints and then Freeze layer 0.

 

 

Link to comment
Share on other sites

You could plot it to PDF and use it as an underlay. You can toggle osnap to an underlay.

I've used this to recreate portions of drawings we only had as PDF's before.

Link to comment
Share on other sites

  • 2 years later...
On 10/24/2017 at 11:03 PM, Cad64 said:

I wouldn't typically recommend doing this, but if you want to disable snapping to your xref, put it on layer Defpoints and then freeze layer 0. This will make the xref unselectable and you won't be able to snap to it.

 

It is not good practice to put anything on layer Defpoints though, so I only mention this as a temporary workaround. Once you're finished, thaw layer 0 and move your xref off the Defpoints layer. ;)

This is AWESOME!!! I've been using AutoCAD for 30+ years, and I'm an Autodesk Ceritified Instructor and do a ton of customization. I've been looking for a solution to this for eons. It works like a charm. Only thing is that it's a bit glitchy as my xref disappears on occasion, but all I have to do for that is unfreeze 0 and then freeze it again & it's back up. Thank you so much for this!

Link to comment
Share on other sites

On 4/21/2020 at 11:13 AM, samifox said:

 

thats not works for me

 

thanks. so autocad is not perfect after all

I reiterate @Cad64's comment - I love AutoCad, but it is far from perfect - there's no such thing as a 'perfect' CAD software.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...