Jump to content

Search the Community

Showing results for tags 'part parameter'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CADTutor
    • News, Announcements & FAQ
    • Feedback
  • AutoCAD
    • AutoCAD Beginners' Area
    • AutoCAD 2D Drafting, Object Properties & Interface
    • AutoCAD Drawing Management & Output
    • AutoCAD 3D Modelling & Rendering
    • AutoCAD Vertical Products
    • AutoCAD LT
    • CAD Management
    • AutoCAD Bugs, Error Messages & Quirks
    • AutoCAD General
    • AutoCAD Blogs
  • AutoCAD Customization
    • The CUI, Hatches, Linetypes, Scripts & Macros
    • AutoLISP, Visual LISP & DCL
    • .NET, ObjectARX & VBA
    • Application Beta Testing
    • Application Archive
  • Other Autodesk Products
    • Autodesk 3ds Max
    • Autodesk Revit
    • Autodesk Inventor
    • Autodesk Software General
  • Other CAD Products
    • BricsCAD
    • SketchUp
    • Rhino
    • SolidWorks
    • MicroStation
    • Design Software
    • Catch All
  • Resources
    • Tutorials & Tips'n'Tricks
    • AutoCAD Museum
    • Blocks, Images, Models & Materials
    • Useful Links
  • Community
    • Introduce Yourself
    • Showcase
    • Work In Progress
    • Jobs & Training
    • Chat
    • Competitions

Categories

  • Programs and Scripts
  • 2D AutoCAD Blocks
  • 3D AutoCAD Blocks
  • Images
    • Backgrounds

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. I am trying to speed-up dimensioning of an assembly drawing (DWG) in Inventor using iLogic. The assembly contains parts which have parameters which I would like inserted into dimension text. I can achieve this manually using the Edit Dimension / Format Text dialogue boxes to select the part parameters and insert them into the assembly dimension text. My iLogic rule can currently identify the part containing the parameters but when I attempt to write these to the dimension text, I receive an error message. The part parameters are called “No_Risers” and “riser”. “partFileName” is the FullFileName of the Part Document containing these parameters. The line which gives me the error message is the oDimensionText line : [color=red][color=red][font=Verdana]If [/font][/color][color=maroon][font=Verdana]oPart[/font][/color][color=black][font=Verdana].[/font][/color][color=maroon][font=Verdana]ComponentDefinition[/font][/color][color=black][font=Verdana].[/font][/color][color=purple][font=Verdana]Material[/font][/color][color=black][font=Verdana].[/font][/color][color=purple][font=Verdana]Name[/font][/color][color=black][font=Verdana] = [/font][/color][color=teal][font=Verdana]"Concrete" [/font][/color][color=red][font=Verdana]Then[/font][/color][/color] [color=red][color=maroon][font=Verdana]partFileName[/font][/color][color=black][font=Verdana] = [/font][/color][color=maroon][font=Verdana]oPart[/font][/color][color=black][font=Verdana].[/font][/color][color=maroon][font=Verdana]FullFileName[/font][/color][/color] [color=red][color=red][font=Verdana]End [/font][/color][color=red][font=Verdana]If[/font][/color][/color] oDimensionText.FormattedText = "<Parameter Resolved = 'True' ComponentIdentifier='" & partFileName & "' Name = 'No_Risers' Precision = '0'></Parameter>" & " No. RISERS @ " & "<Parameter Name = 'riser' Precision = '2'></Parameter>" & " = " & "<DimensionValue/>" (I have split the long line of code so it reads better on the forum. It is one line in the iLogic rule) I have tried many variations of the above, but cannot get it to work. I can successfully write the parameter values to the dimension text, but these do not update if the parameters update. I’m using Inventor 2013 Pro Any help would be gratefully received.
×
×
  • Create New...