Jump to content
ash_m

Osnap turning off by itself?

Recommended Posts

ash_m

Hi there, I'm having a problem with Osnap turning itself off. I'm on AutoCAD 2009. When I'm in a drawing and "undo" multiple times (like 3 times in a row or more), the Osnap turns itself off. I then have to turn it back on, and then pick the entities I want to snap to all over again. It does this every time without fail when I "undo." Any clues as to why this is happening and what I can do to keep it from happening in the future?? It's rather annoying. Thanks.

Share this post


Link to post
Share on other sites
Glen Smith

Are any of the UNDO's part of a LISP routine? Have you added any LISP routines recently?

 

LISP's sometimes turn off the snaps while they are running, if they are not written in a friendly way, they can leave the snaps in a different state than when they started. Likewise of a LSIP errors during execution with no error handling. And doing an undo that undoes part of a LISP may undo the return of the snaps to where they were.

 

Glen

Share this post


Link to post
Share on other sites
ash_m

Thanks Glen. Unfortunately I have no idea what a LISP routine is. So I don't think I've added any recently?

 

I'm just a designer that uses the AutoCAD program - I don't actually know any of this lingo. :) How would I find out if this is a LISP causing this?

Share this post


Link to post
Share on other sites
rkmcswain

Autolisp is a programming language for AutoCAD.

 

An autolisp statement like this (setvar "osmode" 0) will turn off all running object snaps.

But you say it only happens when you UNDO?

Unless your UNDO command was redefined (using autolisp again...) this is unlikely.

 

Now if you set a running osnap, then do a couple of commands, then undo back far enough, you could be undoing the setting of the object snap also...?

 

Are you a single operator or part of a group with a CAD manager and/or IS staff? If the latter, check with them.

Share this post


Link to post
Share on other sites
ash_m

Thanks, but no, we're a single operator - that's why I'm here, hoping someone out there has an answer to this problem. This only happens when I "undo" - whether I'm using the "U" enter, or the undo icon, it still happens. It's not that I'm "undo"-ing back far enough to undo the setting of the osnap - the osnap is set to "on" when I open AutoCAD, so I'm definitely not undo-ing that far.

 

This also happens to my other designer that uses AutoCAD as well. So I know it has to be something within the program itself. I guess I'll just research this LISP stuff and see what I can figure out. If anyone else has a guess, please let me know. Thanks!

Share this post


Link to post
Share on other sites
rkmcswain
This only happens when I "undo" - whether I'm using the "U" enter, or the undo icon, it still happens. It's not that I'm "undo"-ing back far enough to undo the setting of the osnap - the osnap is set to "on" when I open AutoCAD, so I'm definitely not undo-ing that far.

 

This also happens to my other designer that uses AutoCAD as well. So I know it has to be something within the program itself. I guess I'll just research this LISP stuff and see what I can figure out. If anyone else has a guess, please let me know. Thanks!

 

So can you actually see the status bar button "disengage" during a particular "undo" command? Or do you need to figure out exactly when OSMODE is being changed?

 

If the latter, take a look at the example here:

http://cadpanacea.com/node/53

 

If you think this will help and are not sure how to implement, post back.

Share this post


Link to post
Share on other sites
ash_m

Yeah, you can see it disengage itself - the osnap button just turns off. It's never when I undo just once, it has to be multiple times in a row (which is often for me!) :)

Share this post


Link to post
Share on other sites
ReMark

Type OSMODE at the command line and then press Enter. What is the value shown?

Share this post


Link to post
Share on other sites
ash_m

osmode is set at 47.

Share this post


Link to post
Share on other sites
ReMark

Type UNDO at the command line now and tell us what the settings for the following are: Auto, Control, Combine and Layer.

Share this post


Link to post
Share on other sites
ash_m

auto - on

control - all

combine - yes

layer - yes

Share this post


Link to post
Share on other sites
ReMark

Well I had hoped that we would find something amiss with either or both of the settings I asked you to report on but no luck.

 

Do you use any custom made routines to execute commands?

Share this post


Link to post
Share on other sites
ash_m

Oh shoot. Well as for cutom routines, I wouldn't know how to do that.

 

The only thing I can say is that we use 20/20 Cap software within our AutoCAD 2009. I wouldn't think that software would cause this though. Oh well, thank you so much for your help thus far. If you think of anything else, I guess let me know. I might just have to live with being annoying by this osnap thing. Thanks!

Share this post


Link to post
Share on other sites
ReMark

What is 20/20 Cap software?

Share this post


Link to post
Share on other sites
ash_m

It's a software program that has a bunch of furniture symbols for CAD drawings. I work at a contract office furniture dealership, and we use these symbols to space plan our clients' furniture. That's it - it's just furniture symbols.

Share this post


Link to post
Share on other sites
ReMark

Can we test something?

 

Start a new drawing. Toggle your Osnaps "on". Draw 10 lines using the line command ten times in a row. Now use Undo to eliminate each line. Can you go all the way back to no lines showing without disabling Osnaps?

 

Do NOT insert any furniture symbols in this test.

Share this post


Link to post
Share on other sites
ReMark

ash_m: Did you try the test I mention above or not?

Share this post


Link to post
Share on other sites
katts333

I am also having the same problem. I am using AutoCAD 2010 and I use Project Matrix but it works in the same as CAP 20/20 I am using it to insert Furniture symbols from a library of 2D/3D symbols created by Project Matrix. If anyone out there knows how to fix this it would be greatly appreciated. I as previously using ACAD 2009 and it worked OK until I started using 2010 but I think it is a software switch but have had no luck finding it. I have my osnaps on, I insert a symbol and it will snap, but then when it goes to rotate, it will automatically turn off osnaps. As soon as the symbol is completely inserted, it comes back on.

Share this post


Link to post
Share on other sites
Jack_O'neill

I have 2007 and 2010 and could not recreate your problem in either package. I suspect it has something to do with the 3rd party software. There is a "best practices and known issues" link on the Cap 20/20 website, but since I'm not a registered user of that software it wouldn't allow me in. You might go there and take a look to see if others are having this problem. If so, the fix may be posted there. If not, you might submit it and get it fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...