Jump to content

Accuracy at 4 Decimal Places


Recommended Posts

I'm working on a mechanical detail where an extremely slight manufacturing tolerance error could compound into a problem. I'm talking about plus/minus .0002". So, I set my drawing units to 4 decimal places and started playing with scenarios, being very careful to enter correct line lengths and double checking with the distance measuring command. (model space)

 

I entered some details, moved them around the drawing, etc. Got about 2 hours into this exercise and found things were not lining up perfectly when deep zooming into some of the intersection points. Went back to double check a few of the critical dimensions and found a critical line that had moved .0003" from where I placed it. I know what you're thinking.... no, I made sure the items were drawn accurately to start.

 

What gives? Is it possible there's a glitch in ACAD's math accuracy? Seems to me I read something similar years ago, but not sure if it was ACAD or Microstation. I'm using 2008 Mechanical.

Link to post
Share on other sites

I believe it was AutoCAD.

 

After the drawing is finished then what? Is it going to be plotted or is it going to be exported to another program?

Link to post
Share on other sites
JD Mather

I have never seen this behavoir when using correct modeling techniques. Post an example file and steps to reproduce this behavior.

Link to post
Share on other sites
Fire Alarm

When you were creating the object, was your on when you were drawing. I've found that when I am drawing objects separately, and then moving them together if I have otrack selected with osnaps. The otrack would kick on if I am not directly on the osnap end point.

 

What could have happened if you were moving them (say a circle in a circle) if your osnap center is on along with the otrack, and you were not directly on the center point then the otrack could have placed that one piece .0003. Hopefully I explained right and didn't confuse you.

Link to post
Share on other sites
dshowalt

Remember that when you "Deep Zoom" your display resolution will sometimes affect what you see on the monitor. Think about Pline segments and circle smoothness settings in Acad Options, under the display tab.

Link to post
Share on other sites
Patrick Hughes

If you are concerned about accuracy to within 0.0002 I would suggest setting your precision to 6 decimal places. It doesn't take too many round offs to exceed 0.0002.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...