Jump to content
john1983

Black models when importing from Cad

Recommended Posts

john1983

Hi All

 

Ive come across this problem all of a sudden when importing models from cad to max 2011, When i used to import models the model was a grey colour and when i put lights into the drawing they would show up but now when i import something the model is black and no lights show up..... its driving me mad, any ideas whats happened to it and what i need to do to fix it??

 

Cheers all

 

John

 

p.s

 

Ive attatched an image of what i mean about the black model

Untitled-1.jpg

Share this post


Link to post
Share on other sites
Cad64

I haven't installed 2011 yet, but I'm going to try and find time to do it today. So if you want to post your CAD file and your Max file I can take a look at them later this afternoon.

Share this post


Link to post
Share on other sites
john1983
I haven't installed 2011 yet, but I'm going to try and find time to do it today. So if you want to post your CAD file and your Max file I can take a look at them later this afternoon.

 

 

cheers cad64, just this min figured out what was up, i had one of the settings in the import section wrong

Share this post


Link to post
Share on other sites
Cad64

Just out of curiosity, which setting was it? :unsure:

Share this post


Link to post
Share on other sites
john1983

oh no maybe not, its not showing the lights in the drawing??!! would you do me a favour and have a look at which one of these in the drop down menu in the import screen are checked on yours??

Untitled-1.jpg

Share this post


Link to post
Share on other sites
Cad64

Note: I don't work in Metric units, so my settings below will have to be converted if you want to compare them to yours.

 

It depends on what I'm Importing. I might choose Layer, Color, Entity or sometimes One Object.

 

I also typically have "Weld Vertices" checked, with a setting of .01, and "Auto Smooth" checked with a setting of 15.0.

 

I set "Curve Steps" to 10 and "Max Surface Deviation" to .01 or lower depending on how smooth I need the model to be.

 

The "Include" options just refers to the CAD file and how much of it you want to import. It's pretty self explanatory.

 

But no matter which options you choose, you should not get a black model, and you should be able to insert lights, so I'm not sure what's going on? Have you tried Importing the CAD model into a new file?

Share this post


Link to post
Share on other sites
rjxmaldonado

I had the exact same problem and then I changed the import settings for the primitive to one object. I tried putting in daylight afterwards and the light and shadows worked fine.

Share this post


Link to post
Share on other sites
Kenno

Did anyone solve this problem? When I import to 3ds Max 2011 from AutoCAD 2011 everything is pitch black too, and I can't figure out what is going on. I never had that problem with Max 2010.

 

Any ideas?'

 

Thanks in advance.

 

/Kenneth

Share this post


Link to post
Share on other sites
Cad64

Can you upload your CAD file here so I can take a look at it? I would like to determine exactly what's causing this because this question does get asked quite often, and I am unable to reproduce it here on my end.

Share this post


Link to post
Share on other sites
Kenno

I'd love to, but the cad-file exceeds the 250 kb limit:?

 

But I tried to make a simple cone in cad and import that to Max, but with the same result. I have add'ed that instead.

 

Hope you've got some ideas:)

 

/Kenneth

Drawing5.dwg

Share this post


Link to post
Share on other sites
Cad64

Sorry, but it works fine for me. I imported the cone, set up a light, made sure the light was pointing at the cone and hit Render. Everything looks fine.

 

Maybe you can post some screenshots so I can see what you're seeing? :unsure:

Share this post


Link to post
Share on other sites
micahsa

Try adjusting your settings under "Derive AutoCAD Primitives by" to be "Layer, Blocks as Node Hierarchy"

 

I had Split by Material and it was all black for me too. I switched off of Spit by Material and now works fine.

Share this post


Link to post
Share on other sites
Kenno

Apparently it's all black until I assign some kind of material. I don't know why, and I'm pretty sure it wasn't like this in max 2010. But I got it working now :)

Thank you for your help, I'm glad you took your time, I really appreciate it :)

Share this post


Link to post
Share on other sites
Cad64

Glad you got it working. I wish I knew what was causing it though? :unsure:

Share this post


Link to post
Share on other sites
titanium
Glad you got it working. I wish I knew what was causing it though? :unsure:

 

It's not a "cause", it's a preset:

 

When loading the acad file in Max 2011 and the pop up appears, there's a pull down called "Presets". Select the one for AutoCAD or whichever Autodesk software you are using. Attach file.

BOOM! No more black perspective. At least not for me.

 

Not sure why this was implemented.........

 

I too was banging my head against the keyboard!!!!

Share this post


Link to post
Share on other sites
ThrashMetal

are you using vray?..cause if you are, vray does not support "global(architectural)" material which is the material attached to your imported cad models. create a vray material then assign that to your whole composition, then just start texturing them as you please.

Share this post


Link to post
Share on other sites
pdservicesllc

I have had this same problem and can't get it to change. Anyone? Anyone?

Share this post


Link to post
Share on other sites
Cad64

Can you provide us with your CAD file?

Share this post


Link to post
Share on other sites
fatima zahra

i made a model of a chair in autocad 2012. i saved it as .dwg. And later imported it in 3dsmax 2012. But when the model appeared on screen it was all black. Previously in cad it was brown and white. I even applied lights to check if their was in issue with that. But nothing happened.

Therefore i decided to model something in 3ds max itself.The lights did work on that but on the imported file.

 

Plz tell me what is wrong. I just can't seem to make it work.

Share this post


Link to post
Share on other sites
Cad64

Can you provide us with your Autocad file?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×