Jump to content
fahim108

Font Smoothing in AutoCAD

Recommended Posts

fahim108

Lets consider you are using a fancy font to display this:

 

Font_Issue_000.gif

 

...but instead you get this:

 

Font_Issue_004.gif

 

 

 

This is a common issue in AutoCAD, you may even call it a bug; but you can correct it by resetting the following to their default values:

  • z-value of the text to 0,
  • text oblique angle to 0,
  • text width factor to 1.

But then there are cases where the above solution may not work... so your best guess is to copy and paste everything to a new drawing.

 

The problem basically arises when you try to 3D-orbit (and/or Shademode) your drawing. You may not be aware of this but when you orbit the drawing you mess-up its font smoothing. Even switching back to the default "Top" view (with the 2D-Shademode) doesn't get rid of the ugly wrecked texts. :cry:

 

However, there is a way to avoid this problem beforehand:

 

When you begin a new drawing, always save a view (as shown, without the layer snapshot). In-case you later accidentally or deliberately orbit the drawing, this way, you can always revert back to this view and retain the smoothness of your font. 8)

 

  • Lets begin with a new drawing and save the current view:

Font_Issue_001.gif

  • Assuming this is a part of our drawing:

Font_Issue_000.gif

  • Lets orbit it, and see what happens:

Font_Issue_002.gif

  • The text is already messed up:

Font_Issue_003.gif

  • Use the Plan command to switch back to the Top View. Note, it doesn't help:

Font_Issue_004.gif

  • Use the 3D Navigation Bar to revert back to the earlier saved view:

Font_Issue_005.gif

  • Tada!!!! :shock:

Font_Issue_000.gif

A small effort put in the beginning always helps you in the long run... :geek:

Share this post


Link to post
Share on other sites
Pablo Ferral

Nice one Fahim :-)

Share this post


Link to post
Share on other sites
fahim108
Nice one Fahim :-)

 

Thanks! :)

Share this post


Link to post
Share on other sites
nestly

Good information, but there is another solution to copy/pasting the whole drawing into a new drawing if the text gets messed up after 3D orbit. The problem isn't actually with 3D orbit, it's that panning while in the 3D orbit command moves the "target" of the view, and if the "Target" isn't at the same Z position as the TrueType font then smoothing (anti-aliasing) is disabled. This is the same reason TrueType fonts with z-values other than 0 (relative to the view) display jagged.

 

To correct the problem, use DVIEW to reset the z-value of the view to 0.

Here's a macro that will reset the view, which I've assigned to a button to quickly reset any view. ^C^C_.Dview;;_Point;0,0,0;0,0,1;;

Target reset.jpg

Target.JPG

  • Like 1

Share this post


Link to post
Share on other sites
fahim108

Wow! I gotta check that out... :)

Share this post


Link to post
Share on other sites
fahim108

It works! :D

 

I love this forum... !

Share this post


Link to post
Share on other sites
fahim108

Found an even easier method to set the current view's camera target (to zero z value). Goto DASHBOARD > Control Panels > 3D Navigate > Enter 0 for Target Position Z.

Done! :wink:

 

camera_z_value.png

Share this post


Link to post
Share on other sites
mcprescribed

Hi,

 

Would anyone be so kind as to update instructions under AutoCAD 2011, I tried to follow them but do not have enough background knowledge to migrate them into my version.

 

In fact when I type View in the command window I notice my camera Z value is 0, so maybe it is not the same exact problem.

 

Its weird when I create a dimension with Arial font from new it looks okay but if I change my existing dimensions from Romans to Arial they look "blotchy".

 

This happens on a number of files I have and I have been replacing every dimension, so they plot correctly, any help would be greatly appreciated.

 

Many Thanks

Anthony

Edited by mcprescribed
more information

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...