Jump to content

xrefs are unloading themselves after saving


Recommended Posts

Several of us in the office have just started having a problem with some of our drawings. There will be a number of xrefs in a file, and for each file there will be some xrefs loaded and some unloaded. Previously you could select which xrefs were loaded and which were unloaded, save the drawing, close it, and when you opened it again the same xrefs would be loaded or unloaded as before.

 

Now when we are opening the drawings again, many of the xrefs have been unloaded so we have to go through each file and re-load the xrefs we need. This has to be done each time the file is opened.

 

Visretain is set to 1, but is there any other command to correct/prevent this?

Link to post
Share on other sites

Its hard to exactly diagnose without seeing, but make sure that the names of the Xrefs match the name of the file that is listed in the path box of the XREF pallette.

Link to post
Share on other sites

The xrefs themselves haven't changed so the names are all still the same. The problem is that the xrefs that were loaded when the drawing was saved and closed are no longer loaded when the drawing is reopened. This is a problem since not all users know which xrefs need to be loaded or unloaded for each file.

 

Shouldn't the xrefs that are loaded when the file is saved and closed be loaded when the file is opened again? Does anyone know how to fix this?

Link to post
Share on other sites

A couple of things to check.

First, the name thing. Just double check the name of the XREF versus the name of the file listed in the PATH box for the XREF.

Second, go into TOOLS>>OPTIONS and go aver to the file tab. Be sure that the path that is listed is listed under the Temp XREF directory.

There is also an area under TOOLS>>Options where you can select Demand loading (the name of the tabs escapes me now) Make sure that it is enabled.

 

Many times if the name issue doesn't apply, AutoCAD cannot find the path (or it is unavailable) at the time it is loading the drawing.

 

Those are the only options I can think of at the moment...If I come across more, I will let you know.

Link to post
Share on other sites

It's not that AutoCad can't find the files - the names are correct - it's that they are still there but unloaded. This means every time you open the drawing, you have to go through the list of xrefs and select which ones to load/turn on. This is not the same issue as when the link to an xref has been broken.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...