Jump to content
JonoR

How do you ensure an attached PDF is at the right scale?

Recommended Posts

I'm using AutoCAD 2010 and have tried to insert a PDF which I intend to trace and add my element of the design to. Where things stop making sense are when I set the drawing units. I work in decimal and prefer setting my unit scale to meters. How ever I have notived that when measuring something on PDF in model space regardelss of my unit scale, the length is the same ie 6mm or 6m. this means that a line drawn in mm is 1000 times longer than a line drawn in mtrs which means in order to scale the drawing to something that can be printed larger than a pin prick I have to go mm and then it still doesnt print to scale. I have tried so many options and come up wrong each time.

I am a beginer and probably trying to run befor I can walk but I learn best when doing. I am sure there is a simple solution to this, thanks for your help.

Share this post


Link to post
Share on other sites

Congrats on your first post, and welcome to the forums!

 

The process I use for incorporating EFF (electronic flat file) data into my projects is to open the PDF, and export it to .TIFF file. Once inserted into my drawing, this enables a transparent background, and the line work can easily be colorized to make my drafting easier to differentiate (no solid white background).

 

As for the units... Typically, the EFF I am incorporating has some sort of scale reference (i.e., baseline stationing, ROW corners, etc.), which I use to orient my EFF (scale, rotate, etc.) to my project line work.

 

If all of your distance measurements are coming out to be the same, chances are you have your OSNAPS turned on, and when you pick a point on top of the PDF raster image, your getting an endpoint or something. Try hitting the F3 key to toggle your OSNAPS on/off.

 

Also worthy of note... Draw everything within the model at *FULL* scale (hence the scale mentioned earlier).

 

Hope this helps!

Share this post


Link to post
Share on other sites
I'm using AutoCAD 2010 and have tried to insert a PDF which I intend to trace and add my element of the design to. Where things stop making sense are when I set the drawing units. I work in decimal and prefer setting my unit scale to meters. How ever I have notived that when measuring something on PDF in model space regardelss of my unit scale, the length is the same ie 6mm or 6m. this means that a line drawn in mm is 1000 times longer than a line drawn in mtrs which means in order to scale the drawing to something that can be printed larger than a pin prick I have to go mm and then it still doesnt print to scale. I have tried so many options and come up wrong each time.

I am a beginer and probably trying to run befor I can walk but I learn best when doing. I am sure there is a simple solution to this, thanks for your help.

 

What's happening is that your inserted image of the pdf is coming in at its actual physical size in units. If it were supposed to be printed on 24" x 36" paper, then the inserted image is 24 units by 36 units no matter what a 'unit' is. Figuring out your scale factor for the pdf image using math (which I cannnot seem to manage:( ) will get you a close approximation, but it will probably not be spot on accurate enough for machine work. Besides, the only osnaps on an image are along the frame. They have nothing to do with the lines in the image so it is still not measurable accurately.

Edited by Dana W

Share this post


Link to post
Share on other sites

Once I had a multi-acre lot survey to draw. Drawing units (insertion and dimensions) were surveyor's feet. (Size 14 five E :lol:)

 

I had a pdf of some of the features I needed that did not have to be accurate down to the mm. I inserted the pdf in the drawing, found a long (400 feet) straight line on the pdf with a known dimension. I then drew another line off to the side in model space that same length. Then I moved the line over the pdf as close as I could get it to one end and aligned to the pdf image line with Osnaps OFF. I did a 'send to back" draw order command on the pdf cuz it covered up my line. Then I fiddled and twiddled the image scale by dragging one corner in and out until both lines were as close to the same size as they were ever going to be. I then moved the pdf under the drawing of my lot and traced in my gravel driveways, satelite dishes, rabbit droppings, etc....

 

I only ended up a ~foot off. Over 24 acres, that is probably good enough for a meandering 700 foot gravel driveway not by any means encroaching adjacent lots.

Share this post


Link to post
Share on other sites

RenderMan and Dana W, thanks for your advice, it has left me still a little confused.

 

 

 

when I first inserted my PDF I incorporated its scale reference, which was in inches, to the scale factor of 1. I then treid to change the properties of the PDF to cm which seemed to change the scale factor to 0.85 something. I then changed the page and ruler units preference to cm in the PDF and re inserted it incorporating the baseline reference to the size. when I look in the proporties the info is all there and the size of the PDF is as per A1 size. my scale is 1:500 so to measure on the PDF 1 to 1 it should measure 12 mm but it doesnt. I have scaled it up by measuring a known point on the drawing, working out the scale factor and incorporating that. What I dont understand is why if I work in mm is my drawing bigger than if I work in mtres? If I measure the width of a raod and my unit to scale is mm I will measure 6000 units, if my unit to scale is in mtres then I only measure 6 units. What have I missed here? Am I being thick?

Share this post


Link to post
Share on other sites

If you don't mind I'd like to give this a shot since I do this quite often.

 

Do you know what one length or distance of a line is on the PDF? If you do, use scale and reference, then type in the length it is supposed to be. It doesn't matter how you inserted it.

 

Do you know the scale of the PDF? If you do insert the PDF as the original size, then scale with a factor of the scale. For 1:500, try 6000.

 

1:10 factor=120

1:20 factor=240

1:30 factor=360

1:40 factor=480

1:50 factor=600

1:60 factor=720

1:70 factor=840

1:80 factor=960

1:90 factor=1080

1:100 factor=1200

 

catch my drift.....

 

There are a couple of other ways but try these first and see if you can make one of them work.

Share this post


Link to post
Share on other sites

Agreed.

 

To scale my raster objects IAW my project, I move the raster to a known point, then set the rotation (using another known location for reference), then scale from a known point, as a reference to the second known point, to the actual location in my project.

 

Otherwise, I would scale as reference from one station to another, the unit distance (i.e., 100 FT, etc.)

 

Good luck!

Share this post


Link to post
Share on other sites

when I first inserted my PDF I incorporated its scale reference, which was in inches, to the scale factor of 1.

 

 

When inserting the image make sure your units are set to inches first. Insert the image, then draw a line at 100". Then change your units to cm, then scale the PDF and line and reference the line to 100 cm.

Share this post


Link to post
Share on other sites

Thanks Toberino and RenderMan,

 

I have successfully inserted my PDF/TIFF and got in to the right scale (in model anyway), what I have done in is set one drawing up in mters and another in mm, the PDF is scaled to the "right" size so that when I measure a known reference point ie the width of a driveway I get 6m in one and 6000mm in the other. now the confusion begins for me again as when I check the properties of the drawings the one with units set at mtrs the dimentions are width 416.09 ht 293.91 scale 12.57 the drawing with units set at mm dimentions are width 64013.42 ht 45217.52 scale 1933.29 when I look at drawing in mtrs in layout 1 it is a small little spot in the bottom right corner and when I look at mm drawing in layout 1 it fits the page. Why??? It seems to me that regardsless of the setting between mm, cm, m a unit in model space in the same regardless of what setting you have and infact to draw something to full scale as model is supposed to be then we draw in mm only. ???? this is a bit like time vs eternity.... what is it I am failing to comprehend here??? and then the million dollar question how do you scale something to 1:500 or what ever when the scale factor is 1933.29 ?????? Should I have done quantum physics first?

Share this post


Link to post
Share on other sites
Thanks Toberino and RenderMan,

 

I have successfully inserted my PDF/TIFF and got in to the right scale (in model anyway), what I have done in is set one drawing up in mters and another in mm, the PDF is scaled to the "right" size so that when I measure a known reference point ie the width of a driveway I get 6m in one and 6000mm in the other. now the confusion begins for me again as when I check the properties of the drawings the one with units set at mtrs the dimentions are width 416.09 ht 293.91 scale 12.57 the drawing with units set at mm dimentions are width 64013.42 ht 45217.52 scale 1933.29 when I look at drawing in mtrs in layout 1 it is a small little spot in the bottom right corner and when I look at mm drawing in layout 1 it fits the page. Why??? It seems to me that regardsless of the setting between mm, cm, m a unit in model space in the same regardless of what setting you have and infact to draw something to full scale as model is supposed to be then we draw in mm only. ???? this is a bit like time vs eternity.... what is it I am failing to comprehend here??? and then the million dollar question how do you scale something to 1:500 or what ever when the scale factor is 1933.29 ?????? Should I have done quantum physics first?

 

Model space should 1:1, therefore, get the PDF to the right scale in model space first, then in your viewport in paperspace type z, then hit enter, then type "1/6000xp". This will zoom in to the model space thru the viewport and set a scale of 1:500. Lock the viewport or double click outside the viewport to get out of model space and back into paperspace so that you dont mess up your scale.

Share this post


Link to post
Share on other sites

The scale factors will work exactly the same in model space as they do thru the viewport in paperspace. Refer to the list I posted above.

Share this post


Link to post
Share on other sites

Toberino,

Thanks for your help and appologies if this is now becomming frustrating. followed your advice as per suggestion and the pdf zooms out not in, so far out it cannot be seen? in model space the annoted scale is 1:1

Share this post


Link to post
Share on other sites

Ok, I believe I was misleading you slightly since you are working with meter and millimeter units and I am used to inches and feet. So since your units are all on a base of 10 rather than 12 things are slightly different. They are a lot simpler with metric units. I believe your xp should just be 1/500xp. I think. I have not studied very intently. I will if I have to though.

 

Here are a couple of links that should help you understand what you need to do to get the right zoom factor.

 

http://www.cadtutor.net/tutorials/autocad/paper-space-exercise.php

 

http://www.cadtutor.net/forum/showthread.php?50174-layout-print-scale

 

http://www.cadtutor.net/forum/showthread.php?50254-scale-factor-ratio&highlight=scaling+viewport

 

If you have more questions after checking out these other posts feel free to ask me. I enjoy learning new things and helping you problem solve is just another opportunity.

Share this post


Link to post
Share on other sites

JonoR, I think some of your confusion may be due to the way AutoCAD "sees" units. A line 1 unit long is 1 unit long no matter what label it has, meters, millimeters, inches, feet, light years, etc. In other words, say you have a drawing setup in light years and one setup in millimeters. Draw a line 1 unit long in the one that is setup in light years, copy and paste it into the drawing that is setup in millimeters. That line will still measure 1 unit long. Now when going from mm to m you will need to use a scale factor of 1000 to adjust your drawing accordingly.

 

I hope that makes sense. I have seen it explained better.

Share this post


Link to post
Share on other sites
If you have more questions after checking out these other posts feel free to ask me. I enjoy learning new things and helping you problem solve is just another opportunity.

 

 

What a great attitude to have, Happy Friday!

Share this post


Link to post
Share on other sites
Model space should 1:1, therefore, get the PDF to the right scale in model space first, then in your viewport in paperspace type z, then hit enter, then type "1/6000xp". This will zoom in to the model space thru the viewport and set a scale of 1:500. Lock the viewport or double click outside the viewport to get out of model space and back into paperspace so that you dont mess up your scale.

 

Toberino I get this part but what I think is creating chaos within my drawing and throwing everything out is the fact that the drawing has been scaled to get to the size it is at. See post above where I mention that I have inserted the PDF and it is to scale ie when I measure somethin on the drawing in model space it is correct i.e. my driveway is 6m wide or 6000mm wide which ever drawing I am in.

 

When I go to view port the drawing is a small dot in the bottom left corner. I hit extents button and the drawing fills the viewport. Great. if I look at the viewport scale it is 1.880408. The scale in model space was 1:1. If, instead of hitting the extents button I follow your previous suggestion of z then 1/6000xp then the drawing becomes even smaller than the dot it was I have tried all sorts of variations on this with the same result. if double click outside the viewport then the whole page becomes so small it cant be seen and my screen is a grey colour matching the background to the viewport screen. I think that the scale factoring to get the PDF to the right size is now effecting all of this. So how do you keep the PDF at the right size but zero the scale factor? I have tried doing this in the properties but no luck it changes the PDF back to a smaller size and messes the scale factor up so when I measure on the drawing it is all wrong. Any suggestions?

 

thanks again for your help.

Share this post


Link to post
Share on other sites
Toberino I get this part but what I think is creating chaos within my drawing and throwing everything out is the fact that the drawing has been scaled to get to the size it is at. See post above where I mention that I have inserted the PDF and it is to scale ie when I measure somethin on the drawing in model space it is correct i.e. my driveway is 6m wide or 6000mm wide which ever drawing I am in.

So by doing this, you have essentially made the model space 1:1. Now you are to square one. You have your PDF scaled properly. Next step, get the scale factor set for your plot.

 

When I go to view port the drawing is a small dot in the bottom left corner. I hit extents button and the drawing fills the viewport. Great. if I look at the viewport scale it is 1.880408.
Ignore this for right now.

 

The scale in model space was 1:1. If, instead of hitting the extents button I follow your previous suggestion of z then 1/6000xp then the drawing becomes even smaller than the dot it was I have tried all sorts of variations on this with the same result.
I was wrong about this number as this is for feet and inches. Try 1/500xp. I might be wrong about this number. I have not had a chance to dive into metric units yet. I will tomorrow at work.

 

if double click outside the viewport then the whole page becomes so small it cant be seen and my screen is a grey colour matching the background to the viewport screen.

Try double clicking inside your veiwport and see what happens. You should see the viewport lines get thicker. Then double click in the grey area and see what happens. The viewport lines get lighter again. In paper space you can be in either model space(which is actually your active veiwport, when the lines are thicker) or paper space(when the "model space" or "veiwport" lines are lighter again). You can zoom your paperspace just like you can zoom in modelspace. But you don't want to do that, you want to zoom through your veiwport.

Double click in the grey area to activate your paperspace and do a zoom extents. This will fit your paperspace to your screen.

 

I think that the scale factoring to get the PDF to the right size is now effecting all of this.
No it is not. You just need to get an understanding of scaling your plots to get the right scale on the output.

 

So how do you keep the PDF at the right size but zero the scale factor?
:?Zero is not what we are trying to accomplish. 1:500 is.

 

I have tried doing this in the properties but no luck it changes the PDF back to a smaller size and messes the scale factor up so when I measure on the drawing it is all wrong. Any suggestions?
Don't mess with any of the properties. You only have two things to do. 1)Scale the PDF so that it is essentially 1:1, which you have already accomplished. 2)Zoom in through your veiwport to get the correct scale factor, which is 1:500. Which is the whole "Z", enter, 1/500xp routine.

 

Have you tried plotting anything yet and dropping a rule on it to check what scale you are getting?

I apologize if you already know some of what I am saying but without knowing what your exact skill level is it is hard to describe the steps necessary without being redundant. Otherwise I might miss an important step that I might have assumed you knew but did not.

 

Just out of curiosity, exactly what scale are you trying to get? 1mm=500mm, or 1m=500m?

 

Have you checked out the links I posted you?

Edited by toberino

Share this post


Link to post
Share on other sites

Hi Toberino,

 

This is all starting to make sense now ... THANKS!! and just to answer your question I am a beginer, I have only being working on CAD for a couple of months, I dont have anyone in my office who does it as I work alone. I am an irrigation engineer and I have started to learn CAD as I am doing more design and consulting, I have been getting a CAD operator to do it for me till now.

 

the scale I am trying to achieve is 1:500. so using a scale ruler 1cm on the printed page will equal to 5m on the ground. Reading what you have said here I am correct in assuming that: as my drawing in 1:1 in model space, my units to scale are in meters then the scale I set in my view port should be 1/1000xp? As one unit in model space equals 1000mm on the ground??? However this is not working as regardless of the scale I set be it 1/5000xp or 1/1xp and any and everything in between the content of that viewport shrinks down to what ever the factor of that scale determines, at 1/1 the drawing decreases in size by about 36%. I havent printed it yet but I will do so first thing in the morning to see what scale it prints out at.

 

just to clarify and to see if I have understood correctly, if I what to print a drawing and I want the scale to be 1:100 do I set the scale in the view port as 1/100xp?

 

Sorry if this is doing your head in.

 

Thanks again for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×