Jump to content

refclose, not closingref!


Recommended Posts

So im editing a reference in place, and invoke REFCLOSE. everything is working fine. I save my changes, and expect to go back to the child drawing, but it seems im stuck in refedit still... i cant get around it... i end up with a lock on the file, even though the .dwl is deleted, and im the only user! this is the first time ive had this happen to me.... at least its not Friday afternoon.... but i guess being monday doesnt make it any easier!! :P:oops::?

Link to comment
Share on other sites

If I understand your problem, you have a lock on your "child" drawing, the one that includes the xrefed drawing. If you're on a network, you may have trouble with this solution, but it's the only one I know of. When you open a drawing, AutoCAD creates two lock files in that folder, with the same name but with extensions .DWL and .DW2. Erase those two files and you remove the lock.


Understand this is a last resort. It's worth double-checking the timestamp on the files to make sure someone isn't editing the file right now (i.e. the date is yesterday, not today). If you remove the lock while someone has the drawing open, that would be bad.

Link to comment
Share on other sites

I am familiar with the lock files and have deleted them. I am on a network, but I am the only one who is accessing the files. There are only 4 engineers here so im positive that no one else has them open. According to WHOHAS, i still have the "parent" drawing open, even after REFCLOSE...

Link to comment
Share on other sites

Interestingly enough, when I discard changes, the file reverts back and closes properly... I am now just getting an error **Failed to saveback xref file**... :x:?

Link to comment
Share on other sites

  • 12 years later...

Hi all,


I know this is an old thread, but I was struggling with exactly this problem today and found a deceptively easy solution, so I thought I would post here for any future people who end up Googling the issue like I did.

tl;dr don't forget that AUDIT exists!!


To add some information, my issue was the same as above, and my temporary work-around was to do the following:

- Make my changes in refedit/edit-in-place

- Copy everything over to a blank drawing area and remove the copied objects from the set

- Discard changes

- Copy Base the copied objects at an easily referenced point

- Open the block in question in block editor proper, delete everything except what I needed to place what was on the clipboard

- Paste, save and close Block Editor


Obviously that isn't a viable long-term solution. On top of that, I was having locked refedit layers crop up in my layers that were not self-deleting after closing  block editor or refedit (even with discarded changes) and that was driving me nuts. I also tried wblocking, making a brand new block in a new file and replacing it everywhere, all of the versions of 'turning it off and on again' that you can think of, deleting .dwl files, ensuring nothing in my block was referencing objects outside the block, etc... nothing was helping me.


FINALLY... I remembered that AUDIT exists. I ran audit, it fixed 1 error, and now everything works as normal.


Hope this helps someone down the line. 

Link to comment
Share on other sites

  • 1 year later...

I tried all these and still failed to save ☹️

I managed to find a workaround: first copy everything over a set distance to the side of your working area so that you now have a complete copy of everything to one side.

Then remove these copied objects from your working set using the button in the menu bar.  This will make a copy of the stuff in the host drawing.  Then Close out of the xref choosing to discard the changes.  You then have a copy of your amendments that you can copy and paste back into the xreffed file.  Open your xref and delete that original unamended stuff, copy the amended stuff back in from the host drawing (pasting in at coordinates 0,0) and move the copied stuff over by the set distance you used earlier in the process.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...