Jump to content
JerryG

Cogo Point Annotation scale - can it be changed?

Recommended Posts

JerryG

Hey all.

I have a bunch of Cogo Survey points that look great in Model space

but as soon as I go to Paper they get bigger therefore jumbled and

not readable. Here is what I have tried with no luck -

Under Point Groups -Properties, Change Point Label style, changed

Text Height - no change

Also Selected point and changed the "Point Group Properties_all Points"

and changed the Point Style and Label style - no change.

Will I be forced to change the cogo blocks to Autocad blocks so that I can

change the Annotative scale?

 

Thanks in advance for any help!

Share this post


Link to post
Share on other sites
sinc

Sounds like you're at the point where you would get a lot of benefit from training. If you can swing it, it would save you a lot of time and headache.

 

But in the meantime, there's some basic rules to get to know. First is that C3D Labels don't use the Annotative Scales in any way. Instead, they scale using the Drawing Scale (in modelspace) or the Viewport Scale (in paperspace viewports). But the scale in the status bar (in the lower-right of the screen) will change both the modelspace Annotation Scale and the Drawing Scale if you are in modelspace, and it will change both the Viewport Annotation Scale and the Viewport Scale (zoom factor) in a paperspace viewport. So if you always change scales using the scale in the Status Bar, it will feel like the C3D Labels are using the Annotative Scales.

 

The upshot is that if you change your scale in modelspace so that it matches your viewport scale, then what you see is what you'll get. You won't have that problem where things look right in modelspace, but not paperspace. If this makes your labels look wrong in modelspace, then edit the height in the Style to make it look the way you want.

 

That gets into the next set of rules... How Point Styles and Point Label Styles work. There's a hierarchy, so you have to change things in different places, depending on how you have them all set up. The basic rules are this:

 

  1. If you have a Point Style or Point Label Style selected in the Point Group Properties, AND you have the OVERRIDE turned on (on the Overrides Tab in the Point Group Properties), then the point will use the Style that is set in the Point Group.
  2. Otherwise, IF the Cogo Point has a Style assigned directly to it (in the Properties of the Cogo Point itself), the point will use that Style.
  3. Otherwise, the point will use the Style specified in the Point Group.

In the above three rules, when I talk about "the Style in the Point Group", I actually mean the TOP LEVEL Point Group that contains the Cogo Point. A Cogo Point can be in any number of Point Groups at the same time. So if a Cogo Point is in more than one group, then "the Style in the Point Group" refers to the Style assigned to the highest-level Point Group that contains the Cogo Point.

 

To change the levels of the Point Groups in the Point Group hierarchy, select the Point Groups collection in Toolspace, right-click -> Properties. You'll see a dialog listing all your Point Groups, and you can move them up and down in the list. The Point Groups at the top of the list take precedence over Point Groups that are further down in the list.

 

There's a lot more to cover, but that should help you sort out your issues. Once you start digging into it, post back if you have more questions.

Share this post


Link to post
Share on other sites
JerryG

Nice!

Thank you Sinc!

Share this post


Link to post
Share on other sites
cad_monkey

I know this is an old post and I'm sorry to re-visit it, but I'm having the same problem and although the method described here will work to view one layout with one viewport correctly, I have the same model showing in two viewports (on one paperspace layout) which means one viewport looks bang on, and the other looks a mess. The labels are massively big. The points themselves style nicely to the correct style, it's just the labels that seem to be the problem.

 

Any ideas please?

Share this post


Link to post
Share on other sites
JerryG

Did you click in the new VPort and regen after you copied it?

Share this post


Link to post
Share on other sites
ScribbleJ
Posted (edited)

Even though this is a very old thread I thought it would be worth adding that there is another element to this issue. That is the Drawing Settings which can be accessed several ways but for the sake of simplicity it can be found by clicking on the AutoCad Icon in the upper left corner and choosing Drawing Utilities then Drawing Settings. In the first tab 'Units and Zone' you will find the Drawing Units in the upper left. That setting needs to match the setting (Feet, Inches or Meters) of the file where the viewport resides. If they are different your cogo points label style and point style will not display correctly. They will probably look fine in Model Space but will not in Paper Space.

Edited by ScribbleJ

Share this post


Link to post
Share on other sites
JerryG

Wow I forgot about this post! 

Thanks for the addition ScribbleJ.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...