Jump to content
magic_man1

Default Instance Parameters

Recommended Posts

magic_man1

I am modifying a pre-existing electrical panel family and the goal is to create text on the panel in elevation view to reflect the panel name.

 

The issue I have seems to be that even though I type a default panel name in the "Panel Name" parameter (I used "zzz" so the value would stand out), when I load this family into a project and attempt to place my first panel, it comes in with a blank value in the "Panel Name" parameter slot. Typically, this would come in with a value of: "zzz".

 

Again, this is an "out of the box" family that I am attempting to modify, so I am partly wondering if this is because a something has been done to force this field come into a project empty.

 

Any ideas / thoughts are much appreciated.

 

I will also say, that once the panel is inserted, you can give it a name, then update the family to include the functionality and everything works great (because it has a name now). The problem is, getting it to come in with a default name, so you can change it after placing it into the project.

 

(I am using Revit MEP 2011)

 

Thanks,

Share this post


Link to post
Share on other sites
JRevit

can you upload the family file in question?

 

i have MEP at work, but im working from home today and only have Architecture here

Share this post


Link to post
Share on other sites
Lee Roy

Sounds like one of two things is happening...

1. There's a formula that's overriding your default value

 

2. You need to overwrite parameters when inserting the new (modified) family.

 

If these don't work, please upload the file and I'm sure we can pick it apart and fix it very quickly.

Share this post


Link to post
Share on other sites
Joshua Lumley

I have spent, hours and hours trying to figure this out. It is bs as far as I can tell you can't change the default of new instances. But I'll keep searching for a solution, (this reason alone is making me regret investing in Revit 2013).

Share this post


Link to post
Share on other sites
Lee Roy
I have spent, hours and hours trying to figure this out. It is bs as far as I can tell you can't change the default of new instances. But I'll keep searching for a solution, (this reason alone is making me regret investing in Revit 2013).

 

Your post was absolutely dripping with information...

 

If these don't work, please upload the file and I'm sure we can pick it apart and fix it very quickly.

Share this post


Link to post
Share on other sites
irneb

When you redefine the family (i.e. you load it into your project) a dialog like this should open:

capture_03112013_092259.png

 

Click the 2nd option to overwrite the family's definition and ALSO its values in the parameters. If you click the 1st option, only the definition is overwritten.

 

Moral: Read what you're clicking on before clicking it. I've found lots of people using Revit complain about stuff "going wrong" - only to find that they tend to just click on messages / error warnings without even trying to understand why they occurred. Nearly always something not working / simply "disappearing" is because of one of those warnings which you simply clicked on the OK / Continue button without noticing that it was saying that some stuff are going to be deleted / links broken / etc. Same principle goes for this - the override dialog has 2 options, but most only read as far as the 1st few words of the 1st option.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...