Jump to content
Bill Tillman

Objects in Viewport Move When I Resize Viewport

Recommended Posts

Bill Tillman

I've got a strange situation happening. I have some viewports in paper space and when I resize the view port, the objects inside move in a strange way. I don't know if a variable got reset or something but this is weird. Normally I can resize a viewport and the objects stay in the same location. But now they seem to be moving relative to the edge of the viewport.

Share this post


Link to post
Share on other sites
ReMark

Is the viewport display locked or unlocked?

Share this post


Link to post
Share on other sites
rkent
I've got a strange situation happening. I have some viewports in paper space and when I resize the view port, the objects inside move in a strange way. I don't know if a variable got reset or something but this is weird. Normally I can resize a viewport and the objects stay in the same location. But now they seem to be moving relative to the edge of the viewport.

 

I have had this happen to me when the shademode was set to other than 2d in the viewport. Do you have shademode set to to other than 2D in the viewport in question?

Share this post


Link to post
Share on other sites
Bill Tillman

The Shade Plot setting for this viewport is "As Displayed". It's not a problem of it being locked or unlocked, it is unlocked. That would be a different behavior. It seems to be a problem with this particular drawing. I have another DWG file which I just opened and checked for the same problem. This other file has no such issue with the viewports. So it's isolated to this one file thus far.

 

UPDATE: OK I seem to have found it. The Shademode was set to other than 2D like rkent advised. I was confused on this until I read it closer. Funny thing is that I have the drawing set to 2D but I have some 3D stuff in this dwg file and have changed the shademode a few times. I'm finding that as I switch between model and paper space this setting changes on me unexpectedly. Now that I know what to watch for I will see if the error repeats itself.

Edited by Bill Tillman

Share this post


Link to post
Share on other sites
SLW210

Post the file.

Share this post


Link to post
Share on other sites
SuperCAD

I've had this happen a few times. Try deleting the viewport and recreate it. If that doesn't help, start a new drawing and copy all of your geometry into it and start the viewport thing over again. Somehow, the viewports become corrupt and you can't do anything to fix them.

 

I would say it's a graphics card issue, but I've got a good certified graphics card and it's still happened to me.

Share this post


Link to post
Share on other sites
rkent
The Shade Plot setting for this viewport is "As Displayed". It's not a problem of it being locked or unlocked, it is unlocked. That would be a different behavior. It seems to be a problem with this particular drawing. I have another DWG file which I just opened and checked for the same problem. This other file has no such issue with the viewports. So it's isolated to this one file thus far.

 

UPDATE: OK I seem to have found it. The Shademode was set to other than 2D like rkent advised. I was confused on this until I read it closer. Funny thing is that I have the drawing set to 2D but I have some 3D stuff in this dwg file and have changed the shademode a few times. I'm finding that as I switch between model and paper space this setting changes on me unexpectedly. Now that I know what to watch for I will see if the error repeats itself.

 

I was saying to make the viewport current, then use shademode command and set it to 2D.

Update: I didn't see your update soon enough, sounds like you worked it out.

Share this post


Link to post
Share on other sites
runecloud

I'm having a similar ongoing problem when working with images in model space. Every time i click in the viewport in paper space the model space image "jumps" and resizes itself to some random size. To temporarily get around this we have been locking viewports but when working with multiple viewports it gets time consuming. I have tried the solution posted in this thread but is already set correctly. The images are large files (150dpix24x36). Some people in the office are using 2004 and 2006 and does the same in 2009 version. My office (and I) have searched for a solution and have found nothing so help would be grand. Thanks!

Share this post


Link to post
Share on other sites
Dana W
I'm having a similar ongoing problem when working with images in model space. Every time i click in the viewport in paper space the model space image "jumps" and resizes itself to some random size. To temporarily get around this we have been locking viewports but when working with multiple viewports it gets time consuming. I have tried the solution posted in this thread but is already set correctly. The images are large files (150dpix24x36). Some people in the office are using 2004 and 2006 and does the same in 2009 version. My office (and I) have searched for a solution and have found nothing so help would be grand. Thanks!

 

This is usually caused by inadvertently panning or zooming with the mouse while in modelspace through the unlocked viewport. If you are using unlocked viewports, the best way to make changes in modelspace is to go back to the modelspace tab to avoid messing up your viewport scale by accident.

Share this post


Link to post
Share on other sites
runecloud

Thanks for the response Dana- however we are certain it is not your suggestion. We are working with viewport layer states to control attributes inside multiple viewports so directly editing in model space is not an option. On activation of one viewport ALL viewports on the sheet jump out of scale. Again it seems to only happen when images are attached.

 

Any other suggestions?

Share this post


Link to post
Share on other sites
runecloud

I should clarify that when the images jump out of scale in the viewports they are zooming extents so its not random as i previously mentioned.

Share this post


Link to post
Share on other sites
runecloud

We found a solution... type UCSFOLLOW and set value (0)

Share this post


Link to post
Share on other sites
hip

Hello.

Same problem here. Tried SHADEMODE and UCSFOLLOW and no luck. Using Autocad 2013 with Nvidia Geforce GTX 960.

Annoying. Any suggestion? TIA,

hip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×