Jump to content
khoshravan

use "delete" button for erasing objects

Recommended Posts

khoshravan

Before when I selected objects and press "delete" button on the keyboard, it erased those objects.

Now CAD doesn't do that. How can I enable that again?

Share this post


Link to post
Share on other sites
Ahankhah

You must be in Noun/Verb Selection mode.

To enable Noun/Verb Selection follow these steps:

In the command prompt of AutoCAD, issue bold words.

Command: PICKFIRST

Enter new value for PICKFIRST : 1

Share this post


Link to post
Share on other sites
Tiger

I've always wondering why its called "noun/verb selection" - its sounds grammtical to me :?

Share this post


Link to post
Share on other sites
Ahankhah
I've always wondering why its called "noun/verb selection" - its sounds grammtical to me :?

Yes, it is a grammatical statement. I understand it very well because in Persian sentences unlike English, noun is prior to verb. For example equivalent of Rotate that object is: That object rotate (آن جسم را بچرخان). So as you see, in English you speak and write in Verb/Noun method and in Persian it is in Noun/Verb form.

Share this post


Link to post
Share on other sites
khoshravan
You must be in Noun/Verb Selection mode.

To enable Noun/Verb Selection follow these steps:

In the command prompt of AutoCAD, issue bold words.

Command: PICKFIRST

Enter new value for PICKFIRST : 1

 

Dear Mehrdad

 

Thanks. Will this affect all selections like selection for copy, move?

 

I don't want the latter to be changed. I want only for "delete"

In the past I have done it, so I think there is another command which controls this item.

Share this post


Link to post
Share on other sites
Tiger

Pickfirst = 1 will mean that you can select objects before or after you execute a command.

 

Pickfirst = 0 will mean that you only can select objects after you execute a command.

Share this post


Link to post
Share on other sites
khoshravan
Pickfirst = 1 will mean that you can select objects before or after you execute a command.

 

Pickfirst = 0 will mean that you only can select objects after you execute a command.

 

So 1 has both options of before and after and diereses from "0" options in this sense that the latter only has one slection criteria.

 

I didn't know this. Very nice point. Thanks a lot.

 

BTW are there any other commands to be like this one?

Share this post


Link to post
Share on other sites
Ahankhah

Dear Rasoul, as Caroline (Tiger) mentioned, Pickfirst value effects on most commands prompting "Select objects: " or "Select object: ". It means you are not able to change the manner of Erasing (Deleting) objects without affecting on other editing/modifying commands.

Share this post


Link to post
Share on other sites
khoshravan
Dear Rasoul, as Caroline (Tiger) mentioned, Pickfirst value effects on most commands prompting "Select objects: " or "Select object: ". It means you are not able to change the manner of Erasing (Deleting) objects without affecting on other editing/modifying commands.

 

But pickfirst=1 allows us to lunch the command before or after selection. In case of my question, with pickfirst=1, I can select the object first and then press "del" button. This will produce the result I am looking for.

Share this post


Link to post
Share on other sites
Tiger
Yes, it is a grammatical statement. I understand it very well because in Persian sentences unlike English, noun is prior to verb. For example equivalent of Rotate that object is: That object rotate (آن جسم را بچرخان). So as you see, in English you speak and write in Verb/Noun method and in Persian it is in Noun/Verb form.

 

This explains it! Thanks Ironman :)

Share this post


Link to post
Share on other sites
Ahankhah
This explains it! Thanks Ironman :)

You are welcome Tigerwoman :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...