Jump to content
acmesriley

Alias's or shortcuts won't work in 2012, what can I do to fix this?

Recommended Posts

acmesriley

I am able to edit the pgp file but after making the changes the shortcut alias's I changed will not take effect at all, not even if I exit autocad and restart. Specifically, I want 'X' to be 'EXTEND', but when I type 'X' I will get XRef instead. Also I want 'C' to be 'COPY' instead of 'CIRCLE'.

 

These are just a couple of examples that without the shortcut my work gets not just slower but annoying by the end of my usually stressfull day.

 

All the cad managers here where I work can not figure this out. Can any of you help me please?

 

Thanks,

 

acmesriley

Share this post


Link to post
Share on other sites
ReMark

Did you edit acad.pgp from within AutoCAD? Yes/No?

 

Did you put your "user defined" aliases in the proper section of the acad.pgp file? Yes/No?

Share this post


Link to post
Share on other sites
acmesriley

Yes I did ReMark.

Share this post


Link to post
Share on other sites
rkent

Maybe there is more than one acad.pgp file in the search path or the one you are editing is not in the search path or further down in the pgp file the shortcut is defined the other way.

 

There are lots of different ways to get to the file, if you are using the ribbon to to the Manage tab, Customization panel, pick on Edit Aliases. Make your change there, but do so at the bottom of the file where it says to add or make changes. So copy a line and paste down at the bottom then edit for what you want. That should be it.

 

You can check to see if there are multiple acad.pgp files by typing at the command line

(findfile "acad.pgp"). Hopefully it will only report one, if it shows two then one needs to be renamed so it won't be loaded.

Share this post


Link to post
Share on other sites
acmesriley

Wait a minute ReMark. I will update the User Defined area and return to the forum in just a minute or two.

Share this post


Link to post
Share on other sites
Dadgad

Welcome to the forum. :)Did you make the changes in the USER DEFINED command aliases area of the .pgp file, as shown in the image?

Did you remember to SAVE after you made the changes?

Did you reboot the program, or use the REINIT command for the PGP to activate the new aliases?

 

 

 

Remember that this area takes PRECEDENCE over duplicates that appear earlier in the file! :)

user defined  is where yu do it.jpg

Share this post


Link to post
Share on other sites
ReMark

If you edited from within AutoCAD then a REINIT would have been issued automatically. I think you may have edited the wrong portion of the file.

Share this post


Link to post
Share on other sites
acmesriley

rkent I just did as you said, I edited the pgp file by using the ribbon, saved it and got out of autocad and restarted again. Still did not fix the problem.

Share this post


Link to post
Share on other sites
ReMark

Just for giggles.

 

Edit the file then save. When you go back into 2012 issue a REINIT command and make sure you check off PGP file. Now test your "C" for "Copy". What happens?

 

By the way, you do NOT have to exit out of AutoCAD and then restart it. Just issue the REINIT command.

Share this post


Link to post
Share on other sites
Dadgad

Remember that this area takes PRECEDENCE over duplicates that appear earlier in the file! :beer:

Share this post


Link to post
Share on other sites
acmesriley

ReMark,

 

I just went back into the pgp file and changed the body of the file to reflect C, *COPY X, *EXTEND

I did a save as right overtop of the same acad.pgp file. Exited autocad and restarted. Not fixed.

Share this post


Link to post
Share on other sites
acmesriley

Dadgad,

 

Yes I did know that and now the pgp file has the changes I want in the main body of the file and at then end under user preferences. Not fixed yet.

Share this post


Link to post
Share on other sites
SLW210

Can you post an image of your .pgp?

Share this post


Link to post
Share on other sites
Dadgad
Dadgad,

 

Yes I did know that and now the pgp file has the changes I want in the main body of the file and at then end under user preferences. Not fixed yet.

 

Once you change them at the bottom of the file, you will be fine. :)

And if you don't change them there, then you will likely continue to experience this problem, until such a time as you do.

Good luck. :beer:.

Share this post


Link to post
Share on other sites
ReMark

Well your version of 2012 is acting way different than my version as I just tested it using "C" for "Copy" and it worked.

 

The only edits you should be making are at the end of the file. You do NOT have to make edits to the main (original) body of the file as user defined edits trump those listed above.

Share this post


Link to post
Share on other sites
ReMark

REINIT.PNG

Have you seen this lately?

 

I think we scared poor acme off.:(

Share this post


Link to post
Share on other sites
nestly

If you have Express Tools installed....

FORGET ABOUT FINDING THE CORRECT PGP

FORGET ABOUT EDITING THE PGP

FORGET ABOUT REINITIALIZING THE PGP

 

SIMPLY USE THE COMMAND ALIAS EDITOR. It will find the correct file, put your custom alias at right place, preserve the original alias's , make a backup of the original PGP, and automatically reload the updated PGP.

 

Full demo here -->

 

(PS, do not have two versions of AutoCAD open at the same time)

Share this post


Link to post
Share on other sites
ReMark

The Command Alias Editor can be found by clicking on the Express Tools tab and looking on the Tools panel for the icon labeled Command Aliases.

 

If you utilize the drop-down menus click on Express > Tools > Command Alias Editor.

 

If you got to the acad.pgp file via the Ribbon's Manage tab > Customization panel > Edit Aliases button then you would have to save your changes then issue the REINIT command for those changes to occur.

Share this post


Link to post
Share on other sites
acmesriley

nestly,

 

Funny thing is that after IT reinstalled 2012 over last weekend when I went to do just like you say "aliasedit" at the command line there was not a pgp file to be found. The file was in the Support folder and I edited it there just as the above suggestions talked about. Not fixed.

 

Why is it that when I change this file (the pgp) and save it 2012 will not recognize the change? It is driving me buggy and slowing me down a lot.

 

acmesriley

Share this post


Link to post
Share on other sites
acmesriley

nestly,

 

I followed the video link you posted to the letter. Only difference in my attempt wast that I got this message after selecting 'APPLY', "Restored default alias: XC".

 

I did not restart autocad but when I typed 'C' I got 'change' instead of 'copy'.

 

What the heck is happening?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...