Jump to content
architte

Blocks "spontaneously" renaming, relayering and duplicating themselves?

Recommended Posts

architte

Hi everyone, I'm a noob to this forum and to 2013... I was using 2006 for too long, and now have finally made the switch to 2013 (yay?)

 

So I (and some colleagues as well) have been having a problem with our blocks. Upon opening some of our files, we have noticed that the blocks in the file have duplicated themselves, also renaming themselves with the extension "-flat-1", "-flat-2", and so on, for as many instances of that block that exist in the drawing. Also, the block layer has changed to 0, and the linework layers within the block have changed to the layer that block was on previously! This is EXTREMELY annoying and problematic for our workflow, obviously, as it essentially removes the convenience of blocks!

Recently this happened with a file that was very "clean" to start, and with extremely "clean" blocks... with the exception of having some xrefs from an international client (Turkey). We're trying to replicate this occurence intentionally to try to troubleshoot, without any luck.

Is this something we're doing unintentionally, or could it be something viral from our "dirty" xrefs??

ps... my colleagues are using 2010 and 2012.

 

**fingers crossed that someone has an answer!!** Thanks!

multipule block error.pdf

Share this post


Link to post
Share on other sites
Dadgad

Welcome to CADTutor. :)

 

That certainly would be annoying.

It sounds like there is a lisp running which is rocking your boat.

If you delete one block, say flat 2 for instance, do all of the sequential

numbers then rename themselves to reflect a decrement of one, which you deleted?

Is this only happening with a drawing or drawings from that one client?

 

What happens if you explode one of those blocks after you insert it?

 

You might want to look at this http://www.lee-mac.com/autolabelattributes.html,

and see if that seems anything like what is happening.

A great lisp, one of many on Lee's site, but if you didn't know it was, or didn't want it running

it would certainly confuse you.

 

Have you run the -PURGE command (including the hyphen) on those xrefs?

Share this post


Link to post
Share on other sites
architte

Thanks for your suggestions! We considered the lisp possibility, but that was debunked... it turns out it was a very simple answer: the flatten command. Ha.

Only, not so funny when there's a slew of blocks we now have to replace.

But at least we know to be more careful about what's selected when running the flatten command (which we usually only use to rectify "dirty"files (those with 3d information) from consultants...which is why we would select the entire drawing and flatten all at once).

Share this post


Link to post
Share on other sites
Dadgad

Glad you were able to figure it out.

I would suggest that you address any issues or conditions which may later prove to be problematic, within your blocks

before you insert them into your drawing.

But I suspect you have already figured that out too, especially as regards drawings received from

other vendors. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...