Jump to content
Syntax0111

Area Command Adjusts the UCS

Recommended Posts

Syntax0111

Hello everyone,

 

I am having a bit of an issue when using the AREA command. I've noticed that the UCS (User Coordinate System) changes when I attempt to take the area of an existing object (when I trace over a rectangle, for example). The changes to the UCS are dramatic, the drawing zooms out and rotates depending on how I traced the object. The change occurs when I click the third time. This reminds me of setting a new UCS where you would first select the x-axis direction with two clicks followed by the direction of the y-axis with one click. There is no change to UCS when I trace out an arbitrary shape.

 

Here's what I've been able to figure out and it involves the UCSFOLLOW setting. When I set the UCSFOLLOW variable to 0, everything works great and I don't get the zooming out and rotation. When it's set to 1, well, the PLAN VIEW changes by zooming out and rotating. If I zoom back in and complete the area and press enter, everything goes back to normal. So I still manage to get the area of the object that I want, but the zooming out and rotation makes it very inconvenient.

 

Okay, I understand that the UCSFOLLOW solves the problem, but is it normal for the AREA command to make changes to the UCS by default? I ask because creating a new drawing, creating a rectangle and using the AREA command doesn't cause the same UCS change, regardless of the UCSFOLLOW setting. This makes me think the drawing I am working on has objects with a coordinate system that differs from the WCS, right? Is there a way to have the UCSFOLLOW active while not having the AREA command alter the UCS?

 

If I left crucial information out, please let me know, and I'll elaborate!

 

I'm using AutoCAD 2012.

 

Thanks!

Share this post


Link to post
Share on other sites
Dadgad

Welcome to CADTutor. :)

You could get that information on the fly from QUICK PROPERTIES, regardless of your perspective.

area in quick properties works.JPG

Share this post


Link to post
Share on other sites
Syntax0111

Thanks for the reply Dadgad, I really appreciate your input. I am aware of the QUICK PROPERTIES and it is the method I use most of the time to determine an area. However, I deal with a lot of floor plans for work and I find myself having to determine the area of the whole floor or part of the floor that are not always necessarily perfect geometry (oddly shaped). So, I either have trace out the area with a Polyline and determine the area with its properties, or use the AREA command.

 

At this point, I'm trying to figure out, why the AREA command is affecting the PLAN VIEW (why my drawing is being rotated and zoomed out). I realize there are workarounds to this problem, however, I just want to get to the underlying problem at this point.

 

I really appreciate any further input.

 

Thanks!

Share this post


Link to post
Share on other sites
Dadgad

I tried to duplicate the behavior you describe, but couldn't get it to do anything but stay put and tell me what I wanted to know.

I have never used the AREA command before.

I tried using OBJECTS which had been rotated quite randomly, off axis, and from a totally arbitrary view twisted UCS.

It worked perfectly, never so much as twitched.

 

Looking through the SYSVDLG trying to figure it out, and I am putting this suggestion up from way downtown.

You might check the variable detailed in the attachment, and you might want to try changing VTDURATION to 0.

from way downtown re AREA command.jpg

Share this post


Link to post
Share on other sites
steven-g

Jumps all over the place, if you only have one object then nothing happens, it's having 2 (or more) on different planes that do it. And setting ucsfollow to 0 stops it. I can only presume someone thought it a nice idea to have the drawing align to the plane you are selecting points on (you can only determine a plane after 3 points) and area will only work on a plane. The results are the same either way.

Share this post


Link to post
Share on other sites
rkent

Three workarounds,

UCSFOLLOW = 0

OSNAPZ = 1 (if your object's plane is not parallel to the viewing plane you may not get the area of the object)

or

set UCS to the Z value of the object.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...