Jump to content

how to get the light rays for the lamp?


Recommended Posts

I try to do a draft render with no GI at all, but only VrayLight (placed in the lamp- Mesh type).

in the view port (set to: scene light with shadows enabled) this is what I get - see the image below


but after I render out, I get the ambient light probably from the vRay Exp. Control. What Im trying to achieve is the lightrays of the lamp just as shown in the view port. a downward set of rays with a high temperature light. what do you think is the problem?


I have tried this render with GI enabled as well, but it just gives illuminance to the whole. what's hard to get is the rays just like the action of real world downward lamps.



5885794362_b.jpgView Screen Capture

Link to comment
Share on other sites

The problem is not with your light, it's with the material you have applied to the lamp shade. You need to set your lamp material to be 2 sided so that the light does not emit out through the lamp shade. The renders below were done with Mental Ray, but the same principle applies.


Link to comment
Share on other sites

I just checked it was set to 2 sided but I anyway tried it with Vray2SidedMaterial as well, it's still the same. what's obvious here in this case is that the light is hidden in the render. what's the way to fix it? it seems that renderer takes it into as a hidden light so it doesnt shown it in the final image. I looked up every vray parameters in the render setup, I enabled all the options for hidden objects to be rendered. but no result !

Link to comment
Share on other sites

Well, you could try using a spotlight then, instead of an area light. I'm not familiar with Vray though, so I can't really offer any further assistance, and I don't think we have any Vray experts here?


There is a Vray forum over at CGArchitect that is fairly active. You might want to sign up and post your question over there: http://forums.cgarchitect.com/99-v-ray/


Good luck, and let us know if you figure out how to fix this problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...