Jump to content
dznytoy

change my drawing units to millimeters

Recommended Posts

dznytoy

I have some drawings that are drawn in millimeters. I need to add to the drawings but when I type 36 I get a line 36" long. I need to change autocad so that when I type 36 it draws a line that is 36mm.

 

Thanks for any help.

 

Dznytoy

Share this post


Link to post
Share on other sites
chrisdarmanin

type units in the command line and change it from there

Share this post


Link to post
Share on other sites
dznytoy

I have tried that. When I type units and the dialog box opens I change the units dropdown menu to millimeters hit ok and go back to the drawing, I draw a line with a length of 36 and I get a line of 36" long, when I need it to show 1.417" if I am deminsioning it in imperial.

 

by the way I am also drawing this in model space as this is how the original drawings were sent to me.

 

Thanks for trying.

 

dznytoy

Share this post


Link to post
Share on other sites
dbroada

it sounds to me that they are only dimensioned in mm, not drawn in mm. Scale your original object by 25,4 to convert it to metric size. Now you should be able to draw a 36mm line.

 

For dimensioning you can set up Alternative Units with a factor of 25,4 (or 1/25,4).

Share this post


Link to post
Share on other sites
Norts

try looking at LUNITS in the AutoCAD help file.

you may well think you have set the units to millimetres. when in fact all you have set is InsUnits.

 

Units can be tricky to work with, if you are not sure with what is going on, or if something is different to what you are used to working with.

you may also wish to read the following thread, with a different potential solution:

http://www.cadtutor.net/forum/showthread.php?t=2694

Share this post


Link to post
Share on other sites
dznytoy

Maybe this picture will help show what I am trying to do.

untitled.jpg

Share this post


Link to post
Share on other sites
eldon

It would make matters clearer if you consider that you are drawing in AutoCAD in drawing units. You can assign your drawing units as miles or millimetres, but you draw a line as so many units.

 

Your drawing sounds as if it were drawn in inches, because when you draw a line of 36, you get a line of 36 inches. Dimensioning can be scaled to show millimetres.

 

If you need to add to the drawing in your chosen drawing units, you must scale the whole drawing. It is useful to draw a reference line, so that you can scale by reference to this line which must be 1 unit in one set of units and 25.4 units in another set of units.

 

When you scale a whole drawing, all layers must be turned on, unfrozen and unlocked because you have to select what is to be scaled. Also dimensions do not scale well with the arrows not altering. If the dimensions are not to be altered, they can be exploded and then they scale nicely.

 

You can also scale all your additions, but it makes a lot of maths!:)

Share this post


Link to post
Share on other sites
iain9876

might be better if yu started with a new template drawing and set up your units from .

File -> new -> template

set your units etc...to mm, then draw a line in mm.

 

Set up your dimension style to mm, then dimension the line.

 

to set up your dimension style its menu item dimension...then style...then new or modify..then set it to current.

Share this post


Link to post
Share on other sites
Tconn

How about changing your units to "unitless"? I had this problem last year when trying to combine imperial and metric drawings. I changed both files to unitless and it worked fine.

Share this post


Link to post
Share on other sites
dznytoy

Thanks for the help. But I have to stay using the same drawing I am just trying to modify it. Once I am done with the drawing I save it as a .dxf file for some machinery to read from. The only way it seems that I can do this is to draw what I need and then running scale and set to a factor of .03937. Which brings it to the millimeter units that I need. When I goto units and make changes nothing seems to change.

Share this post


Link to post
Share on other sites
dbroada

which is what I was trying to say above. You still have an imperial drawing there. UNITS doesn't change the size of the drawing. It controls certain formating information.

 

I find using SCALE and REFERENCE easier than scaling by 0,03937. Once you have selected your drawing and base point, when you are asked for scale type R followed by 25.4 and then 1. It is the same as what you are doing but I find 25,4 a lot easier to remember.

Share this post


Link to post
Share on other sites
ayhier
it sounds to me that they are only dimensioned in mm, not drawn in mm. Scale your original object by 25,4 to convert it to metric size. Now you should be able to draw a 36mm line.

 

For dimensioning you can set up Alternative Units with a factor of 25,4 (or 1/25,4).

 

Is there a way where I don't have to scale the drawings?. I have the same problem. when I draw a line it looks fine but when I have to plot and scale my drawings it's on Inches instead of meters

Share this post


Link to post
Share on other sites
Dadgad

Autocad defaults to IMPERIAL units.

Try using -DWGUNITS (include the hyphen),

hit F2 to enable you to see additional lines of commandline history.

Follow the prompts, read them and take your time. :)

Share this post


Link to post
Share on other sites
dblclkmatt
I have some drawings that are drawn in millimeters. I need to add to the drawings but when I type 36 I get a line 36" long. I need to change autocad so that when I type 36 it draws a line that is 36mm.

 

 

 

I know exactly what you're looking for since I will have half a dozen imperial dimensioned parts, and get a few parts that are dimensioned as millimeter. My fix was to go to an outside program to convert the MM'd values to Inches, and then input the value generated into my drawing. It was such a hassle. Fortunately, I came across this post: http://forums.autodesk.com/t5/Drafting-Techniques/Automatic-scaling-of-drawing-input-lines-circles-and-other-basic/td-p/2627821

 

 

Where I found this handy little code:

;quick calculation of millimeters to inches
(defun c:mm ( / a)
    (setq a (getreal "Distance in mm: "))
    (/ a 25.4)
)

 

 

Entering MM alone in your command will calculate the dimension to inches quickly for you. And if enter 'MM while drawing a line, for example, then enter the millimeter value, it will draw your line out to the correct size.

 

 

Autocad defaults to IMPERIAL units.

Try using -DWGUNITS (include the hyphen),

hit F2 to enable you to see additional lines of commandline history.

Follow the prompts, read them and take your time. :)

 

Though I do like this as an option, it would be nice to have something similar to the above code, where you could switch it on when you need it to convert the MM to inches on the fly, and switch it off when you need to continue drawing things in inches.

Share this post


Link to post
Share on other sites
RobDraw

2006 dude.

Share this post


Link to post
Share on other sites
dblclkmatt
2006 dude.

 

Yep and it still appears in search engines. Anybody with the same question will now have different solutions to choose from.

I felt like sharing my findings for the people of the future.

 

Think of the children.

Share this post


Link to post
Share on other sites
CadDriver

I have a similar problem. I posted a thread last night and got one reply but now can't even find the thread to continue the conversation. My sincere apology.

My problem is that I can't even see mm in the list when I enter -dwgunits

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×