Jump to content
macsee

Layout tab's viewport scale box won't show standard scale menu.

Recommended Posts

macsee

Hi Everyone,

 

 

Situation: I created a 3d isometric view of a 1/2" pvc prototype assembly I made. In model space, I'm using block attributes to label fittings and pieces to create a parts list.

 

Problem:

In layout tab I can zoom and set up my view pretty much as I want. The view scale box in status bar shows the decimal value for the zoomed view but when the view scale box is clicked on, the standard scale menu does not appear and I can't figure out why. :cry:

 

 

 

When I go into the properties palette for the viewport the Standard Scale box shows Custom. When clicked on, the full standard scale appears but when I set it to any value other than Custom the value momentarily sets then resets back into Custom. :?

The annotation scale entry in the viewport properties palette for the attribute blocks can be set without a problem.

 

I have a feeling there's a simple explanation (setting) for this but search as I might I can't find an answer. Any answers/suggestions for where to look further is greatly appreciated.

 

Using Autocad 2014.

 

Thanks,

macsee

Share this post


Link to post
Share on other sites
Dana W

Is your viewport display locked? That may explain why you can't change the scale. The Standard Scale field on the properties sheet will display Custom any time the actual scale of the viewport does not match any of the scales in the scale list, ie. some scale you randomly zoomed to.

Share this post


Link to post
Share on other sites
macsee

Dana W,

 

Thanks for your reply. The viewport display is unlocked. I can change the scale but only via zooming either by the scroll wheel or Zoom command. The scale value in the view scale box in the status bar does change as I zoom but when clicked on, the view scale box won’t show the standard scale list.

 

Your comment:” …properties sheet will display Custom any time the actual scale of the viewport does not match any of the scales in the scale list…” gave me an idea.

 

I want to set the scale to 1:8 and I am able to get it close via the scroll wheel zoom (0.1287…). I used the Zoom command and set the Scale (nX) to a value that resulted in exactly 0.125 or1:8. Now the view scale box value displays 1:8 (but still won’t show the list) and the Standard Scale field on the properties sheet displays 1:8. When I click on that field the standard scale list appears but when I choose any other value, say 1:4, the field value changes momentarily and immediately resets back to the 1:8 value. Meanwhile, the viewport itself blinks as I change the value indicating it’s setting/resetting, i.e., adjusting according to the field value as expected.

 

In short, I can get my view to a standard scale but only through the convoluted process of Zoom command and setting the Scale factor to result in the desired standard value.

 

This doesn’t happen in any of my other drawings... weird!

 

 

Thanks again for your input.

 

 

macsee

Share this post


Link to post
Share on other sites
Dana W
Dana W,

 

Thanks for your reply. The viewport display is unlocked. I can change the scale but only via zooming either by the scroll wheel or Zoom command. The scale value in the view scale box in the status bar does change as I zoom but when clicked on, the view scale box won’t show the standard scale list.

 

Your comment:” …properties sheet will display Custom any time the actual scale of the viewport does not match any of the scales in the scale list…” gave me an idea.

 

I want to set the scale to 1:8 and I am able to get it close via the scroll wheel zoom (0.1287…). I used the Zoom command and set the Scale (nX) to a value that resulted in exactly 0.125 or1:8. Now the view scale box value displays 1:8 (but still won’t show the list) and the Standard Scale field on the properties sheet displays 1:8. When I click on that field the standard scale list appears but when I choose any other value, say 1:4, the field value changes momentarily and immediately resets back to the 1:8 value. Meanwhile, the viewport itself blinks as I change the value indicating it’s setting/resetting, i.e., adjusting according to the field value as expected.

 

In short, I can get my view to a standard scale but only through the convoluted process of Zoom command and setting the Scale factor to result in the desired standard value.

 

This doesn’t happen in any of my other drawings... weird!

 

 

Thanks again for your input.

 

 

macsee

That condition isn't something I have run across. There may be some combination of settings or something different about the 2014 version that I haven't been exposed to. I guess we'll have to wait and see if someone more familiar with 2014 has an answer.

Share this post


Link to post
Share on other sites
macsee

Dana W,

 

The good thing about writing in forums is it forces me to think out in detail what the problem is. When I wrote:

 

This doesn’t happen in any of my other drawings... weird!

 

Well... not so weird, ouch. This was my first extensive (for me) drawing in 3d and I found that when the view is set to Perspective (right click view cube) the scale can't be accurate hence the standard scale list doesn't appear. Put another way, the perspective view is a custom scale.

 

In the viewport when I right click the view cube and set the view to Parallel, voila, the scale list can now be accessed via the status bar. I actually don’t care about the scale since I’m using the view for parts labeling only and the perspective view serves this purpose better by looking more realistic but I really wanted to know why it was happening.

 

Thanks for your replies,

 

macsee

 

Share this post


Link to post
Share on other sites
Dana W
Dana W,

 

The good thing about writing in forums is it forces me to think out in detail what the problem is. When I wrote:

 

This doesn’t happen in any of my other drawings... weird!

 

Well... not so weird, ouch. This was my first extensive (for me) drawing in 3d and I found that when the view is set to Perspective (right click view cube) the scale can't be accurate hence the standard scale list doesn't appear. Put another way, the perspective view is a custom scale.

 

In the viewport when I right click the view cube and set the view to Parallel, voila, the scale list can now be accessed via the status bar. I actually don’t care about the scale since I’m using the view for parts labeling only and the perspective view serves this purpose better by looking more realistic but I really wanted to know why it was happening.

 

Thanks for your replies,

 

macsee

 

Yeah, OK. Makes perfect sense now. I was thinking 2D because you were scaling. :facepalm: That's like trying to trace a photo. "What's the scale? I dunno, about >".;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...