Jump to content
ILoveMadoka

Extents or Printable Area Screwed Up??

Recommended Posts

ILoveMadoka

I don't know if this requires a lisp or a script solution..

 

I regularly work on multi-tabbed drawings.

I often encounter situations where on a tab, the extents

are much smaller than the title block.

The title block extends off/beyond the existing extents

(defined by the hidden/dashed line.)

Is that the printable area or the extents?

 

What I typically do is:

zoom extents,

Go to plot, change something such as:

unpick the fit to paper check box, pick it again (so that something changes)

Pick Apply to layout button

then hit Cancel.

The extents of the drawing then automatically change (or are updated)

to the correct extents of the title block.

(My dashed line now surrounds my entire title block.)

Regen or Regenall doesn't do it.

Zooming extents alone doesn't fix it either.

 

Having to do those steps on all 30 tabs of a drawing is a PITA. :cry:

 

Any suggestions or solutions that any of you are aware of?

Is there another way of accomplishing this?

 

I would SO APPRECIATE a workable solution...

Share this post


Link to post
Share on other sites
ReMark

Anything within the dashed line (i.e. - "printable" area) will be printed. Anything outside or even on the line will not be printed.

 

Can you attach a representative drawing?

 

What size paper are you printing to?

Share this post


Link to post
Share on other sites
ILoveMadoka

This is an example.

I can't post an actual dwg.

 

Layout6 is what I need all the layouts to end up like..

 

 

I am printing to 11x17.

trash.dwg

Share this post


Link to post
Share on other sites
ILoveMadoka

This just "happens" sometimes to drawings that were fine a day or so before.

I have one printing script that when it is done changes all the layouts

to this "screwed up" condition.

 

I encounter this enough to want to come up with some "automated" solution.

Whether that is lisp or a script I don't care.

It is just time consuming to fix.

One layout at a time..... sigh..

 

The title block I actually use was exported from Solidworks.

 

It doesn't happen with every drawing.

Hard to diagnose where the problem comes from

(outside of the one script that I don't use often)

Share this post


Link to post
Share on other sites
ReMark

You could copy the layout, delete the old one and rename the copy but doing that thirty times would be a bit of a pain.

 

Why don't you create a new titleblock/border in AutoCAD that will fit instead of using the one from Solidworks?

 

An option: Copy to Layout lisp routine by Lee Mac. http://lee-mac.com/copytolayouts.html All the layouts though would have to use the same size paper though.

Edited by ReMark

Share this post


Link to post
Share on other sites
rkent

A named pagesetup will allow you to make all the settings for plotting one time. This named pagesetup can then be used over and over.

 

So for example right click over the current layout tab, pick page setup manager. Pick New, give it a name and pick Layout6 in the "start with:" lower section. Make sure everything is the way you want it and hit ok, close. Now you can pick that pagesetup name for the other layouts.

 

Do this instead in the template you normally use and then it will always be there in new drawings. For existing drawings you can start the plot command and use the import function to point to the drawing and pagesetup name in that drawing.

Share this post


Link to post
Share on other sites
ILoveMadoka

This isn't when I start a new drawing. It just happens to existing drawings on occasion.

Actually the new drawings are perfect. It's when the plot area changes for some unknown reason.

Something can change it so I would "assume" something can make it right.

 

I have a "procedure" down to a 7 step fix.

 

7 x 35 = SUCKAGE!

 

Someone showed me how to turn off all the display settings for

Display Printable Area and Display Paper background that also "work."

Not what I was looking for either but maybe this isn't fixable

beyond what I have been doing anyway..

 

Thanks for the assistance...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...