Jump to content
DS-precast

iLogic rule to insert part parameters into dimension text in assembly drawing

Recommended Posts

DS-precast

I am trying to speed-up dimensioning of an assembly drawing (DWG) in Inventor using iLogic. The assembly contains parts which have parameters which I would like inserted into dimension text. I can achieve this manually using the Edit Dimension / Format Text dialogue boxes to select the part parameters and insert them into the assembly dimension text.

 

My iLogic rule can currently identify the part containing the parameters but when I attempt to write these to the dimension text, I receive an error message.

The part parameters are called “No_Risers” and “riser”. “partFileName” is the FullFileName of the Part Document containing these parameters.

 

The line which gives me the error message is the oDimensionText line :


[color=red][color=red][font=Verdana]If [/font][/color][color=maroon][font=Verdana]oPart[/font][/color][color=black][font=Verdana].[/font][/color][color=maroon][font=Verdana]ComponentDefinition[/font][/color][color=black][font=Verdana].[/font][/color][color=purple][font=Verdana]Material[/font][/color][color=black][font=Verdana].[/font][/color][color=purple][font=Verdana]Name[/font][/color][color=black][font=Verdana] = [/font][/color][color=teal][font=Verdana]"Concrete" [/font][/color][color=red][font=Verdana]Then[/font][/color][/color]
[color=red][color=maroon][font=Verdana]partFileName[/font][/color][color=black][font=Verdana] = [/font][/color][color=maroon][font=Verdana]oPart[/font][/color][color=black][font=Verdana].[/font][/color][color=maroon][font=Verdana]FullFileName[/font][/color][/color]

[color=red][color=red][font=Verdana]End [/font][/color][color=red][font=Verdana]If[/font][/color][/color]

oDimensionText.FormattedText = "<Parameter Resolved = 'True'
ComponentIdentifier='" & partFileName & "' Name = 'No_Risers'
Precision = '0'></Parameter>" & " No. RISERS @ " & "<Parameter Name
= 'riser' Precision = '2'></Parameter>" & " = " &
"<DimensionValue/>"

 

(I have split the long line of code so it reads better on the forum. It is one line in the iLogic rule)

 

I have tried many variations of the above, but cannot get it to work. I can successfully write the parameter values to the dimension text, but these do not update if the parameters update.

 

I’m using Inventor 2013 Pro

 

Any help would be gratefully received.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...