Jump to content
Rosenkrans

Dimensions in dynamic blocks

Recommended Posts

Rosenkrans

I trying to make a dynamic block which includes linear dimensions.

Sometimes the dimensions are deleted completely, when I try to hide them in a visual state.

Other times the dimensions are visible in all states, even though it should only be visible in one state.

Share this post


Link to post
Share on other sites
steven-g

It should work OK, can you post a block, someone can try and see what is happening.

Share this post


Link to post
Share on other sites
Rosenkrans

Sure, here it is.

The dimensions I am having trouble with is the ones in the bottom.

The one on the side works like it should.

Plan.dwg

Share this post


Link to post
Share on other sites
dbroada

I think they are there, but tiny. I assume its to do with annotation scale but as I never use them I can't comment further.

Share this post


Link to post
Share on other sites
Rosenkrans

Sorry, I posted the wrong drawing.

Plan 2.dwg

Share this post


Link to post
Share on other sites
dbroada

are you sure that one is correct? The dimensions don't appear to be connected to anything.

Share this post


Link to post
Share on other sites
steven-g

You have used different parameters and different geometry in each visibility state, you also need to add different dimensions associated with each size, at the moment when you switch visibility state the dims lose the geometry they are associated with.

EDIT

The first dwg looks to work fine here, how where you getting it to break down?

Share this post


Link to post
Share on other sites
resullins

I agree with what Steven said. You've got dimensions that aren't connected to your visibility states properly.

 

I don't think he was having trouble with the first dwg, which is why he posted the second one. There are no VS in that one... so that would make sense that it would work.

Share this post


Link to post
Share on other sites
Rosenkrans

Thanks. It seemed odd though. I made the dimension and when I tried to hide it for a VS it sometimes was deleted and other times kept being visible in all states.

The I saved the drawing and closed it, opened it again and then I could hide it in the vs I wanted, without it being deleted or visible in all states.

Share this post


Link to post
Share on other sites
resullins

That sounds like an AC glitch to me... not a problem with your block.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×