Jump to content
Big Mike

Colors plotting as colors, despite ctb set to black.

Recommended Posts

Big Mike

I'm working on Autocad Electrical (recently updated to 2015).

I was previously using Electrical 2014 & 2013, and didn't have this problem. I normally use Mechanical and Inventor, so I'm not all that familiar with Electrical.

 

The problem is that when I go to plot, the print comes out in color, even though my pen settings are all set to black. I've been using the same ctb pen settings file for probably 15 years...and I triple checked that all colors were set to plot as black. But still, the plot comes out in color.

 

I did some searching and it looks like Autodesk added something about 'Truecolor'....where objects will plot as their true color, even if the pen settings are black.

 

Good grief, Autodesk....coming up with answers to questions that nobody has ever asked.

 

Anyway, the problem is that I can't figure out how to turn this 'Truecolor' off (if that is indeed the problem).

 

Any help?

Share this post


Link to post
Share on other sites
rkent

Go into the layer manager and make sure the layer colors are not set to Truecolors and are only set to index colors.

Share this post


Link to post
Share on other sites
Big Mike

Could you be more specific on that?

 

In the layer manager, the layer colors are all set to their usual index number. If I click on the color, it takes me to a window where I can choose/set the color. There is a tab for Index Color, a tab for True Color and a tab for Color Books. I don't see anywhere to set it to use the index color and not the true color.

 

Also, in the layer manager there is a column called 'Plot Style'....and each layer is set to 'Color_##' (## being the index number).

I would guess that this is where I could set the layers to plot by the pen settings style, rather than color...but this whole column is greyed out and not editable.

Share this post


Link to post
Share on other sites
rkent

In the layer manager it sounds like the Color column is showing color numbers like 2,3,10,42,254, etc. Those are index colors and should plot black according you what you have said.

 

Unless the colors have been overridden in a viewport or the viewport is set to a shademode other than 2D I don't have any other guesses for you.

 

Post the drawing or a small portion of the drawing. With the only difference being that you went to 2015 I don't know what else to suggest, but others will no doubt be along with some suggestions.

Share this post


Link to post
Share on other sites
nestly

Make sure "Plot with plot styles" is checked in the Plot dialog box, and also verify that the objects don't have color properties overrides applied as I believe object level properties superceed plot style settings.

 

... and yeah, a sample drawing is usually the fastest way to get a solution.

Share this post


Link to post
Share on other sites
Big Mike

I've spent a bit of time exploring the issue of color dependant plot styles vs named plot styles. I'm not sure if this is new to 2015 but it's something I've never run into in 20 years of doing this.

 

I used a few obscure commands to convert my ctb file into an stb file. I was trying to access the 'plot style editor' but every time I did....it just gave me a confusing error message.

 

Every setting I checked, should have meant that it would plot as black. All the objects are set to color by layer. All the layers were set to an index color. All the index colors in the plot style were set to plot as black.

 

Just to check, I tried choosing the 'monochrome' plot style....still came out in color.

 

After googling for a while, I came on a post somewhere that sounded similar. They guys issue was that it would work fine if the file was created in 2015, but not on older files that had been created in previous versions.

 

So I copied my drawing and pasted it into a new drawing....and bingo, that worked. As far as I can tell, all the settings are the same but it plotted as expected from the new file. I hope I don't have to do this every time.

 

What a waste of a morning.

Share this post


Link to post
Share on other sites
nestly

Assuming this is the related topic, did you read through the whole topic? The OP's issue was due to a corrupt CTB file (or at least a CTB that needed to be edited in order for 2015 to read it properly). Another user resolved the problem by changing LAYOUTREGENCTL variable

Share this post


Link to post
Share on other sites
gilsoto13

That happent a couple days ago. The problem was caused by the Viewport or viewports configuration. For some reason, it probably could have been changed to Shade or Realistic. What you can do is use the command Mview , then select shadeplot, then select Wireframe or Hidden, and then select the viewports in your drawing that are being plotted in color, and finish with Enter. Plot again and probably the problem is solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×