Jump to content
SAFeSTeR

Crosshair not flipping colour

Recommended Posts

SAFeSTeR

My model space is black and my crosshair is white and the opposite in paper space. It used to be that when my crosshair was on a white object it would flip to black, but all of a sudden it 'disappears'. This is quite frustrating and makes some tasks a bit harder especially when using osnaps.

 

I've not changed any colours except the AutoSnap marker, but this was ages ago so I know it's not that, I've even reset it just in case.

 

So, does anyone know what causes this problem and how to fix it?

Failing that, are there any workarounds?

 

Thanks in advance,

Safe.

Share this post


Link to post
Share on other sites
nestly

Defying all logic, it's graphics Hardware Acceleration that's preventing the crosshairs from inverting colors. Disable Hardware Acceleration and the crosshairs will invert colors automatically. I've been experiencing that problem ever since I upgraded from AutoCAD2005 to AutoCAD2011.

 

It's crazy that they've never fixed this problem but the only solution is to disable Hardware Acceleration (not a good option), or pick a crosshair color that contrasts with "most" of your environment. I've found tinting the crosshairs for X,Y,Z helps because with a multi-color crosshairs, one of the axis is usually visible regardless of what's behind the crosshairs.

Share this post


Link to post
Share on other sites
SAFeSTeR

Thanks nestly.

 

I found that setting in Options > System > 3D Performance > Performance Settings > Manual Tune and it worked.

Do those settings only affect 3D performance? I only work in 2D so it may not be an issue for me to turn Hardware Acceleration off.

 

Why did my system suddenly change? Was Hardware Acceleration disabled by default and somehow enabled itself, or is it a bug with this feature that causes it to happen?

 

If it's not a good idea to turn HA off then perhaps the tint option would be best, doubt that will take long to get used to.

Share this post


Link to post
Share on other sites
lamensterms

Just wanted to follow up on this and see if there was any new solutions.

 

With hardware acceleration on, the cross hair colours do not invert. When disabling hardware acceleration, the crosshairs do invert colours - but a side effect is that the crosshairs flicker when moving the cursor around.

 

Looking forward to hearing back.

Share this post


Link to post
Share on other sites
RobDraw

No solution that I am aware of. I've never seen my cross-hairs color invert when over an object of the same color.

 

Actually, you can change the color to something that is not used.

Share this post


Link to post
Share on other sites
dtkell

I've had this problem from time to time, and these are the couple of tips I've found that most often remedy the situation in the current instance as an alternative to disabling hardware acceleration.

CROSSHAIRS DISAPPEAR

When crosshairs disappear, use 'VSCURRENT' and change to 'Wireframe' from whatever it is. Then switch it back. OR All you have to do is a quick save (ctrl+s) and there it is!

They don't always work, but a restart usually brings crosshairs back to normal.

Share this post


Link to post
Share on other sites
SLW210

I just select the Tint for X, Y, Z box.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...