Jump to content
daczac

Canceling Object Selection / AutoCAD Processing

Recommended Posts

daczac

I am working on a drawing with very large polygons with hundreds of verticies. When one of these polygons are selected, either purposely or by accident, it takes a considerable amount of time for the selection process to run its course. I have tried to turn off properties but that didn't help. Ultimately it would be ideal if you could escape out of this selection process if you decided you did not want to wait. Unfortunately the escape key works only after the selection process ends and the verticies are visible. AutoCAD is locked up until the selection process ends. Is there another way to cancel or escape while AutoCAD is processing a selection such as this?

Share this post


Link to post
Share on other sites
jarr3tt88

Have you tried to show less grips? That might help, its under options, selection tab, then near the bottom theres an input for how many you want to show. I have 1000, maybe you'll want less.

Share this post


Link to post
Share on other sites
daczac

My "Object selection limit for display of grips" is set already to 100 so I don't think that is the issue. What would be most helpful, regardless of any setting, is to have a "kill switch" to abort the AutoCAD process and a return to the command line.

Share this post


Link to post
Share on other sites
Dana W
My "Object selection limit for display of grips" is set already to 100 so I don't think that is the issue. What would be most helpful, regardless of any setting, is to have a "kill switch" to abort the AutoCAD process and a return to the command line.
The "Object selection limit for display of grips" thing limits how many objects will show grips, not grips per object. If you select more than the limit, grips don't show. Even if you set the limit to one, and that one object has 10,000 grips, like a spline, you will still see them.

 

There is no "Kill Switch" for a command that is off crunching numbers and making you wait. Even if there were, it would not even see it until the current background process was finished. At that point, the Esc key will work, but that is normal.

 

This sounds like it could be a either a barely adequate graphics card, or physical memory, or both. At the very least, those two things are limited in capability to handle this particular drawing.

 

Have you tried the typical steps to clean up the drawing? Run -purge with the hyphen. Don't ask it to confirm each item, you will be there all day, hitting enter. Get rid of regapps first. Then run it to get rid of other unreferenced junk afterwards.

Run the Audit command and let if fix any errors.

 

Run Overkill to get rid of duplicate lines and objects stacked on top of each other.

Share this post


Link to post
Share on other sites
daczac

Thanks... I have run purge and audit but only improves the situation ever so slightly. My best course of action thus far is to toggle the grips off entirely. This does make a significant difference in background number crunching time but is not the most ideal solution. Thanks for your help...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...