Jump to content
DataLinkQ

Excel Data linking; Table wrapping text format issues

Recommended Posts

DataLinkQ

Hi everyone,

 

Setup;

 

OS: Win 7 Pro X64

Product: AutoCAD 2015 Electrical

CPU: i7

Graphics: AMD FirePro M6100 FireGL V

Ram: 16GB

 

Problem;

 

I've created a datalink table to an Excel spreadsheet, and I'm only having issues with tables that required a break (table wrapping).

 

Once I break the table and setup text properties; text height, alignment, headers, cell widths. Everything looks okay until I close and open the drawing.

 

The first half of the table remembers the settings, but the second half always reverts back to .5 text height and top center alignment (headers and cell width are still in place on the 2nd part of the table)

 

Solutions I've tried;

 

I've tried to do the formatting before I break the table, I've tried after its broken. I right clicked on the tables and "Remove All Property Overrides" which makes the text all crazy, so I setup text properties, qsave and close. once I open the drawing text height and alignment changes again. If I try to "Remove All Property Overrides" the text doesn't change, so I think that function worked correctly.

 

Summary;

 

How can I get the 2nd half of the datalinked table to remember all property settings?

 

I'm out of ideas :(

 

Does anyone have some other solutions to try?

 

Thanks for your time.

 

-DataLinkQ

Share this post


Link to post
Share on other sites
Ski_Me

Once you break the table the external link for the part you break is severed. While the text will remain the formatting is gone. I did the same thing and had the same result as you. I just created a new second table and imported it. But the amount of data I had in the table was not very much you situation maybe very different from mine.

Share this post


Link to post
Share on other sites
DataLinkQ

Thanks for your reply. I might have to do the bigger tables separately if there isn't a way to force the formatting.

Share this post


Link to post
Share on other sites
RobDraw

I do most of my formatting in Excel. Would that be possible in your situation?

Share this post


Link to post
Share on other sites
DataLinkQ

Hey RobDraw,

 

Yes I've tried that, but the 2nd half still forgets its property settings.

Share this post


Link to post
Share on other sites
RobDraw

I'm not familiar with table breaking and didn't fully understand your OP at first.

 

Has that ever worked for you?

How about setting up named ranges in the Excel file?

Share this post


Link to post
Share on other sites
DataLinkQ

No, this is my first time trying this feature.

I have a BOM, and when its too long to fit in the title block, you can resize it, smaller; as you resize the table auto-breaks into 2 tables so you. when you highlight either table, both tables highlight as if it was 1 entity. in order to break the table, you just need drag the re-size arrow on the bottom of the table.

 

Starting to think its a bug.

Share this post


Link to post
Share on other sites
ReMark

Are you doing this in AutoCAD Electrical or plain AutoCAD?

Share this post


Link to post
Share on other sites
DataLinkQ

ReMark, AutoCAD Electrical.

Share this post


Link to post
Share on other sites
ReMark
ReMark, AutoCAD Electrical.

Why aren't you using the built-in REPORT feature then?

Share this post


Link to post
Share on other sites
DataLinkQ

Daily changes to big lists is easier to manage with excel spreadsheet rather than a feature that requires lots of preparation.

Also, REPORT cannot sort by tags.

Share this post


Link to post
Share on other sites
HectoCAD

Hi DataLinkQ,

Quote

The first half of the table remembers the settings, but the second half always reverts back to .5 text height and top center alignment (headers and cell width are still in place on the 2nd part of the table)

 

What is happening is that AutoCAD resets all formatting you do to DATA cells after the table-break.  The solution is to format the table style settings.  Follow these steps:

 

1. Type TABLESTYLE the Table Style dialog should pop up.

3. Select the table style you are using then click Modify.

4. Make sure Data is selected on the Cell Styles.

5. Under the General Tab select your desired alignment and margins

6. Under the Text Tab select your text style and text height.

7. When you're done click OK, then Close.

8. Save your drawing and close.

9. Open your drawing and the table format should remain.

 

- Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...