Jump to content
jonathanpiette

Export dwg from Sketchup.Problem with attributs created on every groups.

Recommended Posts

jonathanpiette

Hi drafters, hope you can help me with that one. It's a question concerning Autocad but also sketchup.

 

When I export a 3D model to dwg, and I open it with autocad, I notice that sketchup (or acad) have created an attribut for every group in the model. So I can see little text everywhere saying GROUP #345, GROUP#267.. etc.

 

Doesn't seems to do it with component, only with groups.

 

This is a bit annoying. Mostly when you have a lot of blocs, into blocs, into blocs... I struggled in cad to find a LISP able to delete all nested attribut. I found a few. Mostly by using ATTOUT and ATTIN command but so far... no success. Most of LISP (like attdel.lsp) give me error message. And when I try removing the attribut in the bloc. Cad can't find it... even with QSEL. The only tric I found is to rename the attribut with a space, so nothing is shown in the drawing. But this is only a bandaid... not a real fix!

 

Any idea!

Share this post


Link to post
Share on other sites
f700es

Hi Jonathan, I just tried this and I am not seeing any attribute text with mine. I see you are using Acad 2012, what version of SU are you using? What are your settings for DWG export in SU?

Now mine does have an attribute with the block but there is no value with it to show on screen. See attached jpg.

 

Sean

 

Screenshot_1.jpg

Share this post


Link to post
Share on other sites
jonathanpiette

Hello Sean, thanks for your reply. You just proposed nice bandaid, but not a fix. I think there is no way you can removed the attribut on the group... but you can give to the SKP group, a value of none, IN SKETCHUP. That imply renaming every group before you export.

 

I ran a small test. Check my outliner sketchup structure. When it's wrote only Group, that's because this group have no name. Acad will assign a group number but it will be no value in the attribut, just like your example. If you give a name to the group, like the one I called: Name Group... you will have the attribut value: Name Group. Once in cad, only the named attribut group (pyramid) have the visual attribut.

 

I don't know if there is a real fix for that but not having name for my group doesn't really bother me. I can cope with that. It's just a shame if you want to keep your drawing structures when using the outliner. But anyway, I rarelly have time to rename everything.

 

It's much more simpler to rename group in SKP than edit bloc in edit bloc in edit bloc in acad.

 

It would be nice if Sketchup simply add an option in the export option window to not create attribut. I know that Trimble (owner of Sketchup) have another software called Tekla who does the exact same thing. I don't see in any circonstance why anyone would need an attribut in their 3D model!! If also I can find a LISP to remove all attribut at once, would be nice, but all my attemp had failed.

 

For that test, I ran Autocad 2014 and Sketchup Pro 2014. Check png in attach.

 

Test att dwg.jpg

Test att skp.jpg

Test att options.PNG

Test att dwg zoom.jpg

Share this post


Link to post
Share on other sites
f700es

OK what if you go another way? What if you use AutoCAD's import SketchUp utility? You have to install it from the AutoDesk App Exchange (free). I tried it and I don't see any attributes this time. I even gave one group a name before I brought it into Acad 2015. Sorry that I am not much help. I usually go the other way, from ACAD in SU.

 

Sean

Share this post


Link to post
Share on other sites
jonathanpiette

That's an interesting approach, didn't know you can do that. I'll try that and give you feedback.. thx

Share this post


Link to post
Share on other sites
jonathanpiette

Hey Sean... it works.... First it failed... so I try saving my skp in 2013: failed again.. then saved in skp8: it works! No attribut at all. I also try with a big project I have, then it works too.

 

That's a fix... not a bandaid. You made my day!

 

BIG THANKS SEAN.

Share this post


Link to post
Share on other sites
f700es

Duh, I should have pointed out that I also had to save as v8 for it to work, sorry about that. Cool, that it got you the results you were looking for. Hang around more as I am sure you can teach us a few tricks as well.

Cheers :)

 

Sean

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...