Jump to content

Recommended Posts

OK, It's more complicated than that...

 

I'm working through a tutorial on linking parameters to an Inventor part. I have a spreadsheet set up to drive a regular box shape. My parameters are WIDTH, LENGTH, and HEIGHT.

 

I am in the base sketch where I'd like to set d0 and d1 to WIDTH and LENGTH respectively. How do I find the two existing parameters please? I have looked both in the sketch and out on the workspace. If I try to add a dimension, it comes in as d3.

 

The gentleman doing the video just magically clicks on the edge of the rectangle and d1 appears, ready to be edited.

 

TIA

Bill

 

Param_Sketch.jpg

Share this post


Link to post
Share on other sites

...it appears to not matter. I went back into sketch mode. I place dimension d4. I don't know why it numbered "up", as I don't think I ever placed d3 completely. I tried to rename d4 to WIDTH. I got error message "The expression cannot be evaluated".

 

Then I linked my Excel spreadsheet and it let me rename d4 to WIDTH. I placed d5 and made it LENGTH. Both dimensions updated to the spreadsheet values.

 

I went back to the 3D Model workspace and extruded it. Instead of entering a dimension, I typed in HEIGHT. It worked.

 

I'm still wondering how the tutorial person got d1 to drop in automatically though.

 

Param_Sketch2.jpg

Share this post


Link to post
Share on other sites

Hindsight, I think each part file makes its' own set of "d0" parameters. I had used the first couple and deleted them. It restarted and went forward numerically rather than trying to reuse blank existing ones.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×