Jump to content
RobDraw

True Type Fonts Slowing Down Drawings

Recommended Posts

RobDraw

Hi all,

 

This is my first post.

 

Using ADT3.3/ XP Pro/ P4/ NVIDIA GeForce Vid Card

 

I've been researching this problem for a while now and have not been able to come up with a clear reason or simple solution.

 

When an XREF has true type fonts, drawings referensing it slow down proportionally. The more objects using TTF's, the slower the drawings get. The reference drawing does not slow down at all. Just the referencing drawings. I know that it is the TTF's because eliminating them "cures" the problem. Although eliminating the TTF's is not too difficult, it is time consuming. The slowness is most noticable when selecting any object and having to wait for the grips to appear. This delay is proportional to the number of objects in the XREF containing TTF's.

 

I would like to be able to use the TTF's for consistency as they are on drawings from an outside source that we use for backgrounds. Our workstations, although not super, are relatively new and should be able to handle the added load to the graphics card that TTF's can demand.

 

Any information on this issue would be greatly appreciated.

 

Thanks,

Share this post


Link to post
Share on other sites
tzframpton

I am not familiar with your version of ADT, but try this (this is what i do):

 

type QSELECT at the command line, when the dialog box comes up, under Object Type, select MTEXT. under the Operator pull down box, select "Select All" and click OK. this should grab all the MTEXT (which is what TTF fonts are used in) in the drawing, and just EXPLODE it to bring them to a *.shx font file.

 

I do this to all my drawings because i don't like not having control of lineweights of text, and also it can cause a performance issue at times, when i have loads of TTF's as well.

 

Hope this helps, and welcome to the forum. :)

Share this post


Link to post
Share on other sites
RobDraw

Thanks, but I have been able to eliminate the TTF's by changing the text styles and using a lisp routine to remove the TTF's from individual MTEXT objects. Many of the MTEXT objects in these files have the font assigned individually overiding the font style. (Why they do they do that? I just don't understand that one.) It would save me a lot of time if I didn't have to do that. This particular project is quite large with many XREF's to cleanup with each update. If I knew more about why this happens, I might be able skip that part of the cleanup and use these fonts.

Share this post


Link to post
Share on other sites
eldon

Have you tried QTEXT command?

 

When this is set to on, all the text is shown by a bounding box, and the actual text does not have to be regenerated each time. :)

Share this post


Link to post
Share on other sites
Polisson

Thread has 10 years old! Did you know, that since last post in this discussion, users didn't came with reasonable solution across all of the Internet? Issue persists in Windows & AutoCAD world.

 

I've found main cause of laggy select xrefs with TTF's.

The solution is simple:

all MTEXT objects should have using basic TTF's from Microsoft (like Arial, Tahoma, Verdana),

or additional, special font is used must have installed all types (normal, bold, italic).

 

Example: xref has layer with 2,5k MTEXT objects with font EFN Technic set by textstyle with italic option. If your windows has this font only as bold type, AutoCAD has to render it so selection cause lag.

 

BTW other CAD apps, doesn't have any similar effects and work smoothly.

Share this post


Link to post
Share on other sites
RobDraw
Thread has 10 years old!

 

But you had to dig it up from the dead.

Share this post


Link to post
Share on other sites
iconeo

Which is why AutoCAD needs to be multithreaded and will eventually just be left behind.

 

Sent from my SM-G930T using Tapatalk

Share this post


Link to post
Share on other sites
RobDraw

This horse is dead. Please move on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×