Jump to content
MichaelAllfire

Command Line issues - "The object is an external reference"

Recommended Posts

MichaelAllfire

Hi all,

 

When using certain commands, my command line repeatedly displays "The object is an external reference" when mousing over an external reference.

 

For example, if I use the Line command, and go to snap over part an external reference, the command line will display "The object is an external reference" when I mouse over any part of the reference, quickly filling up my command line box. This is particularly painful if I have just used the distance command, and am using the info straight out of the command line box.

 

I have looked for xref commands that might be to blame, but have had no luck. Any thoughts?

 

Thanks in advance! :)

Share this post


Link to post
Share on other sites
Dadgad

What visual style are you using?

Are you working in an Ortho perspective?

 

Try using 2D Wireframe visual style, if you are not already.

Perhaps you might want to try using Dynamic Input, there are a number of available options as to how information is displayed.

Share this post


Link to post
Share on other sites
MichaelAllfire

Hi Dadgad,

 

Currently using 2d wireframe style already. It only started happening this morning when I loaded up a drawing, not sure if I accidentally turned on a setting or what.

 

Turning Dynamic Input off results in the same issue, no change.

 

Thanks for the suggestions! :D

Share this post


Link to post
Share on other sites
Dadgad

If it just started today, have you tried rebooting?

Have you experienced the problem with other drawings, or just the one?

 

 

If you have already rebooted, and no help, might you have an .svf (system variable file) saved against just such an eventuality?

If you don't, you should have one, as a safety for future use.

Share this post


Link to post
Share on other sites
MichaelAllfire

The issue is across multiple drawings, and yeah, reboot didn't do anything to fix it, so my assumption sits on a particular setting.

 

I'm not familiar with svf files, so I'll look into that for the future. Cheers for your assistance anyway!

Share this post


Link to post
Share on other sites
Dadgad

If you run the SYSVDLG command, you will see the option to SAVE ALL at the bottom of the dialog box.

That will create a .SVF file which will comprise of all of the system variable settings at the moment you create it.

Name it appropriately, and store it where you will be able to find it.

In the future you can very easily restore all of your personalized system variable settings, with no muss nor fuss.

In order to restore all DEFAULT Autocad system variable settings, one can use the READ button in the bottom of that same dialog box.

 

Don't use that one, if you have personalized your variable settings.

You can use that personalized .svf file later to share your settings with a coworker or team, or install those settings on another machine.

Edited by Dadgad

Share this post


Link to post
Share on other sites
Dadgad

What is your GRIPBLOCK setting?

If it is , set it to .

Probably not your problem, but worth checking. :|

Share this post


Link to post
Share on other sites
jagwinn

I was wondering if this issue were solved?

Share this post


Link to post
Share on other sites
PBergerTKG

I was having the same issue that the original poster asked about and I believe it is related to the Dynamics UCS setting/system variable.

 

Hovering over the icon in question, I get a pop-up display with two lines the first line listing "Snap UCS to active solids plane - On" and the second line listing "Dynamics UCS - UCSDETECT (F6)". After changing the setting to "Off" I no longer see the line "The object is an external reference" appear in the command line.

 

If you use the function keys on your keyboard to turn settings on and off like I do, you may have just accidentally hit F6 and turned this setting on. Hope this solves your problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×