Jump to content
jaff

UCS in AutoCAD LT 2017

Recommended Posts

jaff

I have an exported DXF file from Risa 3D model however when I open the file I only see a line and is because the UCS in the DXF file is not in "World" how to I make the UCS to be the same as the default from a new drawing?

RISA EXPORT TO CAD EAST ELEV.dxf

Share this post


Link to post
Share on other sites
Cad64

I opened your file and the UCS is set to World. What are you trying to do?

 

Here's what I see when I orbit around your drawing.

Untitled-1.jpg

Share this post


Link to post
Share on other sites
jaff

What I am trying to do is to view the entire structure of the frame in the xy plane in lieu of the profile view (just a line view in the xy plane, I hope that make sense). see attached

InkedEast Elev._LI.jpg

Share this post


Link to post
Share on other sites
jaff

Thanks CAD64 but changing the vertical axis in Risa is not practical, I will need to do the frame from scratch. I thought it will be easy to change the ucs in cad.

Share this post


Link to post
Share on other sites
Cad64

It's just the export setting that you're changing, so that when you export your structure, the "Up" axis will get flipped and it should import into Autocad correctly. You're not changing anything in the Risa 3D work environment.

 

As for the UCS in Autocad, there's nothing to change because it's already set to World. It's the imported structure that's flipped on end.

 

Just try it and see if it works. You can always set it back if it's a problem.

Share this post


Link to post
Share on other sites
jaff

I tried it and it does not work. Thank you for the help

Share this post


Link to post
Share on other sites
BIGAL

What you want is rotate3d but thats not in LT.

 

If LT supports UCS set your UCS to the plane of the frame then use copy clipboard go to a new dwg and paste it will paste as world.

 

3rd attempt I will try to find set ucs to plane for you and add to the dxf as its so short, trying to get this to work but not sure what I am missing.

 

4th is rearrange the dxf changing the values it is very short so could be done.

 

This works so need to work out which bits to cut out. It has the current UCS set to the Z plane and it has a name ZZZZ. So UCS R ZZZZ PLan

test.dxf

Edited by BIGAL

Share this post


Link to post
Share on other sites
steven-g

You need to use the UCS command, LT doesn't have some of the tools used in full Autocad and so you have to use what there is. Set the variable "ucsfollow=1", then type "ucs" followed by enter next "left" from there select everything and copy everything with a base point of 0,0 "Ctrl+shift+C". Select everything again and delete it.

set the drawing back to "ucs" "world" and now paste using 0,0 as the insertion point (if everything is mirrored then change the command to "ucs" "right" in the first step above), in fact you can choose between world (or top), left, right, front, back, and bottom, which are not shown at the prompt. You'll also find these on the ribbon and menu.

Now you will need to rotate everything.

But this is just the start of your problems, in Autocad, there is something called "normals" (it's a difficult subject to cover in 5 minutes but it's there and your geometry is mixed up), and so all you're geometry from the other program is just about unusable for a lot of things in Autocad or could at least potentially stop some commands from working. You really need to look at CAD64's advice and look at the settings in that other program.

Share this post


Link to post
Share on other sites
BIGAL

Nice one steven-g I used UCS 3 for testing did not think about erasing then paste to world, which is the same method as paste to a new dwg. This is much simpler than trying to change the ucs via the dxf.

Share this post


Link to post
Share on other sites
Cad64

Seems like a lot of excessive jumping through hoops when the original 3D program should be able to export a usable dxf file to open in Autocad. I sometimes have to deal with this issue when moving from one program that utilizes a "Y" axis up work environment to another program that uses a "Z" axis up work environment. Usually you just change the setting in the Export options and it provides a seamless transition between the two programs. Not sure why it isn't working the same way with this Risa 3D program? :unsure:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×