Jump to content
masterfal

commands not entering properly

Recommended Posts

masterfal

Hi All,

 

I have this strange issue where when I type a command into the command line and press space bar/enter, it doesn't actually enter it until I press space bar a second time. If I pause for a moment before pushing space bar it works. As you can imagine this is slowing down everything I do quite a lot and its becoming increasingly frustrating.

I do run a set of lisp routines with every drawing but as another staff member is running the exact same lisp routines and he doesn't seem to have this same issue, I don't think that's the cause of the problem. I tried entering commands the same way I normally would on his machine and it seems to work as it should.

If anyone has any ideas of possible solutions I could try it would be much appreciated

Share this post


Link to post
Share on other sites
Dadgad

You might want to check your settings at the commandline, on the left end, click on the little wrench.

Check your INPUT settings.

Might you have DELAY TIME turned on?

 

I personally enjoy using Time-sensitive right clicking which can be accessed from the User Preferences tab in OPTIONS under Right-Click Customizations.

Share this post


Link to post
Share on other sites
masterfal

Nope, no delay time. I've tried turning autocomplete off previously as well as I thought that may be causing delay while its trying to autocomplete, but that didn't seem to change anything

Yeh I've played around with the right click menu delay before. Can never get it just right. By default though I think everybody should have right click to always repeat prev command. Such a time saver!

Share this post


Link to post
Share on other sites
masterfal

have just noticed i can enter commands quickly if i use right click instead of space bar. drafting that way doesn't feel right though. reminds me of when i'm trying to write or throw with my wrong hand.. haha

Share this post


Link to post
Share on other sites
Dadgad

Personally I prefer doing it that way, because whenever I have to take my hand off the mouse I feel like I am losing time.

 

I find it better to be able to do two different things with the right click.

Share this post


Link to post
Share on other sites
masterfal

hand never leaves the mouse.. one on keyboard, one on mouse. rarely need to use 2 hands on keyboard. only time is if theres a long command really. and if that's a regular command i'm using i'd just make a lisp/shortcut for it so its 2 or 3 letters instead of any more than that

 

i'd use 2 hands then too i guess if i'm typing out some notes too i guess. bit silly using 1 hand for that haha

Share this post


Link to post
Share on other sites
Dadgad

Most of my custom shortcalls are multiple hits of the same key, saves a lot of time.

Share this post


Link to post
Share on other sites
jUNI0R

Have you tired typing INPUTSEARCHDELAY on the command line, and than changing the value to 500? I was having the problem where i would type a lot more quicker than the command line could keep up and when i changed it to this, it worked like a charm. It might not be the same issue you are having but its worth giving it a go.

Share this post


Link to post
Share on other sites
Dadgad
Have you tired typing INPUTSEARCHDELAY on the command line, and than changing the value to 500? I was having the problem where i would type a lot more quicker than the command line could keep up and when i changed it to this, it worked like a charm. It might not be the same issue you are having but its worth giving it a go.

 

Sounds like it would be worth trying, can't hurt, you can always change it back. :beer:

 

You could also try turning off any of those commandline input options which you don't think you need.

Edited by Dadgad

Share this post


Link to post
Share on other sites
masterfal

What you mentioned sounds exactly like my problem. typing to quick

INPUTSEARCHDELAY was already set to 500 though

I tried changing to 200. tried a few commands and i'm thinking this has maybe fixed it. won't really know till I've used it for an extended period and see if it occurs at all. will let you know

what a stupid option though.. why would you want a delay? if I push enter I obviously want it to enter..

Share this post


Link to post
Share on other sites
jUNI0R

Have you been able to solve your problem yet? Would love to know what you may have done if you did solve it.

Share this post


Link to post
Share on other sites
masterfal

sorry about the slow reply. I think changing INPUTSEARCHDELAY may have helped a bit. still happens from time to time but definitely don't notice it as much anymore

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×