Jump to content
benhubel

Quickly entering commands tampers with the input

Recommended Posts

benhubel

When I enter a command quickly, it will sometimes duplicate my input into the command line.

 

Example: after selecting, if I press "m" for move, and quickly follow it with spacebar to confirm, I will be prompted to enter a base point. Sometimes, it will input an "m" in the command line in the place where I'm supposed to enter the point. I then have to backspace it before I can pick a point.

 

This is happening with other commands too. If I type "line" then follow the last letter quickly with a spacebar (or enter), it will ask me for the line startpoint, with the prompt immediately followed by "e" (which is the most recently input character).

It seems to happen more often if I have something already selected, and I have only seen it happen when a command is requesting a point. It isn't reliable, meaning it doesn't happen every time for any command.

I thought it was a problem with the keyboard because it recently had liquid spilled on it, but I tried plugging another one in and it also acted exactly the same. It's a new problem that I've never seen before today. I can't get it to happen in any other programs, so I don't think it's my input. It also happens when I open a new drawing. It doesn't happen, however, on any other computers here, only mine. I thought it might be a LISP interaction, but it continued even after disabling all custom routines. Despite being a minor issue, it's slowing me down dramatically.

 

For reference, I've attached an image of what's happening. I didn't enter the "c" in the command line, except previously when entering "sc". Has anybody ever had this happen before, and do you know of a possible cause/solution?

 

InputProblem.jpg

Share this post


Link to post
Share on other sites
ReMark

Are you using one hand or two? I tried to duplicate your problem and was only able to do so by using two hands and even that took multiple tries.

 

Have you been mucking around with any settings lately via Options or by editing the CUIx?

 

Have you tried resetting to the default value all settings?

 

Have you tried a Repair of the installation (not the same as an uninstall/reinstall)?

 

Have you tried plugging you keyboard into a different USB port?

Share this post


Link to post
Share on other sites
SLW210

Try a different keyboard.

Share this post


Link to post
Share on other sites
CyberAngel

Check your AUTOCOMPLETE settings. If Autocorrect and Autocomplete are on, you may get unintended results. Turning them off could resolve the issue.

Share this post


Link to post
Share on other sites
benhubel

Thanks guys for the suggestions. I haven't found the cause yet, but I'm bound to find it eventually.

 

Are you using one hand or two? I tried to duplicate your problem and was only able to do so by using two hands and even that took multiple tries.

 

Have you been mucking around with any settings lately via Options or by editing the CUIx?

 

Have you tried resetting to the default value all settings?

 

Have you tried a Repair of the installation (not the same as an uninstall/reinstall)?

 

Have you tried plugging you keyboard into a different USB port?

I only use one hand for the keyboard (the other for the mouse), but I'm used to pressing the buttons at almost the same using multiple fingers. Some commands do it more regularly than others, with "m" (move) triggering it nearly every time. It hardly ever happens on "r" (rotate) though.

I haven't recently touched any options that I don't use on a regular basis. I also haven't done any CUIx editing as far as I'm aware. I reset several settings one at a time, but I haven't found any culprits yet.

I just now tried a couple different usb ports, all of which did the same thing.

 

Try a different keyboard.

I have tried multiple other keyboards. I haven't noticed any difference with any of them.

 

Check your AUTOCOMPLETE settings. If Autocorrect and Autocomplete are on, you may get unintended results. Turning them off could resolve the issue.

My autocomplete delay time is set to 0.5 seconds. Just to troubleshoot, I tried turning off autocomplete altogether, but it reacts the same. I can't find anything related to autocorrect. Does that feature exist in Acad2012?

One note is that the commands are successfully executing instantly. The problem is that I'm getting input after the command has started.

Share this post


Link to post
Share on other sites
ReMark

What about plugging the keyboard into another USB port?

Share this post


Link to post
Share on other sites
benhubel
What about plugging the keyboard into another USB port?

 

Yeah, I've tried a few different usb ports, some from a hub and some directly into the back of the computer. No luck.

Share this post


Link to post
Share on other sites
ReMark

Have you tried a REPAIR of the installation?

Share this post


Link to post
Share on other sites
benhubel

I haven't tried a repair so far.

 

The problem stopped acting up just now, and I'm quite confused about why. I have the same drawing files open, I didn't make any changes to any settings since the last time it happened. The only thing I can think of that's different is room temperature. Every attempt to reproduce the problem is coming up unsuccessful. :? I'll test things again later if it acts up any more.

Share this post


Link to post
Share on other sites
ReMark

I fixed the problem using telepathy. I'll send you a bill tomorrow.:lol:

Share this post


Link to post
Share on other sites
benhubel
I fixed the problem using telepathy. I'll send you a bill tomorrow.:lol:

 

Much appreciated. I need to pick up that skill. Do you accept payment in bottle caps?

Share this post


Link to post
Share on other sites
ReMark

Bitcoin will do.

Share this post


Link to post
Share on other sites
AVS

Try increasing the value of the variable INPUTSEARCHDELAY

Share this post


Link to post
Share on other sites
ReMark
Try increasing the value of the variable INPUTSEARCHDELAY

 

Did you read post #9 by the OP?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×