Jump to content
SLW210

Difference in Materials applied ByLayer

Recommended Posts

SLW210

Maybe I am missing something.

 

My ByLayer assigned Materials are all showing as black in AutoCAD 2018, they were created in AutoCAD 2011 and show correctly in AutoCAD 2011.

 

I can individually assign the materials and they show correctly, so I know it isn't the lighting.

 

Maybe Graphics Card? I loaded different drivers.

 

Any clues to get them to work ByLayer without starting from scratch?

 

AutoCAD 2018 is the top set. Small example file is attached.

Bench Assembly Test 2018.jpg

Bench Assembly Test 2011.jpg

Yoke Test 2011.dwg

Share this post


Link to post
Share on other sites
Cad64

This issue could be due to the new rendering engine. Starting with 2016, Autocad is no longer using Mental Ray, so anything created in earlier versions may need some tweaking to get the materials, lighting, etc. looking right. See here: https://knowledge.autodesk.com/support/autocad/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/AutoCAD-Core/files/GUID-7DB68AE5-0E8C-4A3B-B921-58B1EB6482A9-htm.html

Share this post


Link to post
Share on other sites
GP_
...Starting with 2016, Autocad is no longer using Mental Ray...

 

Set RENDERENGINE system variable to 0

Share this post


Link to post
Share on other sites
SLW210
This issue could be due to the new rendering engine. Starting with 2016, Autocad is no longer using Mental Ray, so anything created in earlier versions may need some tweaking to get the materials, lighting, etc. looking right. See here: https://knowledge.autodesk.com/support/autocad/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/AutoCAD-Core/files/GUID-7DB68AE5-0E8C-4A3B-B921-58B1EB6482A9-htm.html

 

So far the only thing that is working is to remove the materials, -PURGE and then reapply them to ByLayer or just drop on each item, none of those settings have made any difference, maybe the Materials have been changed since AutoCAD 2011.

 

Set RENDERENGINE system variable to 0

 

No such SysVar in 2018, looks like 2016 was last release for that.

Share this post


Link to post
Share on other sites
Cad64
maybe the Materials have been changed since AutoCAD 2011.

 

That's probably true. Per the link I posted previously:

 

Note: Materials originally created for use with the legacy renderer might need to be updated when used with the current renderer. For example, a pure white material can result in a rendered image being too bright.

Share this post


Link to post
Share on other sites
SLW210

The Materials are there in the list, but it seems they are just all black in color, going forward shouldn't be a problem and I can just change anything old as needed if I have to go back.

 

Most of the time Hidden works for a good visual for the shop. I was just hoping I had missed a setting somewhere.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×