Jump to content
MastroLube

Hatch multiple objects that overlap

Recommended Posts

Hi guys,

I've to hatch multiple objects that sometimes overlap. I don't want that the hatch get removed if the islands are in common.. currently I'm ending the command and start again to avoid that but maybe there is a better way. Any advice?

 

giphy.gif

 

Thanks for your help!

 

Dennis

Share this post


Link to post
Share on other sites

I just use a crossing window and pick everything in one feel swoop and it works for me. The only downside, if you want to call it that, is the square in the corner ends up getting hatched twice. Its as though you hatched each long rectangle separately then overlapped them. See for yourself...

 

Hatch_me.jpg

Share this post


Link to post
Share on other sites

Just to be clear, I did not pick inside each individual area. I used a crossing window that passed through both objects at the same time.

Share this post


Link to post
Share on other sites
See this thread from 2011.

 

Autodesk has had seven years to address this issue. Oh wait, they don't do issues.

 

Works just like ReMark shows in AutoCAD 2018, not sure what release, but it is fixed now.

Share this post


Link to post
Share on other sites

I've found that Associative hatches react horribly to most situations where two or more objects are to be run through the "hatch association algorithm". (whatever happens in there is dark energy.)

 

1 use non associated separate hatches exclusively, with fewer issues.

 

It still won't hatch those overlapping corners all the time unless the rectangles are selected separately, and I have found modifying the island detection setting often to be ineffective.

Share this post


Link to post
Share on other sites

I guess I wasn't clear enough. I did not select the rectangles separately.

 

Here's another example that I tested a half dozen times and got the same results each time. Everything got hatched even the areas (the squares) that were overlapping using one crossing window for making the selection. The square areas (four) got hatched twice.

 

HatchitTime.jpg

Share this post


Link to post
Share on other sites

Thanks for your help!

 

I'll use separate hatches and select all the rectangles and don't care about overlapping hatch.. Was wondering if I could have only 1 hatch for all :D

 

Thank you guys! :)

 

Dennis

Share this post


Link to post
Share on other sites

As noted in the thread I referenced, the only sure way to get a clean hatch is to draw one border that contains every space. Or you can upgrade.

Share this post


Link to post
Share on other sites

Yes it could be a solution!

 

Anyway with upgrade you mean that autocad 2018 allow to have one hatch for all these object picking objects and not points inside?

 

Thanks!

Share this post


Link to post
Share on other sites

As SLW points out, the "feature" discussed here was fixed in some version between 2015 and 2018. In other words, if you upgrade to the current version, you can select overlapping objects and hatch all of the interior spaces. In other other words, AutoCAD 2018 behaves the way you expected it to in your original post.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×