Jump to content

Zoom to limits


Recommended Posts

therock005

There are cases where i set the limits of my drawing, which are smaller than what ive drafted. when i want to do zoom extents i want it to be where ive set my limits, not object that surpass them. How can i set that

Link to post
Share on other sites
therock005

Ok nice alternative. But whats the use of drawing limits though if they are inferior to the extents. From an academic standpoitn im asking

Link to post
Share on other sites
steven-g

Limits and Extents are 2 different animals, Limits are only there to work with the Grid and can also be used to stop you being able to enter points outside of the Limits if you turn Limits on. Zoom Extents will Zoom to include all objects you have drawn.

Limits isn't broken it just has no relationship to Zoom, as another alternative to what you are trying to do you could draw a rectangle around your "Limits" place it on the defpoints layer if you don't want it to plot and then Zoom Object would work. And as an addition to that the option Zoom-Object will also allow you to use a Group as the Object, so making your Limits rectangle a Named Group would work in a similar way.

Link to post
Share on other sites
steven-g

Read the help files, that usually gives a pretty good indication of what is what, sometimes there are ways to achieve similar results with different commands, and on very rare occasions there are a few hidden extras, but as it stands the Limits command is about setting the Grid display size and nothing to do with the Zoom command. So with what you are describing there are methods to achieve that but they don't include the Limits options.

Link to post
Share on other sites

You could do 2 little lisps set mywindow and zoommywindow

 

(defun c:zx ( / )
(if (= zwpt1 nil)(c:zs))
(command "zoom" "W" zwpt1 zwpt2)
)

(defun c:zs ( / )
(setq zwpt1 (getpoint "pick 1st window pt"))
(setq zwpt2  (getpoint "pick 2nd window pt"))
(command "zoom" "W" zwpt1 zwpt2)
)

Link to post
Share on other sites

If no objects are in the drawing, then Zoom, All, will use limits.

If there are objects in the drawing, but within the limits, Zoom will use limits setting.

With objects beyond the limits, then Zoom, All will include everything.

No matter where objects exists in the drawing, Zoom, Extents will just show you the extents of the objects.

Link to post
Share on other sites

If I remember correctly, "Limits" used to be an option within the "Zoom" command. But is not present now. Not sure when removed.

Link to post
Share on other sites
If I remember correctly, "Limits" used to be an option within the "Zoom" command. But is not present now. Not sure when removed.

 

I don't think that is correct. I have manuals back to 2.0 and it is not in there. Possible it was in the 1.X release I suppose.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...