Jump to content

Newbie questions


Recommended Posts

plaans.dwg

 

Here I have attached a dwg of plot im working on.

 

I finally want to figure out and understand a couple of things.

 

1. How do I set that everything.. EVERYTHING is in mm ? Currently the dwgunits are set to mm, and to my understanding when I pick line and set it to 1000 , it will draw a line of 1000mm. However when I write command PE, and take width the number I have to set in, is not in mm , right?

 

same goes for dimension format. The defaults are 0.180 for example, which is in no way in mm. How do I know in what units does it want me to write it ? How do I set it to mm.

 

2. Ive been using polyline width to change line thickness, because I never got the lineweight working. Perhaps someone can chech to dwg, I have set all the setttings for it to display, but it wont. No matter what I try.

 

3. How do I get all my lines etc in mm , but also have dimension numbers and text in mm, but without it scaling together with the rest of the plot ? ( it would be super tiny )

Link to post
Share on other sites

First and most important, the drawing is definitely in millimeters. Learn to use the command -DWGUNITS, (see the leading hyphen).

 

When drawing in 2D do not use THICKNESS, that is how "tall" the line is vertically, on the "Z" axis.

 

The object properties Line WIDTH and GLOBAL WIDTH are for special creative purposes concerning how wide one needs particular polylines. They are fun to use, one can even taper a polyline along its own length, but right now control line weight and color using layer properties instead of object properties. If you want a line to be 0.15mm wide, put it on a layer with that property, in general.

 

Your lineweights are set to decimal fractions of a millimeter as they should be.

 

Don't worry about not being able to see the lineweight in modelspace with lines this thin, the lines won't be as wide as a screen pixel unless you go to OPTIONS > USER PREFERENCES > LINEWEIGHT SETTINGS, then adjust the lineweight display slide switch all the way towards the maximum position until you can see them.

 

Lineweight is easier to see on paper, and in paperspace.

 

In paperspace lineweights are displayed at their actual width(lineweight), if you have the display turned on.

 

On paper your objects are scaled to fit on the paper, but the lineweights are not scaled, unless you check that box on the layout manager, if you want to, but at 1:100 the lineweight differences will probably again disappear. Then your lines may be narrower than your printer can print an ink droplet.

 

Change all your object properties, including lineweight to BY LAYER, including your dimensions (by using the dimension style editor). Place all your drawing objects you want to be differentiated on a separate layer.

 

Line weight and color should be controlled by layer properties.

 

You will need to apply some changes to your dimensions. Everything is way too small to be seen in modelspace. I adjusted the text height to actually be visible in modelspace.

 

You should avoid modifying the STANDARD dimension, text, and leader styles. You may need them in the future to start another STYLE from.

 

Make a NEW one of each style starting with STANDARD as a beginning point

 

I modified your drawing to work a little bit better. It is not perfect, but a fair starting point.

 

I added two more layers, "2", and "Dimensions", applied color and lineweight to layers 1, 2, & Dimensions and moved all objects to those layers. The dimensions were moved to the Dimensions layer.

 

I changed all the individual object properties of your dimensions to BY LAYER.

 

I saved a copy of the drawing here, to 2013 format so you could open it.

plaans 2013 version.dwg

Link to post
Share on other sites

Thank you, Dana, for the explaination. I should , from now on, use layers to seperate the styles. Will try it out myself now too.

 

But also still two of my questions remained unanswered. If my drawing is in milimeters. then there is no way that the default number 0.180 means mm. Or when I change it to 350 to be visible, that its 350 mm. But then again, if the text is relative to the drawing it self then it makes sense , I guess? What units does it take when I write them in the dimension format dialog? And how can I make the text, dimension numbers etc independant on the plot itself ? ( like, I want to set it to be 5mm on paper, not in plot ( real life ) )

Link to post
Share on other sites

Are you using one of the metric drawing templates that ships with Autocad? If not, that would be a good place to start because your units will already be set for metric and there will be a dimension style already set up that you can use or modify.

Link to post
Share on other sites
Are you using one of the metric drawing templates that ships with Autocad? If not, that would be a good place to start because your units will already be set for metric and there will be a dimension style already set up that you can use or modify.

 

Yes, I am using the one that comes with it

Link to post
Share on other sites

If you're using the metric template and you draw a line with a length of 10, your line should be 10mm long. If you type PE and change the width to 2 then your polyline should be 2mm wide.

 

For dimension text, you want to set the text height depending on your viewport scale. I don't work in metric, so I'm not familiar with viewport scale settings, but after running some tests, I believe that if your viewport is set at scale 1:1 then your dimension text height would be 2.5. If your viewport is set at 2:1 then your dimension text height would be 5.0, etc.

 

By the way, I can't open your drawing because it was created with a newer version of Autocad. I'm using 2014. When uploading CAD files to the forum, you should save back to an earlier version, like 2010, so those of us using older versions of Autocad can open your files.

Link to post
Share on other sites
tzframpton
By the way, I can't open your drawing because it was created with a newer version of Autocad. I'm using 2014. When uploading CAD files to the forum, you should save back to an earlier version, like 2010, so those of us using older versions of Autocad can open your files.
You're lagging behind five version years so everyone else has to help you? C'mon now!! lol

 

https://www.autodesk.com/products/dwg

 

TrueView converts versions for you. Get it while it's hot!!

 

;)

 

-TZ

Link to post
Share on other sites
You're lagging behind five version years so everyone else has to help you? C'mon now!! lol

 

TrueView converts versions for you. Get it while it's hot!!

 

Hey man, it's about time somebody helps me for once. Lol

 

I get Autocad from my client, so I work with the version they give me. If I ever have to buy my own license I'll be going with Bricscad, but that's a whole other subject.

 

I have TrueView installed but it's an older version. I guess I should probably upgrade. :oops:

Link to post
Share on other sites
...then there is no way that the default number 0.180 means mm. Or when I change it to 350 to be visible, that its 350 mm.
Which default? Lineweight? If your drawing units are millimeters, then 0.180 lineweight means 0.180mm. (:shock:UNLESS you might have selected decimal inches for your available line weight list.) I know one may select either when working from an Imperial template (acad.dwt), but I am not sure you can do that using a metric template (acadiso.dwt).

 

OK, in modelspace line work is always displayed at ONE PIXEL WIDE except for two conditions. Condition one is if you apply a width property greater than zero to a polyline. Condition two is if you go to the line weight dialog from the OPTIONS dialog as I mentioned before, and adjust the slide switch for lineweight display until some differentiation can be discerned once the Display Lineweights toggle on the task bar is turned on.

 

Sometimes, an On board graphics processor will refuse to display lineweights properly or at all. Try turning hardware acceleration on or off, opposite what you have now anyway, and see if it makes a difference. Turning it off, can degrade overall display resolution inside of AutoCad.

 

Lineweight display in modelspace is not actual size, it is only a percentage of differentiation. In other words, some are thick, and some are not, that's all. The lineweight apparent width in modelspace does not change with zoom level.

 

Now in Paperspace, once the lineweight display is adjusted and the display toggle is turned on, lines are displayed close to the actual width they will be plotted except that any lines smaller than one screen pixel will be displayed at one pixel wide. Apparent line width does change with zoom level in paperspace.

 

Keep in mind that there is not a lot of visible difference in lineweight between 0.55mm and 0.50mm, even on paper.

But then again, if the text is relative to the drawing it self then it makes sense , I guess?
Nope, neither text nor dimensions are relative to anything unless they are annotative, and that is another whole ball of wax. What you have are dimensions and text that will be real world height only in modelspace, or at 1:1 scale, exactly as they are set up in the style editor.

 

Lets say your viewport will be scaled at 1:100 which is 1 paperspace unit = 100 modelspace units, or 1mm = 100mm, and you want your dims and text to be printed at 3mm, and you only have one dimension style with a 3mm text height.

 

That dimension style will only print at 3mm at 1:1 scale. At 1:100 scale it prints at 0.030mm.

 

This means that you have to set up another dimension style with a text height 100 times bigger than what you want for a printed text height.

 

For 1:50 scale the dims have to be 50 times larger than 3mm, and so on.

 

That issue is why somebody invented annotative scaling, where ONE dimension style can adapt to any scale in any viewport, but there is somewhat of a learning curve to annotative scaling.

 

That multiple dimension style issue is also the reason many drafters put all their dimensions in paperspace. Paperspace dimensions are pretty simple. You can use your 3mm (1:1) dimensions exclusively over any viewport in paperspace without having to worry about the scale, even a viewport set to no particular scale from the standard scale list. The only thing is, if you miss a snap point ever so slightly, the dimension will read as paperspace distance, how long the distance really is on paper.

Edited by Dana W
Link to post
Share on other sites
Which default? Lineweight? If your drawing units are millimeters, then 0.180 lineweight means 0.180mm. (:shock:UNLESS you might have selected decimal inches for your available line weight list.) I know one may select either when working from an Imperial template (acad.dwt), but I am not sure you can do that using a metric template (acadiso.dwt).

 

OK, in modelspace line work is always displayed at ONE PIXEL WIDE except for two conditions. Condition one is if you apply a width property greater than zero to a polyline. Condition two is if you go to the line weight dialog from the OPTIONS dialog as I mentioned before, and adjust the slide switch for lineweight display until some differentiation can be discerned once the Display Lineweights toggle on the task bar is turned on.

 

Sometimes, an On board graphics processor will refuse to display lineweights properly or at all. Try turning hardware acceleration on or off, opposite what you have now anyway, and see if it makes a difference. Turning it off, can degrade overall display resolution inside of AutoCad.

 

Lineweight display in modelspace is not actual size, it is only a percentage of differentiation. In other words, some are thick, and some are not, that's all. The lineweight apparent width in modelspace does not change with zoom level.

 

Now in Paperspace, once the lineweight display is adjusted and the display toggle is turned on, lines are displayed close to the actual width they will be plotted except that any lines smaller than one screen pixel will be displayed at one pixel wide. Apparent line width does change with zoom level in paperspace.

 

Keep in mind that there is not a lot of visible difference in lineweight between 0.55mm and 0.50mm, even on paper.

Nope, neither text nor dimensions are relative to anything unless they are annotative, and that is another whole ball of wax. What you have are dimensions and text that will be real world height only in modelspace, or at 1:1 scale, exactly as they are set up in the style editor.

 

Lets say your viewport will be scaled at 1:100 which is 1 paperspace unit = 100 modelspace units, or 1mm = 100mm, and you want your dims and text to be printed at 3mm, and you only have one dimension style with a 3mm text height.

 

That dimension style will only print at 3mm at 1:1 scale. At 1:100 scale it prints at 0.030mm.

 

This means that you have to set up another dimension style with a text height 100 times bigger than what you want for a printed text height.

 

For 1:50 scale the dims have to be 50 times larger than 3mm, and so on.

 

That issue is why somebody invented annotative scaling, where ONE dimension style can adapt to any scale in any viewport, but there is somewhat of a learning curve to annotative scaling.

 

That multiple dimension style issue is also the reason many drafters put all their dimensions in paperspace. Paperspace dimensions are pretty simple. You can use your 3mm (1:1) dimensions exclusively over any viewport in paperspace without having to worry about the scale, even a viewport set to no particular scale from the standard scale list. The only thing is, if you miss a snap point ever so slightly, the dimension will read as paperspace distance, how long the distance really is on paper.

 

 

Thanks! Got a bit clearer picture. But now.. I pick multiline text.. and to get 5mm text in paper I have to write 500 units. Its just so confusing that each place units are different. Why is it 500 now ? Im still on 1:100

Link to post
Share on other sites
Thanks! Got a bit clearer picture. But now.. I pick multiline text.. and to get 5mm text in paper I have to write 500 units. Its just so confusing that each place units are different. Why is it 500 now ? Im still on 1:100
Your paperspace scale ratio is 1 paperspace unit = 100 modelspace units. Both model & paperspace are using millimeters for units.

 

Your 1:100 viewport will display an image of modelspace 100 times smaller than full size, making your text once again 5mm tall on paper if it is 500mm tall in modelspace.

 

If you want the text 5mm tall in a viewport scaled at 1:100. then the text has to be 100 times bigger in modelspace. Text in modelspace that is 5mm tall will be displayed 100 times smaller in the 1:100 viewport, or 0.05mm.:shock:

Side note. That scale selection button on the taskbar in modelspace only affects annotative objects. It doesn't change anything else, period.

 

Lets say for example, that your 5mm text was set as Annotative when you set up the text style, then you put some 5mm text in modelspace using that text style.

 

Now one would hit that scale button down on the taskbar and change it to 1:100. Then you would select the text you just put in, click the Add Current Scale button on the contextual ANNOTATION ribbon. suddenly your 5mm text jumps to 500mm high.

 

Now when you go set up your 1:100 viewport, this same text will automatically show up in the viewport at 5mm high. You can now go back to modelspace, change the scale back to 1:1, and the same text object will automatically change back to 5mm high without affecting that text object's appearance in the viewport.

 

The thing about annotative objects is that they will automatically scale themselves to fit the current scale either in modelspace or paperspace, if that particular current scale is assigned to that particular annotative object.

 

There is a lot more to annotative objects, but I think for now that is enough about them.

Link to post
Share on other sites
You're lagging behind five version years so everyone else has to help you? C'mon now!! lol

 

;)

 

-TZ

 

The only ones that have to help, are those who have come here looking for help. :|

Help us to help you. :beer:

 

Late to the party.

Good job Dana. :beer:

Link to post
Share on other sites

Wait for the next step about using layouts to print. A real quick metric set up.

 

Had a quick look at your layout and the following suggestions

1 It appears set up for A3 so ok plot at 1:1

2 put a outer rectang 420x297 on a no plot layer

3 move your inner and outter so lower left of inner is at 0,0 makes life much easier for automation stuff. Then use window and pick lower left and top right and use center.

4 -toolbar Viewports Show, pops viewport toolbar option, when you double click inside viewport a number appears such as when zoom Extents you can directly type a number in the viewports toolbar box setting the scale no thinking, PRAISE METRIC. So for the model object in your dwg zoom E then look at number and type 0.01 it will set to 1:100 again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...