Jump to content
Nivinem

XREF Overlapping

Recommended Posts

Nivinem

Hello All,

 

In our method of working,  we create multiple dwg files which are later added as XREF to a base drawing.

 

For eg.,   1.dwg ,  2.dwg , 3.dwg  is created and On Base.dwg , the three aforementioned dwg files are attached as Xref.

 

I would like to know if there is an option to have the insertion point of Xrefs apart from each other when attached.

 

Regards.

 

 

 

Share this post


Link to post
Share on other sites
Cad64

When you insert an xref, there is an option in the "Attach External Reference" dialog where you can set the insertion point, or you can just grab the xref and move it after insertion, but I wouldn't recommend doing either of these things. It's bad practice to move xrefs, especially if they contain survey information or items that need to line up with other xrefs. You're setting yourself up for problems if you get into the habit of moving xrefs.

 

If it were me, and I needed to see each xref without them overlapping, I would insert the xrefs and then set up layouts in paper space with viewports for each xref. Within each viewport I would turn off the xrefs I don't want to see. So in the case of your example, I would have 3 viewports, one for each xref.

 

 

  • Confused 1

Share this post


Link to post
Share on other sites
CyberAngel

You can set the system variable INSBASE to a coordinate. The default is (0,0,0). When you later xref that drawing, it uses that location. This scheme may take a little adjustment if you don't have one in place, but it should handle your situation.

  • Thanks 1

Share this post


Link to post
Share on other sites
Nivinem

@CyberAngel

I am not sure what the final location when I set INSBASE. We are actually nesting multiple patterns DWG to a single base drawing.

 

@Cad64

Please could you provide some examples how you do it with viewports

Edited by Nivinem

Share this post


Link to post
Share on other sites
Cad64
54 minutes ago, Nivinem said:

 

@Cad64

Please could you provide some examples how you do it with viewports

 

Load the xrefs into your drawing.

Switch to a Layout tab and create a Viewport.

Double click inside the viewport to activate it.

Open your Layers palette and freeze the xref layers you don't want to see.

 

I don't know what type of work you do, or what kind of files you're working with or anything else, but using viewports in layouts is how I would do this.

Share this post


Link to post
Share on other sites
addysmith97

You can unload the external reference if you want to check your progress and see if the Walls being added cleanup acceptably without the external reference present, then reload the external reference to continue tracing.If the external reference file will remain in the file for an extended period and the cleanup errors bother you, you can do one of two things:

  • Disable cleanup between external references and the host drawing:  Open the file you are externally referencing, and edit the Wall Cleanup Group Definition(s) you are using.  On the Manage ribbon tab, on the Style & Display panel, select the Style Manager tool.  Expand the Architectural Objects node below that drawing file, and the Wall Cleanup Group Definitions node as well.  Select each definition in turn and, on the Design Rules tab, uncheck the Allow Wall Cleanup between host and Xref drawings toggle.  OK back out to the drawing, save the file and then reload it in the upper floor file.  The Walls in that file should no longer be trying to clean up with the Walls in the externally referenced file.
  • Create a different Wall Cleanup Group Definition in the host drawing (upper floor), and assign that to the Walls in the upper floor drawing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...